WebDAV to NextCloud
#1
Hi,
I would like to ask you for help, I have tried numerous combinations nothing worked.
How do you connect to nextcloud server using secured WebDAV?
Nextcloud says this is my WebDAV link: https://servername.sk/remote.php/webdav/

On windows I made my NextCloud a network drive via: 
net use Z: https://servername.sk/remote.php/dav/files/USERNAME/ /user:USERNAME 
(USERNAME replaced with my real username)

When I open the following address in Chrome
https://USERNAME:[email protected]/remote.php/dav/files/USERNAME/
it says: "This is the WebDAV interface. It can only be accessed by WebDAV clients such as the Nextcloud desktop sync client."

Yet I am not able to force Kodi to work with my NextCloud content.
What values should I set for: protocol, address, remote path and port ?

Thank you very very much, I must be doing some stupid mistake.
Reply
#2
Image
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#3
GREAT !!! Thanks a lot for your time Ronie, works like a charm.
Reply
#4
I doesn't work for me. It keeps saying «unable to connect to server» although my server works fine. I tried with the url given by my nextcloud instance «https://myserver.tld/nextcloud/remote.php/webdav/» but it still not working.
Librelec 8.2.1 with kodi 17.6 on RPI 3 kernel 4.9.59.
Reply
#5
Try to do it without the https:// in it.
Type it exactly as shown in the picture. It worked for me.
Just type the following:

servername.sk without the https:// strings
remote.php/dav/files/username  without the https:// strings

I simply typed remote.php/dav and that worked for me, it will simply show all the files / maps that are included.

Hope this helps for you.
Reply
#6
@ronie 
Thank you. This worked also for me.
Reply
#7
Hi everyone!

Same as the OP, I want to use Kodi on my Windows 10 machine to access media libraries hosted on my NextCloud using WebDAV.

I can access the media libraries in Windows without a problem. I can browse and download the content.

I've set up the network location in Kodi as follows:
  • Protocol: Web server directory (HTTPS)
  • Server address: servername.duckdns.org
  • Remote path: nextcloud/remote.php/dav/files/username/
  • Port: 443
Kodi accepts it, but the new network location is empty.

Here is the link to log extract.

Is there anything else I need to set up in order to be able to access my media through WebDAV?
Reply
#8
I found out the issue - I was using the wrong protocol Smile

Please disregard my previous post, Kodi is working just fine with WebDAV.
Reply
#9
(2019-01-11, 02:52)OvoNemaSmisla Wrote: I found out the issue - I was using the wrong protocol Smile

Please disregard my previous post, Kodi is working just fine with WebDAV.
 Hi.

What do you mean that you where using the wrong protocol?

I have the same issue, I configured like in the picture, I do not get any error but the location does not contain anything.
Reply
#10
I chose the wrong protocol. It should be like this if you are using HTTPS:
Image
Have you checked if you can access the content of your WebDAV by any other means (e.g. Explorer)?
Reply
#11
Also struggling connecting.  Followed the above options with no success so far for hours.
Even tried making another user in NextcloudPi and tried using its credentials in the connection string as suggested by user OliverV in this thread 
https://help.nextcloud.com/t/how-to-set-...-ssh/47598
Reply
#12
Fist step would be to make sure WebDAV is working correctly by mapping it as a network drive in windows.

If successful, you should be able to browse the content of your WebDAV share on your NextCloud.

Here is a tutorial how to do it, it's quite simple. If you are a Windows user, look for the Accessing files using Microsoft Windows section.

Hope this helps.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
WebDAV to NextCloud00