• 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 36
Broken Amazon Prime Video Add-on [CLOSED]
#46
I have just bought Deadpool 2 via Prime video, and now watching it via this addon (which is third party!) it is playing in HD and in surround.

Kudos to all the devs to making this possible. I never thought that this would happen!

*yes... I’m bouncing off the walls I’m so pleased!*
Server: Ubuntu Server 22TB HDD running SAMBA
Kodi: 4 Raspberry Pi 3 running Libreelec -  on the main PC - running Linux Mint
My Setup thread |
#47
Hello

Using this addon I have access to German Amazon Prime content through my UK Amazon  Prime account

1. The Win 10 installation goes fine. The installation sticky says use the Netflix tepository. Should this be use the sandeman repository?

2. I can logon to my UK Prime account and get access to German content

3. I can play a German language film through Kodi.

4. I can't work out how to close the add-on. I have to crash Kodi to end the Amazon Prime connection.

5. Ok, I have just seen that the Prime output is being played in a full screen Edge browser window. Sorry for a naive question but how do I close this without crashing Kodi?

Regards,

Clive
#48
(2018-09-08, 11:40)Crlong Wrote: Hello

Using this addon I have access to German Amazon Prime content through my UK Amazon  Prime account

1. The Win 10 installation goes fine. The installation sticky says use the Netflix tepository. Should this be use the sandeman repository?

2. I can logon to my UK Prime account and get access to German content

3. I can play a German language film through Kodi.

4. I can't work out how to close the add-on. I have to crash Kodi to end the Amazon Prime connection.

5. Ok, I have just seen that the Prime output is being played in a full screen Edge browser window. Sorry for a naive question but how do I close this without crashing Kodi?

Regards,

Clive
You need to use the Kodi nightlies and the inputstream Add-on to play the video. Then it will use the normal Kodi video player with all normal functioning keys.
#49
Hi

Thanks for the quick reply.

I followed the instructions at the beginning of this thread. I installed Kodi v18.0 nightly on Windows.

I then installed Amazon VOD add-on.

I switched output to "Instream"

I input my Amazon userid and password in the Addon configuration.

It works!

I can now play Amazon English language videos through Kodi using Kodi controls.


Thanks

Clive
#50
I'm a concerned user here.  I have a Prime membership, but don't want to accidentally purchase a movie or TV show that isn't included free with my account.  Will this addon alert me if I'm selecting a video that would require a purchase, or will it just automatically buy it?
#51
Hi, paid content is labeled in another color (orange) in the amazon vod app to distinguish it from the already included 'free' content. Also i wasn't able to purchase new content in the app, it just says that 'the content was not purchased' and then aborts the selection.
Hope this helps you!
#52
Wow thanks for letting me know.  Too bad in-app purchasing doesn't work.  I could see that being a nice perk if somebody wanted it.
#53
I think that would be a killer programing wise since that core function isn't implemented at all into native kodi - tbh i never did miss it, luv the amazon vod app as it is Smile
#54
Hi, 

I'm new to Kodi and this is my first post here. I've put Linux Mint into an old laptop I have and have installed Kodi on it, and all seems to be very sweet indeed for many things, but not for running videos from Amazon Prime. 

I've installed the Amazon VOD plugin from the Sandeman79 zip file. I have set the playback output to 'Inputstream' and enabled Inputstream.

I've turned off DRM checking. 

I have logged in using my (UK) Amazon account. I can see lists of videos, search them and so on.

However whenever I try to play a video from Amazon I get the two concentric circles of blue segments, which fade and then appear again and then nothing happens. If I try do play lots of videos I am told that Amazon is unable to play the video but no further progress. 

An entire log from Kodi is here: https://pastebin.com/MdV3Vp5Y . (Note: this log corresponds to starting Kodi, trying and failing to run an Amazon video, then closing Kodi) 

My suspicion is that the relevant section is thus; 

16:56:02.351 T:139788837451520  NOTICE: Creating InputStream
16:56:03.558 T:139788837451520   ERROR: AddOnLog: InputStream Adaptive: Unable to find license;hdcpEnforcementResolutionPixels in JSON string
16:56:03.558 T:139788837451520   ERROR: AddOnLog: InputStream Adaptive: License update not successful (no keys)
16:56:03.558 T:139788837451520   ERROR: AddOnLog: InputStream Adaptive: Initialize failed (SingleSampleDecrypter)
16:56:03.559 T:139788837451520   ERROR: CVideoPlayer::OpenInputStream - error opening [plugin://plugin.video.amazon-test/?asin=B01M6Z56SM&mode=PlayVideo&adult=0&name=1+-+The+Holy+Trinity&trailer=0&selbitrate=0]

This looks like I need a licence of some kind to run InputStream, and googling for this gives a number of possible solutions. If anyone can help then I'd be grateful. If I need to give more info then please let me know. 


Thanks.
#55
Check you have an HDCP connection (On Nvidia Shield for example you go to android settings and it should show HDCP status), or try turning on the HDCP ignore option in the inputstream addon settings.

@peak3d may be able to explain some more on that message its not entirely clear to the end user the problem.
#56
(2018-09-23, 18:11)zcacogp Wrote: Hi, 

16:56:03.558 T:139788837451520   ERROR: AddOnLog: InputStream Adaptive: Unable to find license;hdcpEnforcementResolutionPixels in JSON string

Thanks.

There is a [hex].respone file in your .kodi/cdm/ folder, this is the response of the widevine licensing request.
Pls. open it in a editor / or paste the file here.
#57
Gus, 

Thanks for the answers. 

Docwra, turning off the HDCP checking in the settings didn't make an difference. I am using Kodi on a Linux Mint machine and don't know how to check if I have a HDCP connection. 

Peak3d, the file is called EDEF8BA9-79D6-4ACE-A3C8-27DCD51D21ED.response and the content is like this: 

{"errorsByResource":{"Widevine2License":{"errorCode":"PRS.InvalidRequest","message":"Cannot complete request.","type":"PRSInvalidRequestException"}},"returnedTitleRendition":{"asin":"B01M8KND5M","audioQuality":"Stereo","audioTrackId":"all","contentId":"amzn1.dv.vcid.97e2652f-d276-4d9d-aa09-d71df2dfe8d6","selectedEntitlement":{"consumptionExpiration":"1537982397000","entitlementType":"PRIME_SUBSCRIPTION","grantedByCustomerId":"A2KMCL9WPPV8SP"},"titleId":"B01M8KND5M","videoMaterialType":"Feature","videoQuality":"HD"}}

Thanks again.
#58
Thanks docwra! Great addon. 

The only thing keeping me from using my amazon video was that I had to use my browser. Now I have access to so much more content within KODI.

One question, how do we get subtitle support for this? I went into the menu and have subtitles enabled but I am unable to download any. Please advise.
#59
hi ... working well ,, but i cann't download subtitel manualy.....
#60
Does this work in the US and is there a way to change this to english? My install is apparently in german... and I'm guess the reason it fails is because it's connecting to amazon.de
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 36

Logout Mark Read Team Forum Stats Members Help
Amazon Prime Video Add-on [CLOSED]4
This forum uses Lukasz Tkacz MyBB addons.