20 Nov 2019 - TVDB Scraper v3.2.0 is now available which reinstates scraping. TVDB are still in the process of fixing a number of bugs so there may still be further breakages. See this post. 2901570 (post)

Android Can't install Kodi on new Android TV
#16
OK, I just found the RIGHT thread about this problem. Indeed, it is not the SOC. It is that if you rename the package i is working fine. I now have a Working KODI 18 BETA 5 on my KD-65AF9.

 Here the thread with the solution. 336272 (thread)

I have some contacts inside SONY. So I did sent them this info. See if they will solve it.
Reply
#17
(2018-11-18, 13:45)sukkel Wrote: It is that if you rename the package it is working fine. I now have a Working KODI 18 BETA 5
So... Sony actively blocks the installation of Kodi on their TVs?! WTH is that all about?

(2018-11-18, 13:45)sukkel Wrote: I have some contacts inside SONY. So I did sent them this info. See if they will solve it.
Or they'll break it with their next Sony TV firmware. It's not the company that I will buy hardware from anytime soon if I can help it.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#18
Hi- I recently purchased the Hisense 55H9E Plus which comes with the Android TV OS. I am having some issues installing the Kodi app. Going through the Google Play store on the TV, I get a 506 error. I have tried clearing the cache etc, but no success. Alternatively, I have gone through the Google Play store on my computer and click install to the Hisense TV device. It shows that it installed and I do see the icon on the TV. However, when trying to open it, it never opens. I tried both the v17 and v18.

Any ideas? I've tried loading the downloaded Kodi directly from the site loading it on a USB and installing it that way. However, I do not seem to see/have a file browser on the TV. Could I download a file browser?

Any recommendations would be incredibly helpful.

ps: The TV is running an Android 8.0 system and I can install other apps without any problems.
Reply
#19
Looks like recent releases of the Android TV Oreo OS running on 2019 Sony - Master Series - Smart TV's and now the Android TV - HiSense have implemented a App install "Blacklist".

Kodi devs will respond with they do not care - legitimately because there is nothing they can do or should do to the standard release of Kodi.

I've only even seen this previously with the Foxtel Now Pay TV box in Australia, actively blocking Kodi from being installed with it's blacklist.

You can change the Kodi App Signature (org.xbmc.kodi), during compiling to work around such Blacklist issues, and sideload that specific version of Kodi using the Xplore App and a USB stick.

I've done just that so I can test Kodi Leia RC without conflicting with the previously installed Kodi Krypton, such a Kodi Leia RC2 is this one:
Kodiapp-armeabi-v7a-181127-Leia RC2.apk

I do not intend to provide individual Android TV Oreo - Smart TV support, but will compile another release when Leia reaches final status.

Reply
#20
THANK YOU so much! This solution worked. As you mentioned, it would be great if you could post the new apk when the final version is released.
Reply
#21
Thumbs Up 
Just bought a Sony 65 AF9 and eagerly tried to install KODI. Fell into this thread.

Thank you  wrxtasy for the solution!
Reply
#22
You should all go complain to Sony
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
#23
And Google for even allowing these Android TV Oreo vendors to implement an Apps install blacklist on a supposed "Open" OS platform.

Reply
#24
Thanks for providing this apk. I tried it in my Firestick 4k  to play around with it without ruining my Krypton install  However I can't find inputstream adaptive in your build. Is there any intended reason for this? Thanks in advance
Reply
#25
Look in the kodi repo.
Reply
#26
Yes. It's where I'm looking. The videoplayer inputstream just has the RTMP to choose. I also installed this Leia version in my Galaxy S9 mobile and I get the same problem with videoplayer inputstream absent. Is there the same issue with the normal rc2 version? I don't want to install that because of my existing running version. Anyways, sorry for pestering the thread with this, I gave up and installed the latest rc3 and it works fine so all good.
Reply
#27
Sorry, I was under the impression this was now in the repo (it is in windows builds).
Reply
#28
this work for me on my 2018 Hisense TV that was also blocking all possible ways of installing, any chance we could get an RC3 update?
Reply
#29
See THIS thread (click):

Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Can't install Kodi on new Android TV00