Leia / alpha2 - playlistasfolders is now ignored, is that on purpose?
#1
Noticed that as of alpha2 (coming from alpha1) this setting in advancedsettings.xml is ignored, or otherwise not working (not 'smart' playlists).   The impact is pretty high for me, I use various automations and external triggers to launch M3U playlists every day (via kodi-send --action=PlayMedia(/path/to/playlists/foo.m3u) , and they all failed after my weekly apt upgrade ran overnight.   In the GUI, the problem was apparent - selecting a playlist no longer plays, it, rather it opens a virtual directory of the playlist items. 

I tried various (non smart) playlist formats without any change in behavior.  I created a new advancedsettings.xml with only the playlistasfolders (false) property present to exclude a potential bad advancedsettings file, or something being deprecated, though the debug log (I'm on Xenial) shows the advanced file being read and loaded without error. 

The wiki still shows playlistasfolders as being a valid selection, and I checked commit statements for alpha2 at Github to see if this was planned, didn't see anything.  But a forum search did turn up this statement  from dev heavyweight @jmarshall a couple years ago regards the property:
Quote:Smart playlists seems to ignore the <playlistasfolders> advanced setting. Is this intentional, or a bug/oversight? -sialvi

Probably a mixture. Personally I'd like the setting gone completely   -jmarshall
To get the old functionality back I flipped over to the stable release branch, though I'll probably go back the last pre-alpha commit to get some of the v18 functionality back.  

Any idea if this was a planned deprecation?
Reply
#2
(2018-06-25, 04:00)thestig Wrote: this setting in advancedsettings.xml is ignored,
Which setting?


(2018-06-25, 04:00)thestig Wrote: I created a new advancedsettings.xml with only the playlistasfolders (false) property
Can you post your advancedsettings.xml contents. Here if it is not too big.


(2018-06-25, 04:00)thestig Wrote: the debug log (I'm on Xenial) shows the advanced file being read and loaded without error. 
Well, don't be shy, share it. Wink
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#3
No the <playlistasfolders> setting has not been deprecated, that part of the code has not changed.
Quote:...they all failed after my weekly apt upgrade ran overnight.   In the GUI, the problem was apparent - selecting a playlist no longer plays, it, rather it opens a virtual directory of the playlist items. 
Then it is probably some other recent player/playlist handling change that is having this effect, not the setting.

Can you say which build this is working in and when it breaks (giving date and SHA if possible)? Narrowing down the range of build to even more tightly than "the last week" would be a help to find the cause .
Reply
#4
Hey guys, thanks for replying.  @Karellen  - I'm referring to the property in the thread title:

<advancedsettings><playlistasfolders>true</playlistasfolders></advancedsettings>

The log content of that property being loaded is at the end of this post, but it's not useful in this case, promise.  

@DaveBlake  - I'm on the "unstable" branch, so I was going from 

2:18.0+git20180304.1724-alpha1-0xenial
to 
2:18.0+git20180621.2143-alpha2-0xenial

I typically trigger my playlists vocally, with a bit of a rube goldberg type hack using an alexa.  But at the end of it, kodi-send --action=PlayMedia(/path/to/playlist.m3u) happens.  Likewise I have that kodi-send command mapped to a keyboard key.  And I use yatse remote app for android, where I sometimes use its file browser to navigate to the playlists directory, and tap to launch them.    


The behavior makes sense in the context of the system being asked by a remote client to "play" the playlist, when it wants to open them as folders.  Both kodi-send and Yatse will play individual files - mp3's, MKV videos etc, without any issue.  If I use the GUI to navigate to a playlist, select the playlist (which opens as a folder) and select an item, it plays normally.  

I'll update to alpha2 again to replicate the issue and grab a full debug.  If anyone currently on the git20180621.2143 build wants to test if this is a thing, just run the command

kodi-send --host=localhost --port=9777 --action=PlayMedia\(/home/kodi/.kodi/userdata/playlists/music/YOURPLAYLIST.m3u\)


logfile:

20:10:11.869 T:139696232274304 NOTICE: Loaded settings file from special://profile/advancedsettings.xml
20:10:11.869 T:139696232274304 NOTICE: Contents of special://profile/advancedsettings.xml are...
<advancedsettings>
<playlistasfolders>false</playlistasfolders>
</advancedsettings>

(normally I have ~100 lines worth of advanced settings, but for testing purposes I dropped to *only* including this property.  )
Reply
#5
reinstalled alpha2 and replicated the problem via kodi-send as shown in this pastebin of the debug log. Also included in this paste, after the line "INTERMISSION", are the logs where I use keyboard to navigate to the playlists dir, select classical.m3u, and it opens like a folder.

Contents of classical.m3u were pared down to:
Quote:#EXTM3U
/home/xbmc/Music/sorted.mp3/Classical/Mozart - Piano Concertos/Mozart - 64 - Piano Concerto No. 25 In C Major I. Allegro Maestoso.mp3
/home/xbmc/Music/sorted.mp3/Classical/Bach - Violin Concertos/Bach - 04 - Violin Concerto No.2 In E, Bwv 1042 1. Allegro.mp3

For simplicity, however as I said, the type and source of the playlist make a difference (self made, from a digital download release, created through kodi playlist editor, .pls, etc). The #EXTM3U header isn't even strictly necessary.


Thanks again for the assistance!
Reply
#6
Back on alpha1 and the issue is gone again, so something has changed from alpha 1 to alpha 2.  Can anyone on alpha2 try running a music playlist via kodi-send, or yatse?  I'd even hop over to nightlies if this works there.
Reply
#7
(2018-06-27, 05:49)thestig Wrote: Back on alpha1 and the issue is gone again, so something has changed from alpha 1 to alpha 2. 
Yes, lots has changed in the last 3 months!
Sorrry but I misread your op to think you updated build weekly. I don't know which change will have caused this regression, and it could take some research to find it.
Reply
#8
Bummer.  I tried to diff the alpha1 and alpha2 tags myself, but there were way way too many changes.  Had I been on nightlies I could have pinpointed when it happened and had a much smaller subset to work with.  

I'm sure there's a reason that 'playlists as folders' has become favored, even if i'm not sure what the appeal is, but I have to think there are plenty of others like me that trigger playlists using Yatse/remote apps, web interfaces, keyboard shortcuts, kodi-send, and so on.   Will it get a bug report/ticket?
Reply
#9
Just realised this issue is still outstanding (and no a ticket would not have helped, plenty of those lurk forgotten). @thestig is it possible to see this issue just from GUI behaviour? Most of what you decribe involves also using JSON API, and I'm at a bit of a loss what change in behaviour I am looking for.

I see a GUI behaviour difference between 17.6 and 18a1 (no idea when it started), but not 18a1 to 18a2 that behave the same as each other. This makes me think there could be two separate regressions here:

a) the GUI behaviour with <playlistasfolders>false</playlistasfolders> - v17 shows total file size and plays .m3u files when hit enter, but v18 this setting make no difference .m3u files are treated like the other playlists and enter opens list of files within it.

b) the JSON ability to use a single player.open call to play a playlist (nothing to do with <playlistasfolders>)
This is discussed https://forum.kodi.tv/showthread.php?tid=315249 and possible elsewhere but I can't find it right now.
Reply
#10
Hey thanks for picking it back up.  By happenstance, after sticking to alpha 1 since I last posted, yesterday I updated from ubuntu 16.04 to 18.04, and moved to the current 'unstable' kodi branch ( 18.0+git20180828.0901-beta1-0bionic ) , just to see if the behavior had changed.  It did, somewhat, but I may have unearthed another bug.

So now, I can trigger playlists via Yatse, and with JSON (kodi-send).  Nothing opens as a folder anymore.  Great!

The major caveat to that is, plenty of playlists were causing kodi to crash immediately on triggering them. ...

EDITED by DB
New issue so split into a new thread https://forum.kodi.tv/showthread.php?tid=335368
Reply
#11
Well it seems I have located the wrong regression Confused
There is a regression involving <playlistasfolders> being ignored, this was introduced in May 2017 by PR12004 to always expand ISO images. I have yet to work out how best to fix it.

But this setting has nothing to do with the differences you experienced between alpha1 and alpha2 and using kodi-send to perform a PlayMedia action on .m3u files. This issue has now vanished in beta1, I'll take that as a win.

You have now found another issue in Beta1 involving playback of AAC encoded .m4a files from playlists. I think I will split that into a new thread, and need to gather some example files and clear instructions on how to reproduce the issue before asking my player expert colleagues to investigate.
Reply
#12
OK, some cludgy mod changes and edits I have created a new thread for the m4a files in playlist issue https://forum.kodi.tv/showthread.php?tid=335368, lets continue that discussion there
Reply
#13
For completeness https://github.com/xbmc/xbmc/pull/14417 fixes the regression that was foricng .m3u playlists to always be treated as folders in the music window regardless of the <playlistasfolders> setting in advancedsettings.xml

Despite the thread title this was not the problem experienced by the original poster, but there was a bug with <playlistasfolders> that will be fixed once that PR has merged.
Reply



Logout Mark Read Team Forum Stats Members Help
Leia / alpha2 - playlistasfolders is now ignored, is that on purpose?0
This forum uses Lukasz Tkacz MyBB addons.