Kodi v18 slow launch with OSX Mojave
#16
Wow, that works great! Quitting Kodi is much faster as well.
Even on my 2010 mini with patched version of Mojave.

Thanks for the solution.
Reply
#17
(2019-04-04, 12:40)McView Wrote: Wow, that works great! Quitting Kodi is much faster as well.
Even on my 2010 mini with patched version of Mojave.

Thanks for the solution.

Enjoy ! I've searched for a solution... and today I found this way ! Hope it can help other people.
Reply
#18
Smile 
It sure will help others, you're the best  Smile
Reply
#19
(2019-04-04, 10:54)kernelitto Wrote: SOLVED ! finally !

Quit Kodi
Go to Mac preferences > Mac Security Preference Pane > Confidentiality > Accessibility 
Remove all Kodi entries
Restart Kodi and cancel the message warning for allow kodi manage accessibility prefs
Kodi is so fast at start now.

Yes, that does resolve the issue. Can anyone from team Kodi clarify what exactly would not work if 'Deny' was the option selected? The help for this says
Quote:Accessibility
Shows apps that run scripts and system commands to control your Mac. Deselect the app if you want to prevent it from controlling your Mac.
Reply
#20
I have no idea why kodi even appears in that list. Nothing we actively enforce in the code. I don’t think it will change any features in kodi if this is disabled in Macos ...
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#21
(2019-04-04, 10:54)kernelitto Wrote: SOLVED ! finally !

Quit Kodi
Go to Mac preferences > Mac Security Preference Pane > Confidentiality > Accessibility 
Remove all Kodi entries
Restart Kodi and cancel the message warning for allow kodi manage accessibility prefs
Kodi is so fast at start now.
It's ok, but do I have to do this every time?
Is there some permanent solution?
Reply
#22
(2019-08-31, 13:44)Iwanche Wrote:
(2019-04-04, 10:54)kernelitto Wrote: SOLVED ! finally !

Quit Kodi
Go to Mac preferences > Mac Security Preference Pane > Confidentiality > Accessibility 
Remove all Kodi entries
Restart Kodi and cancel the message warning for allow kodi manage accessibility prefs
Kodi is so fast at start now.
It's ok, but do I have to do this every time?
Is there some permanent solution? 
This is a permanent solution.
Reply



Logout Mark Read Team Forum Stats Members Help
Kodi v18 slow launch with OSX Mojave2
This forum uses Lukasz Tkacz MyBB addons.