Kodi v18 "Leia" RC 1, unable to disable subtitles
#1
Hello,

Previously I was able to disable subtitles for all movies, however the OSD disable all subtitles as a default isn't working...

Each time I stream a movie video subtitles appear..  Video and player settings are set their defaults.

I also uninstalled any subtitle add-ons I vaguely remember installing two addons from opensubtitle.org   and changing some settings to get a subtitle to work, however AFAIK the subtitle add-on have no control over the Kodi subtitle settings which apparently can only be changed while playing a movie and selecting subtitles from the osd menu. With an option  to make the subtitle settings as Kodi default.

Also seem to remember re-installing Kodi at least once or twice since the subtitle settings malfunction..

Every time I play a movie video that doesn't require subtitles  I need to disable them.

Is there any method to get back to disable subtitle as  default? The movie player subtitle settings seems to be broken.
Reply
#2
While watching a video with subtitles...use the osd to turn them off, then 'set as default for all media', that should work. Failing that delete the guisettings.xml in the Userdata (wiki) folder. As a side note: keyboard T toggles the subtitles.
Reply
#3
I tried setting the subtitle disabled as the default setting via the OSD menu, however that doesn't work before and after deleting guisettings.xml. I looked through the xml file however there's many settings related to subtitles and uncertain which setting(s) disables subtitles  by default.
Reply
#4
Look for  <defaultvideosettings> after that should be <showsubtitles>false</showsubtitles> or true as the case may be.  But you should not have to dig this deep.
Reply
#5
This is happening to me the other way around. Subtitles are not showing unless I tell kodi to. 
So far, only muxed subtitles are not displaying. Externals seem to be displaying fine.
Origin (the TV Show) for exemple, once the episode starts, KODI picks up the .srt that is inside the .mkv but then auto-disables it. I have to manually turn it on, and then it stays until the end of the episode.
Rinse and repeat.

Only started happening on RC2
Reply
#6
RC3 night-lies are available, I tried with a video that had 2 internal subs and subtitles acted as they should. OTH TV shows seemed to have their subs are not showing unless toggled and confirms your experience but was consistent, I didn't see any of the auto-disable.
Reply
#7
(2018-12-04, 21:11)PatK Wrote: RC3 night-lies are available, I tried with a video that had 2 internal subs and subtitles acted as they should. OTH TV shows seemed to have their subs are not showing unless toggled and confirms your experience but was consistent, I didn't see any of the auto-disable.
Will test. And disregard what I said about this only affecting muxed subs. Its happening with external subtitles. As soon as playback starts, "subtitles" (in the OSD) gets turned off.


EDIT: kodi-20181203-1de0d409-master-arm64-v8a.apk seems to have fixed it for one out of 3 of my NVidia Shields. After enabling subtitles in the "subtitles" section of the OSD and going to the "Video" section in the OSD and selecting "default for all media" it memorizes for other playbacks. Unlike it was doing pre-RC3

The other 2 are still having mixed results. Some movies or tv shows the "on" setting is memorized, others dont.

EDIT 2: I think I've found the bug. And it seems to be related to Emby for KODI 3.1.35a latest beta version. I'm saying this because I had one of my NVidia Shields on RC1 20181121-314c302 and none of this was happening. As soon as I updated Emby for KODI to that version, started happening.

https://emby.media/community/index.php?/...s-on-kodi/
Reply
#8
(2018-12-04, 06:42)PatK Wrote: Look for  <defaultvideosettings> after that should be <showsubtitles>false</showsubtitles> or true as the case may be.  But you should not have to dig this deep.
 I'm seeing from the guisettings.xml " <showsubtitles>false</showsubtitles> " after trying to save subtitles off  as the default setting. So the setting <showsubtitles>false</showsubtitles> doesn't seem to be working
Reply
#9
@User-3023 need a few more details that a proper debug log would include, we're up to RC3 in the night-lies, you might want to go with that for proof. Log file/Advanced (wiki)
Reply
#10
(2018-12-05, 18:26)PatK Wrote: @User-3023 need a few more details that a proper debug log would include, we're up to RC3 in the night-lies, you might want to go with that for proof. Log file/Advanced (wiki)
 As I said above, confirmed bug on Emby for KODI plugin regarding my issue.
Reply
#11
(2018-12-06, 03:26)djhifi Wrote:
(2018-12-05, 18:26)PatK Wrote: @User-3023 need a few more details that a proper debug log would include, we're up to RC3 in the night-lies, you might want to go with that for proof. Log file/Advanced (wiki)
 As I said above, confirmed bug on Emby for KODI plugin regarding my issue.

How about not usi6the Emby plugin?
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
#12
(2018-12-06, 12:24)Martijn Wrote:
(2018-12-06, 03:26)djhifi Wrote:
(2018-12-05, 18:26)PatK Wrote: @User-3023 need a few more details that a proper debug log would include, we're up to RC3 in the night-lies, you might want to go with that for proof. Log file/Advanced (wiki)
 As I said above, confirmed bug on Emby for KODI plugin regarding my issue. 

How about not usi6the Emby plugin? 
I have an Emby server, if I don't use that plugin I can't use KODI since my database is all on a Synology NAS feeding 3 NVidia Shields lol. That's a wierd suggestion man Big Grin. The issue is with .35 version .34 is ok and I was just reporting that it's being fixed in the upcoming version. To whoever is also using such plugin and having the same issue with .35 version Smile
Reply
#13
If it's an issue with plugin then you should complain there and not in a general Kodi topic.

Now it's wasting our time thinking it's a Kodi issue while it's just the add-on thats not working
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
#14
I'm not wasting time to anyone. I'm seeing more users talking about this here and also here:
https://forum.kodi.tv/showthread.php?tid...pid2797489

And I was warning them.

No need to be harsh or recommend ilogical measures. I think you've misunderstood me.

Cheers and keep up the good work.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Kodi v18 "Leia" RC 1, unable to disable subtitles00