•   
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 13
  •   
Important Windows Store v18 update resets my settings
#16
@Karellen 

Yes tried copy/past and nothing changed.



asacoyekew.kodi (paste)
Reply
#17
Thanks for moving me to this thread...sorry I missed it before posting.

I can confirm that I have a similar situation to @flavict with two different folders: a Local Cache and a Local State with the latter being created on January 29th. (Local State is not entirely empty, however, because I have already installed an addon from the Kodi repository since the update, and it seems to have been stored there.)

Please let me know if you have any questions, and I will watch the thread for possible fixes.
Reply
#18
@flavict

Thanks for trying that.

According to the log, Kodi has found your files. I can see the old databases being updated.
18:04:29.465 T:14520   DEBUG: CDatabaseManager::Initialize, updating databases...
18:04:29.466 T:14520 NOTICE: Running database version Addons27
18:04:29.467 T:14520 NOTICE: Running database version ViewModes6
18:04:29.468 T:14520 NOTICE: Running database version Textures13
18:04:29.471 T:14520 NOTICE: Running database version MyMusic72
18:04:29.474 T:14520 NOTICE: Running database version MyVideos116
18:04:29.476 T:14520 NOTICE: Running database version TV32
18:04:29.477 T:14520 NOTICE: Running database version Epg12
18:04:29.477 T:14520 DEBUG: CDatabaseManager::Initialize, updating databases... DONE

I can see a number of non-default add-ons being pinged.
18:04:29.461 T:3136   DEBUG: LocalizeStrings: loaded 64 strings from file C:\Users\Francois\AppData\Local\Packages\XBMCFoundation.Kodi_4n2hpmxwrvr6p\LocalState\addons\script.user.rating\resources\language\English\strings.po
18:04:29.462 T:3136 DEBUG: LocalizeStrings: loaded 97 strings from file C:\Users\Francois\AppData\Local\Packages\XBMCFoundation.Kodi_4n2hpmxwrvr6p\LocalState\addons\script.xbmcbackup\resources\language\resource.language.en_gb\strings.po
18:04:29.462 T:3136 DEBUG: LocalizeStrings: loaded 3 strings from file C:\Users\Francois\AppData\Local\Packages\XBMCFoundation.Kodi_4n2hpmxwrvr6p\LocalState\addons\service.onmute\resources\language\English\strings.po
18:04:29.463 T:3136 DEBUG: LocalizeStrings: loaded 35 strings from file C:\Users\Francois\AppData\Local\Packages\XBMCFoundation.Kodi_4n2hpmxwrvr6p\LocalState\addons\service.upnext\resources\language\resource.language.en_gb\strings.po
18:04:29.463 T:3136 DEBUG: LocalizeStrings: loaded 44 strings from file C:\Users\Francois\AppData\Local\Packages\XBMCFoundation.Kodi_4n2hpmxwrvr6p\LocalState\addons\service.watchdog\resources\language\English\strings.xml
18:04:29.464 T:3136 DEBUG: LocalizeStrings: loaded 54 strings from file C:\Users\Francois\AppData\Local\Packages\XBMCFoundation.Kodi_4n2hpmxwrvr6p\LocalState\addons\weather.weatherbit.io\resources\language\English\strings.po

Though I am at a loss as to what these errors are...
18:04:59.598 T:14520   ERROR: XFILE::CWinLibraryFile::GetFile: unable to get file 'win-lib://removable/M://VIDEO_TS.IFO' with error Erreur non spécifiée
18:04:59.611 T:14520 ERROR: XFILE::CWinLibraryFile::GetFile: unable to get file 'win-lib://removable/M://VIDEO_TS/VIDEO_TS.IFO' with error Erreur non spécifiée
18:04:59.619 T:14520 ERROR: XFILE::CWinLibraryFile::GetFile: unable to get file 'win-lib://removable/M://index.bdmv' with error Erreur non spécifiée
18:04:59.632 T:14520 ERROR: XFILE::CWinLibraryFile::GetFile: unable to get file 'win-lib://removable/M://BDMV/index.bdmv' with error Erreur non spécifiée

Can you explain what you mean by "nothing changed"? What hasn't changed, what are you seeing or not seeing?
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic_controls (wiki) | Import-export_library (wiki) | Movie_sets (wiki) | NFO_files (wiki) | Quick start guide (wiki)
Reply
#19
@YaYaTurre

No problems. The thread was difficult to find, but I have changed the thread title so it is more obvious to all users.

Hang in there for a bit, we are trying to sort this out. It should be a simple matter of copying your files to the new location (go ahead and give it a try) but I just want to see what problems the previous member is still experiencing by doing that.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic_controls (wiki) | Import-export_library (wiki) | Movie_sets (wiki) | NFO_files (wiki) | Quick start guide (wiki)
Reply
#20
Thanks for information. Moving advancedsettings to the new location solved the bigest problem.
Reply
#21
It worked! I copied all of the files from the Local Cache\Roaming\Kodi to the Local State folder, and everything is back to normal. All repositories and addons are restored.

Thanks so much!
Reply
#22
@Karellen 

Still no access to local hard drive. All add-on are there but disable, need to be re-enable one by one.

All library (video, music and picture) on a NAS with SMB not reachable.

Trying to make new network location SMB is not in the choices.
Reply
#23
You've been updated to the UWP version of the app so you need to install the SMB vfs addon from the repo.
Reply
#24
I copied from localcache to localstate and all settings appeared back, but when I tried to run anything it seems like tyem said to have lost the ability to see the local drives.

One question are we able to put a previous store version back in and if not is there a way to prevent automatic update of store version.

Thanks,
Reply
#25
+1 here. Installed the latest update via the MS Store and my settings and libraries are gone, but the bigger issue is that Kodi can't seem to see any of my local hard drives aside from my DVD drive. Happy to post logs or any additional information if needed - just let me know what you need.
Reply
#26
Same problem here.  Been using the Windows 10 UWP version since it came out and every upgrade was basically seamless.  This one auto-updated and seems to have broken literally everything.  Consistent with all other reports.  Settings reset completely.  Unable to access any local hard drives, remote drives or USB drives.  Basically useless.  Since the problems are so consistent, how much actual testing of the UWP version was done?
Reply
#27
@jjd-uk 

where is this SMB vfs addon in the repo?

have look under services and program...nothing
Reply
#28
(2019-01-30, 02:06)Bilbo430 Wrote: One question are we able to put a previous store version back in and if not is there a way to prevent automatic update of store version.
As far as I know, this is not possible without hacking your Windows 10.  You can neither install an old version, nor prevent updates.  This is why TESTING a UWP application before deployment is actually more critical than normal EXE installations.  It would appear no one actually tested the UWP version.  Either that or something was corrupted during the UWP deployment process.
Reply
#29
If you had 17.6 then this was not the UWP version of the app, that was simply an adjusted version of the normal desktop exe app for Store distribution. The genuine UWP app is new for v18 as it was needed to get Kodi onto Xbox.
Reply
#30
(2019-01-30, 02:03)jjd-uk Wrote: so you need to install the SMB vfs addon from the repo

thanks jjd, could you tell me which repo to find this in?
Reply
  •   
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 13
  •   
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Windows Store v18 update resets my settings00