•   
  • 1
  • 10
  • 11
  • 12
  • 13(current)
  • 14
  •   
Release TheMovieDB movie scraper - PYTHON version
(2021-10-01, 20:33)Zurg Wrote: : Suddenly the scraper doesn't take artwork from fanart.tv but only from TMDB in scraper settings I enabled fanart.tv and It was working fine till yesterday. 
It is all working fine for me. I scraped your movie and had all the fanart images downloaded without problems.
I cannot see any problems in your log, but I don't see any images for that movie being scraped either.

I do see an error with the scraper in your second log on Line 700 that is artwork related. Not sure why you would have that error all of a sudden and nobody else (including me) does.

Maybe @rmrector can check it.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
(2021-10-02, 10:57)Karellen Wrote:
(2021-10-01, 20:33)Zurg Wrote: : Suddenly the scraper doesn't take artwork from fanart.tv but only from TMDB in scraper settings I enabled fanart.tv and It was working fine till yesterday. 
It is all working fine for me. I scraped your movie and had all the fanart images downloaded without problems.
I cannot see any problems in your log, but I don't see any images for that movie being scraped either.

I do see an error with the scraper in your second log on Line 700 that is artwork related. Not sure why you would have that error all of a sudden and nobody else (including me) does.

Maybe @rmrector can check it.
I tried 2 times with different settings but always fanart.tv artwork were not scraped

1) VIDEO : https://drive.google.com/file/d/17zC0JvA...sp=sharing    LOG : https://paste.kodi.tv/mutituyuda.kodi

2) VIDEO : https://drive.google.com/file/d/1SAwKQ63...sp=sharing   LOG : https://paste.kodi.tv/sokicegabi.kodi

The problem is more strange because on my TV box android I don't have it but on PC yes Huh

In the log of my smartphone I found this line :  DEBUG <general>: easy_acquire - Created session to https://assets.fanart.tv  ; on PC's log there is not
Smarphone Log movie id is 379170
Reply
The error happened because the scraper doesn't perfectly handle disabling fanart from TMDB.
Reply
(2021-10-02, 18:33)rmrector Wrote: The error happened because the scraper doesn't perfectly handle disabling fanart from TMDB.
Did you check the videos in my previous message ?  The main issue is that artworks from fanart.tv are not scraped anymore on my PC even with a fresh install.
Reply
I have meda pull request with some changes:
Code:
Feature: downloading logos from tmdb:
Priority:
-fanart
-tmdb from your language
-general tmdb logo (without language)
-tmdb from "en"

Feature: search language option added
This is useful if you have other language than "en". For example I hava "pl" and for movie "My Son 2021" I will get wrong result because the right one has polish translation.

Change: searching movies from differnt years if not found
I have file "Nic Smiesznego 1995" for example. But the movie is from 1996 and will not be found. Now it is tried to find from +/- 1 year and without year if not found.

Is it the right place to do it: https://github.com/xbmc/metadata.themovi...n/pull/101 ?
Will it be added to official repo?

Zip for testing:
https://mkaflowski.github.io/metadata.th...python.zip

I needed to add one string. How to quickly add it to all strings.po files?
Reply
Was wondering if anyone can across any issue before with Android version unable to scrape movies from this source. I seem to of run into an issue where all of a sudden this scraper will not allow me to add anything new to my database, if i swap it up to something else, movies scrape fine. Already had posted a log in the Android section but @Karellen could see much wrong with it at all.
Reply
(2021-10-17, 04:13)ThatSlimGuy Wrote: Was wondering if anyone can across any issue before with Android version unable to scrape movies from this source. I seem to of run into an issue where all of a sudden this scraper will not allow me to add anything new to my database, if i swap it up to something else, movies scrape fine. Already had posted a log in the Android section but @Karellen could see much wrong with it at all.
I also started getting errors this morning. I use a Nvidia Shield TV. Error log at https://paste.kodi.tv/uxutuhomuy.kodi.
Reply
(2021-10-18, 04:13)Tyreless Wrote: I also started getting errors this morning. I use a Nvidia Shield TV. Error log at https://paste.kodi.tv/uxutuhomuy.kodi.
Please enable debug mode and provide the log. I can see the errors, but not enough info to show me why.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
(2021-10-18, 04:13)Tyreless Wrote: I also started getting errors this morning. I use a Nvidia Shield TV

Yeah i cant even begin to explain the issues this small thing caused me. Sent me down a path where i have now lost my setup of over 3000 movies and 195 shows with episodes. I now have a full reset shield with a kodi that now cant even detect rar files. Hope you dont have the same issues but this is pushing me to the edge big time..
Reply
(2021-10-18, 04:48)Karellen Wrote:
(2021-10-18, 04:13)Tyreless Wrote: I also started getting errors this morning. I use a Nvidia Shield TV. Error log at uxutuhomuy.kodi (paste).
Please enable debug mode and provide the log. I can see the errors, but not enough info to show me why.
Thanks for your help, Karellen. Debug log at https://paste.kodi.tv/ewerecibot.kodi.
Reply
(2021-10-18, 06:53)Tyreless Wrote: Debug log at https://paste.kodi.tv/ewerecibot.kodi.
Can you give me the link to the following movie...
[metadata.themoviedb.org.python]: Find movie with title '12 01pm' from year 'None'

Could you please change to the XML version of the scraper and see if you encounter any problems and let me know?
https://forum.kodi.tv/showthread.php?tid=363391
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
(2021-10-18, 07:07)Karellen Wrote:
(2021-10-18, 06:53)Tyreless Wrote: Debug log at ewerecibot.kodi (paste).
Can you give me the link to the following movie...
[metadata.themoviedb.org.python]: Find movie with title '12 01pm' from year 'None'

Could you please change to the XML version of the scraper and see if you encounter any problems and let me know?
https://forum.kodi.tv/showthread.php?tid=363391
Link is https://www.themoviedb.org/movie/30647-12-01-pm

The xml version works for me.
Reply
(2021-10-18, 09:49)Tyreless Wrote: The xml version works for me.
Ok, thanks.
There was a recent update to the python scraper.. Looks like we'll need to check it to see what the problem is.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
(2021-10-18, 10:13)Karellen Wrote: There was a recent update to the python scraper

Would this affected me at all with my original issue ?
Reply
(2021-10-18, 10:19)ThatSlimGuy Wrote: Would this affected me at all with my original issue ?
No, I am pretty sure yours is a different issue, though what that issue is, I don't know. But once rmrector has had a chance to look into the above issue, a new update will be pushed out and you can check if it fixes the issue.

Did you play around with those settings matthuismann mentioned in the other thread? Any change?
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
  •   
  • 1
  • 10
  • 11
  • 12
  • 13(current)
  • 14
  •   



Logout Mark Read Team Forum Stats Members Help
TheMovieDB movie scraper - PYTHON version0
This forum uses Lukasz Tkacz MyBB addons.