Ubuntu 19.10 and MCE Remote
Starting from Ubuntu 18.04 MCE Remote doesn't work anymore in Kodi.
Only Enter, Up, Down, Left, Right work.
Already read all the guides and tried ir-keytable and lirc.
It seems that xorg is intercepting all mce remote keystrokes (all commands are recognized with irw and ir-keytable -t).
Kodi log doesn't show any onkey events.
I'm the only one to have this problem?
Thank you,
What did you use before ?  ir-keytable or lirc ? My custom lirc remotes work fine in 18.04 with Kodi 18.4 and lirc 0.10.0-2.  I did have to point it to /dev/lirc1 rather than /dev/lirc.

From memory, that was the only change I had to make.
Learning Linux the hard way !!
Before I didn't change nothing from default config, and remote worked out of the box, so don't know if it was using lirc or ir-keytable.
Also in Libreelec old and latest version remote works perfectly.
What I can't understand is that with ir-keytable -t I can see all the keypresses, but they aren't recognized by kodi (no onkey event).
So it seems to me that there's something that intercepts that keystrokes.
I'm not an expert, but seems that ir-keytable translates remote buttons into keyboard keypresses: the problem is that remote button "1" (that should be translated into key_1 or key_numeric_1 depending on config) is not recognized by kodi, but key 1 and numeric key 1 on keyboard are perfectly seen!
Anyway, thank you for your answer.
Found solution, but it took three days, because I'm no expert.
My system is Ubuntu 19.10.
Searching everywhere, I found that xorg intercepts all keyboard keystrokes (why?).
The problem is that mce remote is seen as a a keyboard, so also all his keystrokes are intercepted.
Don't know how, but all (real) keyboard keystrokes work, but not remote buttons.
Nobody has a wiki, a doc page that show how all this is managed by xorg/Ubuntu.
Anyway found that the solution was to exclude mce remote from devices recognized by xorg, and let the remote be managed by lirc.
So, at first, added my remote to the /usr/share/X11/xorg.conf.d/10-quirks.conf.
More precisely, as I found somewhere in a site, I added this to that file:
# Disable the MCE remote from acting like a keyboard.  (We use lirc instead.)
Section "InputClass"
    Identifier   "MCE USB Keyboard mimic blacklist"
    Driver       "mceusb"
    MatchProduct "Media Center Ed. eHome Infrared Remote Transceiver (1934:5168)"
    Option       "Ignore" "on"
So, after a reboot, my mce remote was not seen by xorg.
Now I installed lirc.
Lirc package in Ubuntu 19.10 is defective.
When you first try to install, it terminates with an error because it doesn't find a file: /etc/lirc/lirc_options.conf.
So you have to copy (an empty text file is enough) a file with that name in that location, and install the package again.
After that, you have to edit lirc_options.conf and lircd.conf depending on your configuration.
I followed instructions on lirc site: http://www.lirc.org/html/configuration-guide.html.
Reboot, and after lircd is started, all is working now!
I don't know other distributions, but kodi and mce remote is a really common hardware-software config.
How is it possible that a normal user has to do all that?
There's a complete lack of information.
I couldn't find anywhere how keystrokes are managed in ubuntu (or xorg).
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
Ubuntu 19.10 and MCE Remote00
This forum uses Lukasz Tkacz MyBB addons.