Solved 18.6 can play rar movies for 7min then they just crash
#12
I just noticed the same issue and thought it was an issue with the new Kodi update that seems to have been released (based on the Play Store dates). It not only affected playback but also seeking more than a 1-5 minutes ahead. After having installed version 18.6 downloaded from the website and not seeing any changes, I found this thread after googling potentially relevant lines in the kodi log (though from my understanding that error simply indicates that rar-control.xml is missing, source.). Sure enough, reverting the vfs.rar plugin to 2.0.8 seems to have solved the problem. Smile

While the experience above only serves to confirm the suggested fix, the one new part might be that the vfs.rar v2.2.0 addon exhibits the same issues on 18.6 as well, at least on Android (64-bit build). Based one of the commit messages, it seems the bug referred to in the plugin description is about incorrect folder contents being shown so that might simply be a different bug. Maybe this last point is of interest for @alwinus? Given the large (and awesome) plugin update, it's hardly unreasonable for a few bugs to have crept in too. If futher logs with the latest version of the plugin on 18.6 are needed, let me know. I'd be happy to temporarily reinstall the new one in order help. Smile

EDIT: It seems like he's already aware of the issue (link). My offer of helping with logs still stands of course. Smile

EDIT 2: Version 2.2.1 seems to have solved this issue now with Kodi 18.6. Playback and seeking appears to be back to normal now, but with better archive support as a bonus.
Reply


Messages In This Thread
RE: 18.6 can play rar movies for 7min then they just crash - by blunden - 2020-03-08, 23:41


Logout Mark Read Team Forum Stats Members Help
18.6 can play rar movies for 7min then they just crash0
This forum uses Lukasz Tkacz MyBB addons.