•   
  • 1
  • 169
  • 170
  • 171(current)
  • 172
  • 173
  • 189
  •   
YouTube Plug-in Thread
@zhanglini 
Try disabling YouTube Settings - MPEG-DASH - Use MPEG-DASH and Use for videos. Restart Kodi and re-enable those settings.

@C.O.D. 
Thanks for reporting, I will look into it

@ynasida 
Need the complete debug log (wiki)

@brendonbell
If it's using old keys it is likely importing from your settings.xml.
With Kodi shutdown, edit your userdata (wiki)/addon_data/plugin.video.youtube/settings.xml to either remove your old, or add your new keys.
Code:
    <setting id="youtube.api.key"></setting>
    <setting id="youtube.api.id"></setting>
    <setting id="youtube.api.secret"></setting>
If you're adding your keys here, remove api_keys.json as well before starting Kodi.
Debug Log (wiki) | Troubleshooting (wiki)Add-ons
(2020-04-29, 19:10)anxdpanic Wrote: @zhanglini 
Try disabling YouTube Settings - MPEG-DASH - Use MPEG-DASH and Use for videos. Restart Kodi and re-enable those settings.

@C.O.D. 
Thanks for reporting, I will look into it

@ynasida 
Need the complete debug log (wiki)

@brendonbell
If it's using old keys it is likely importing from your settings.xml.
With Kodi shutdown, edit your userdata (wiki)/addon_data/plugin.video.youtube/settings.xml to either remove your old, or add your new keys.
Code:
    <setting id="youtube.api.key"></setting>
    <setting id="youtube.api.id"></setting>
    <setting id="youtube.api.secret"></setting>
If you're adding your keys here, remove api_keys.json as well before starting Kodi. 
Everything in MPEG-DASH is grey-ed out, I don't think I ever touched them.
I have two simple questions (mainly for the devs - anxdpanic & bromix - but I don't know how to contact them easier).

1. Since this unique API key request was introduced by Google, I'm unable to get 720p or 1080p resolutions for the content I play, which is usually official videoclips (vevo) or docs on official channels. It worked before and I'm requesting (add-on settings) 1080p for live and 720p for usual content. If I configure to always ask about the resolution,  then the only one h264 offered is still below 720p - usually 360xsomething.
Is it only me or is this a YouTube specially tailored low quality content for Kodi loosers? I'm running Kodi 17.4 on Raspberry Pi and I'm in the EU.

2. Why does the YouTube Addon need to always be running? I believe it's started automatically with Kodi (is it because of that stupid wizard?)
It's the only Addon I can see in the Kodi Setting Menu > Add-ons > Running and I do have a dozen of others installed that are only running when needed. Can this be somehow disabled - disable the stupid configuration wizard?
I'm a little concerned about my privacy now, since I need to provide an unique ID to Google and I don't like having them tracking my status. As a workaround I'm disabling the Youtube Addon when not using it (which will also crash (hang) Kodi 17.4 Sad but I got used with restarting Kodi - I have a special remote button for that - irexec running a script).

Thanks for any useful replies!
& thanks for the efforts invested in this Addon

P.S.
BTW, is there any alternative to YouCrapTube? It looks like Google is preparing to turn it into Netflix soon, even in browser I'm experiencing a lot of issue lately - need to disable a lot of privacy addons to be able to use it. Google is dying to see what's hidden in my underwear Smile
(2020-04-29, 19:10)anxdpanic Wrote: Need the complete debug log(wiki)

Please take a look.

https://pastebin.com/UHmYnZEu
I'm using Kodi git from a few days ago now (19.0-ALPHA1-git+cdb887b088), and the youtube plugin (version="6.8.0+matrix.1") installed from the gui via official repository. I configured it as far as setting up the api keys, logging in, searching for something, and then playing it. All that worked fine. But, my kodi.log is getting hammered every 60 seconds with:
Code:
2020-04-30 16:51:14.506 T:174968   DEBUG <CAddonSettings[plugin.video.youtube]>: loading setting definitions
2020-04-30 16:51:14.506 T:174968   DEBUG <CAddonSettings[plugin.video.youtube]>: trying to load setting definitions from old format...
2020-04-30 16:51:14.510 T:174968   DEBUG <CAddonSettings[plugin.video.youtube]>: loading setting values
2020-04-30 16:51:14.511 T:174968   DEBUG <CSettingsManager>: requested setting (kodion.access_token) was not found.
2020-04-30 16:51:14.511 T:174968   DEBUG <CAddonSettings[plugin.video.youtube]>: failed to find definition for setting kodion.access_token. Creating a setting on-the-fly...
2020-04-30 16:51:14.511 T:174968   DEBUG <CSettingsManager>: requested setting (kodion.access_token.expires) was not found.
2020-04-30 16:51:14.511 T:174968   DEBUG <CAddonSettings[plugin.video.youtube]>: failed to find definition for setting kodion.access_token.expires. Creating a setting on-the-fly...
2020-04-30 16:51:14.511 T:174968   DEBUG <CSettingsManager>: requested setting (kodion.login.hash) was not found.
2020-04-30 16:51:14.511 T:174968   DEBUG <CAddonSettings[plugin.video.youtube]>: failed to find definition for setting kodion.login.hash. Creating a setting on-the-fly...
2020-04-30 16:51:14.511 T:174968   DEBUG <CSettingsManager>: requested setting (kodion.login.password) was not found.
2020-04-30 16:51:14.511 T:174968   DEBUG <CAddonSettings[plugin.video.youtube]>: failed to find definition for setting kodion.login.password. Creating a setting on-the-fly...
2020-04-30 16:51:14.511 T:174968   DEBUG <CSettingsManager>: requested setting (kodion.login.username) was not found.
2020-04-30 16:51:14.511 T:174968   DEBUG <CAddonSettings[plugin.video.youtube]>: failed to find definition for setting kodion.login.username. Creating a setting on-the-fly...
2020-04-30 16:51:14.511 T:174968   DEBUG <CSettingsManager>: requested setting (kodion.mpd.proxy) was not found.
2020-04-30 16:51:14.511 T:174968   DEBUG <CAddonSettings[plugin.video.youtube]>: failed to find definition for setting kodion.mpd.proxy. Creating a setting on-the-fly...
2020-04-30 16:51:14.511 T:174968   DEBUG <CSettingsManager>: requested setting (kodion.mpd.webm) was not found.
2020-04-30 16:51:14.511 T:174968   DEBUG <CAddonSettings[plugin.video.youtube]>: failed to find definition for setting kodion.mpd.webm. Creating a setting on-the-fly...
2020-04-30 16:51:14.512 T:174968   DEBUG <CSettingsManager>: requested setting (kodion.refresh_token) was not found.
2020-04-30 16:51:14.512 T:174968   DEBUG <CAddonSettings[plugin.video.youtube]>: failed to find definition for setting kodion.refresh_token. Creating a setting on-the-fly...
2020-04-30 16:51:14.512 T:174968   DEBUG <CSettingsManager>: requested setting (kodion.subtitle.language) was not found.
2020-04-30 16:51:14.512 T:174968   DEBUG <CAddonSettings[plugin.video.youtube]>: failed to find definition for setting kodion.subtitle.language. Creating a setting on-the-fly...
2020-04-30 16:51:14.512 T:174968   DEBUG <CSettingsManager>: requested setting (kodion.video.support.mpd.addon) was not found.
2020-04-30 16:51:14.512 T:174968   DEBUG <CAddonSettings[plugin.video.youtube]>: failed to find definition for setting kodion.video.support.mpd.addon. Creating a setting on-the-fly...
2020-04-30 16:51:14.512 T:174968   DEBUG <CSettingsManager>: requested setting (kodion.video.support.mpd.builtin) was not found.
2020-04-30 16:51:14.512 T:174968   DEBUG <CAddonSettings[plugin.video.youtube]>: failed to find definition for setting kodion.video.support.mpd.builtin. Creating a setting on-the-fly...
2020-04-30 16:51:14.512 T:174968   DEBUG <CSettingsManager>: requested setting (youtube.api.enable) was not found.
2020-04-30 16:51:14.512 T:174968   DEBUG <CAddonSettings[plugin.video.youtube]>: failed to find definition for setting youtube.api.enable. Creating a setting on-the-fly...
2020-04-30 16:51:14.512 T:174968   DEBUG <CSettingsManager>: requested setting (youtube.api.key.switch) was not found.
2020-04-30 16:51:14.512 T:174968   DEBUG <CAddonSettings[plugin.video.youtube]>: failed to find definition for setting youtube.api.key.switch. Creating a setting on-the-fly...
2020-04-30 16:51:14.512 T:174968   DEBUG <CSettingsManager>: requested setting (youtube.api.key.switch.use) was not found.
2020-04-30 16:51:14.512 T:174968   DEBUG <CAddonSettings[plugin.video.youtube]>: failed to find definition for setting youtube.api.key.switch.use. Creating a setting on-the-fly...
2020-04-30 16:51:14.512 T:174968   DEBUG <CSettingsManager>: requested setting (youtube.api.last.hash) was not found.
2020-04-30 16:51:14.512 T:174968   DEBUG <CAddonSettings[plugin.video.youtube]>: failed to find definition for setting youtube.api.last.hash. Creating a setting on-the-fly...
2020-04-30 16:51:14.512 T:174968   DEBUG <CSettingsManager>: requested setting (youtube.api.last.switch) was not found.
2020-04-30 16:51:14.512 T:174968   DEBUG <CAddonSettings[plugin.video.youtube]>: failed to find definition for setting youtube.api.last.switch. Creating a setting on-the-fly...
2020-04-30 16:51:14.512 T:174968   DEBUG <CSettingsManager>: requested setting (youtube.login.version) was not found.
2020-04-30 16:51:14.512 T:174968   DEBUG <CAddonSettings[plugin.video.youtube]>: failed to find definition for setting youtube.login.version. Creating a setting on-the-fly...

What's the deal here? Am I the only one experiencing this? If it's creating those settings, why isn't it saving them? We're not even watching the youtube plugin anymore, why is it even `requesting` any settings, much less the same thing over & over for infinity? This is beyond obnoxious. I'd really appreciate some clarity here. Thanks for patience, and hopefully resolution.
@teriyaki 

I'm running: [plugin.video.youtube] Running: YouTube (6.8.0) on Krypton (Kodi-17.4) with Python 2.7.17
And I did a clean youtube Add-on installation. Removed the old one, exited Kodi and deleted the whole  .kodi/userdata/addon_data/plugin.video.youtube/ directory
Started Kodi again, went to add-ons> video add-ons and installed the latest youtube add-on 6.8.0 from the official repo. Then, exited Kodi again (I also clicked cancel to that stupid youtube add-on configuration wizard).
While on console and with Kodi not running, I edited manually the .kodi/userdata/addon_data/plugin.video.youtube/api_keys.json file and added my api_key + client_id + client_secret  (client_secret is NOT the google account password!)
Started Kodi and (maybe again I had to cancel the stupid youtube configuration wizard) went into the youtube add-on settings menu and didn't touch the login stuff, just some other video quality/menu display/ & co settings.
I don't have the records you're posting in my kodi.log. But I also didn't enable the debug logging...
(2020-05-01, 02:14)teriyaki Wrote: I'm using Kodi git from a few days ago now (19.0-ALPHA1-git+cdb887b088), and the youtube plugin (version="6.8.0+matrix.1") installed from the gui via official repository. I configured it as far as setting up the api keys, logging in, searching for something, and then playing it. All that worked fine. But, my kodi.log is getting hammered every 60 seconds with:
What's the deal here? Am I the only one experiencing this? If it's creating those settings, why isn't it saving them? We're not even watching the youtube plugin anymore, why is it even `requesting` any settings, much less the same thing over & over for infinity? This is beyond obnoxious. I'd really appreciate some clarity here. Thanks for patience, and hopefully resolution. 

Kindly do not post log snippets to the thread. Use pastsbin/hastebin.

As you know, Kodi Matrix is in pre-alpha development status. So it isn't surprising that there are various log entries. These are not to be obnoxious, but to help developers. You might be better served with stable Kodi version 18.6.

But as far as settings, I believe there will be a push to get add-on devs to update their settings.xml files to the new settings format. It's kind of a PITA but probably needs to be done. Just having those logged info isn't an error.

scott s.
.
maintainer of skin  Aeon MQ5 mods for post-Gotham Kodi releases:
Matrix see: Aeon MQ5 Mod Matrix release thread
Nexus see: Aeon MQ5 Mod Nexus release thread
Aeon MQ 5 skin and addon repo 11.1.0
@scott967 This is not a Kodi 19 issue, it has been there for a long time, before 19 existed. I probably should have mentioned that to avoid any assumptions this is 19 exclusive. Also, I wasn't filing a bug report, I was asking questions. Is this a known thing? Is is just me seeing it? Does anyone know the cause? If the answer is no to all those things then it may be worth filing a bug report. And, the debug logging is working correctly and is not the problem. The problem, as far as I'm concerned, is a plugin that is not in use, polling it's own settings every 60 seconds. I absolutely consider that to be obnoxious. You may disagree, which is perfectly fine, but my opinion is no less `valid` if you do.
I am not sure if this is related but I am experiencing something that suggests the app is doing something in the background on Krypton.

I watched 5 music videos this afternoon - then had a stream error. Tried to replay and got a ‘Quota exceeded error’.

Checked the details in my personal API - ever since the day I updated to 6.8.0 it has made over 9,000 queries over about 2 hours of use both yesterday and then today. The max queries per day allowed by google is 10,000 on a personal API - so now I get a ‘no stream found error’ and cannot use my personal APi until it resets at midnight.

I am going to roll back the install to see whether it fixes the issue tomorrow.

The queries per day graphs on the google api dashboard are pretty comical - Flatlined for the past few months then after install of the new version it went straight up to 10,000.






(2020-05-01, 02:14)teriyaki Wrote: What's the deal here? Am I the only one experiencing this? If it's creating those settings, why isn't it saving them? We're not even watching the youtube plugin anymore, why is it even `requesting` any settings, much less the same thing over & over for infinity? This is beyond obnoxious. I'd really appreciate some clarity here. Thanks for patience, and hopefully resolution.
The addon reports playback stats to youtube, but there is no option to turn it off to save api.
Does anyone know if (& how) its possible to increase the number of items per page, beyond the default 50 limit.
I've modified the settings.xml file to add |100|200 options, which then shows up as options within Kodi, but it still only shows 50 per page, so its purely a cosmetic change, it isnt being used as a value.

Im currently trying to watch old content across multiple channels from a year ago, in their real-time order, and having to go through 10-20 pages of their videos to get the next video, then in order to watch the next one, i have to go back 10-20 pages to get to the subs list, then go through 10-20 pages to the next video... 
I was hoping i could figure it out myself, but it doesnt look like theres a way for me to botch the solution.
(2020-05-02, 23:08)PaulC2K Wrote: Does anyone know if (& how) its possible to increase the number of items per page, beyond the default 50 limit.
I've modified the settings.xml file to add |100|200 options, which then shows up as options within Kodi, but it still only shows 50 per page, so its purely a cosmetic change, it isnt being used as a value.
It looks like there are a couple places where 50 is hardcoded in addons/plugin.video.youtube/resources/lib/youtube_plugin/youtube/client/youtube.py. I know little python but it looks pretty simple to work around.
This is likely a rather silly question, but....

Is there a way to have a view that shows liked videos and playlists listed on the same page? That's pretty much all I use (liked, custom playlists, and sometimes history) and being able to access them from one tier would be awesome.
(2020-05-03, 00:34)teriyaki Wrote:
(2020-05-02, 23:08)PaulC2K Wrote: Does anyone know if (& how) its possible to increase the number of items per page, beyond the default 50 limit.
I've modified the settings.xml file to add |100|200 options, which then shows up as options within Kodi, but it still only shows 50 per page, so its purely a cosmetic change, it isnt being used as a value.
It looks like there are a couple places where 50 is hardcoded in addons/plugin.video.youtube/resources/lib/youtube_plugin/youtube/client/youtube.py. I know little python but it looks pretty simple to work around.   
Just had a crack at it, and cant really make much sense of it all. Changing the '50's to '500' did nothing, it'd still tell me there were 51 videos.

The weird thing is that ive found a solution, and i think i understand why its happening this way.

\Roaming\Kodi\addons\plugin.video.youtube\resources\settings.xml
<setting id="kodion.content.max_per_page" type="enum" label="30022" values="5|10|15|20|25|30|35|40|45|50 default="9" />

Simply adding "|100" onto the list didnt make it 100 items per page. However what i never noticed last night because it so clearly wasnt double what i was used to, was that Kodi was telling me it was showing 56 items, where normally it'd say 51. That line in settings.xml is apparently doing nothing more than telling Kodi what to show as values, but Kodi isnt actually reading that value and using it. The add-on appears to be hard-coded to the point that each value increases by 5. So entry 0 = 5, entry 9=50, and if i add 100 entries, it'll give me 500 videos per page. 
So while the actual value used isnt important, every value increases the limit by 5.

Loading 250 ipp is definitely slower than 50, maybe 3 times slower. I'd hoped it might be marginally slower, as typical day-to-day use i dont really want it to take 10sec to load 250 results if i only care about the last handful added. At least i know i can put it back to 50 or move it to 250, depending on what i want at the time, so its certainly better having that option available now.

Thanks for your help.

edit: turns out the above isnt possible. When trying to view subbed channels it errors saying 50 is the limit, so its back to 50 Sad
I've searched this thread but I didn't find anything about my question so here it goes: after creating an API key I can watch content from my subscribed channels without any issues. However, no matter what kind of view I choose (Info Wall, Widelist etc.) the clips are not arranged by channel. So if I sort by 'added on', I'll see the latest added video atop of the list but the second video will not be from the same channel but from one of the other ten channels I've subscribed to where the video was added later as the first one. This is fine if I want to get the latest from all the channels I've subscribed to but I'd really love to be able to list the videos by channel as well. Is this already possible?
  •   
  • 1
  • 169
  • 170
  • 171(current)
  • 172
  • 173
  • 189
  •   



Logout Mark Read Team Forum Stats Members Help
YouTube Plug-in Thread18
This forum uses Lukasz Tkacz MyBB addons.