Subfolders not showing up
#4
(2020-08-23, 17:16)tero__ Wrote:
(2020-08-23, 16:16)phunkyfish Wrote: If you go to “web/movielist” does it list all the recordings or only the ones in the root folder.

I lists only ones from the root folder.
I noticed from the enigma2 addon source code that it supports multiple e2location entries if webif just gives them from the getlocations query.

It was unknown to me how can I add more locations, so I did some research.
This is not verified yet (found out this just minutes ago), but it seems like openwebif gets the list of locations from the config.movielist.videodirs enigma2 configuration parameter.
And that is updated in the lib/python/Screens/MovieSelection.py => I guess I just need to add those folders in regular movie selector?

Easiest way to add new folders was to go into timer list and there try to change some existing timer record directory and then just add bookmarks.
Then save the timer and there you go, webif reports those bookmarks as e2locations. I'd say that's strange.
So, now I have a few large folders included and the Kodi Video / Recordings listing takes ages to generate... let's see how long.
Reply


Messages In This Thread
Subfolders not showing up - by tero__ - 2020-08-23, 14:16
RE: Subfolders not showing up - by phunkyfish - 2020-08-23, 16:16
RE: Subfolders not showing up - by tero__ - 2020-08-23, 17:16
RE: Subfolders not showing up - by tero__ - 2020-08-23, 18:34
RE: Subfolders not showing up - by phunkyfish - 2020-08-23, 21:39


Logout Mark Read Team Forum Stats Members Help
Subfolders not showing up0
This forum uses Lukasz Tkacz MyBB addons.