Solved FRENCH language not scraping in UMS or TMDB
#1
sadly i have the same problem as many (with kodi 188 and 190) : 
i select fr-fr in  all the options in  universal movie scraper( 5.42) , tmdb (5.22) and nevertheless everything is in english (title, synopsys, plot,...)
Reply
#2
don't know why of course but in kodi.log :
2020-10-21 08:46:28.555 T:4040 WARNING: CSettingsManager: unable to read value of setting "tmdbgenreslanguage"
2020-10-21 08:46:28.555 T:4040 WARNING: CSettingsManager: unable to read value of setting "tmdbplotlanguage"
2020-10-21 08:46:28.555 T:4040 WARNING: CSettingsManager: unable to read value of setting "tmdbsearchlanguage"
2020-10-21 08:46:28.555 T:4040 WARNING: CSettingsManager: unable to read value of setting "tmdbsetlanguage"
2020-10-21 08:46:28.555 T:4040 WARNING: CSettingsManager: unable to read value of setting "tmdbtaglinelanguage"
2020-10-21 08:46:28.555 T:4040 WARNING: CSettingsManager: unable to read value of setting "tmdbtitlelanguage"
2020-10-21 08:46:28.555 T:4040 WARNING: CAddonSettings[metadata.universal]: failed to load value "fr" for setting tmdbgenreslanguage
2020-10-21 08:46:28.555 T:4040 WARNING: CAddonSettings[metadata.universal]: failed to load value "fr" for setting tmdbplotlanguage
2020-10-21 08:46:28.555 T:4040 WARNING: CAddonSettings[metadata.universal]: failed to load value "fr" for setting tmdbsearchlanguage
2020-10-21 08:46:28.555 T:4040 WARNING: CAddonSettings[metadata.universal]: failed to load value "fr" for setting tmdbsetlanguage
2020-10-21 08:46:28.555 T:4040 WARNING: CAddonSettings[metadata.universal]: failed to load value "fr" for setting tmdbtaglinelanguage
2020-10-21 08:46:28.555 T:4040 WARNING: CAddonSettings[metadata.universal]: failed to load value "fr" for setting tmdbtitlelanguage
that's probably  why i don't have french
Reply
#3
@michelb2

Could you please provide the full Debug Log thanks. Make sure debug mode is enabled and try scraping your French show again.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#4
i made the kodi.log (147kb) but don't know how to put it here with   https://paste.kodi.tv/
Reply
#5
(2020-10-21, 09:26)michelb2 Wrote: i made the kodi.log (147kb) but don't know how to put it here with   https://paste.kodi.tv/
Does this help... https://forum.kodi.tv/showthread.php?tid...pid2839494
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#6
found :
https://paste.kodi.tv/apobulijin.kodi
Reply
#7
(2020-10-21, 09:31)michelb2 Wrote: found :
https://paste.kodi.tv/apobulijin.kodi
Nope, no good. You did not restart after enabling debug mode. You enabled debug mode after the problem, so I cannot see what is wrong.

Follow the four steps exactly
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#8
https://paste.kodi.tv/xewibetugo.kodi
better ?
Reply
#9
Yes better. Thanks.

Leave it with us while we investigate.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#10
@michelb2

The scraper was recently updated with new language codes as required by TheMovieDB. As the old codes are no longer compatible, the scraper needs to be reset and old settings cleared out of the database.

1. Exit Kodi
2. Go to C:\Users\<YourUsername>\AppData\Roaming\Kodi\userdata\addon_data and delete the metadata.themoviedb.org folder if one is there.
3. Start Kodi. Go to Settings>Add-ons>My Add-ons>Information Providers and adjust the default settings. Make sure you select fr-FR for the language (or the appropriate language for your case). ^^
4. Go to your source and change scrapers. Any scraper is fine and save the selection and answer No when asked to update the library.
5. Go back and change the scraper again back to TheMovieDB. On that same page you can select Settings and adjust your settings there if required.
6. Repeat steps 4 & 5 for each source that uses that particular scraper

Do this for both UMS and TheMovieDB Scrapers


This may affect other languages also

Notes:
^^ Changing the default settings saves you adjusting the same settings on each source you need to update
  • The above paths are based on Windows. For all other platforms see Userdata (wiki) for the correct path.
  • The language code needs to be 4 characters. If your selected language is still 2 characters, this change will not work for you. Please report it in this thread.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#11
great !! It works
thanks a lot
Reply
#12
@michelb2

I have split your posts off. Hopefully it might make it easier for other users that experience the same problem to find their answer.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#13
Thread marked solved.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#14
sadly, it does not work with  kodi 190a2
https://paste.kodi.tv/erexejinut.kodi
Reply
#15
It should. It is the same scraper for both Leia and Matrix.

Try changing to another scraper and back again. Then adjust your settings.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply



Logout Mark Read Team Forum Stats Members Help
FRENCH language not scraping in UMS or TMDB0
This forum uses Lukasz Tkacz MyBB addons.