Scan not scrapping all episodes
#1
Trying to scan a new TV show to library.  All episodes present in path (NFS to NAS), and created local nfos using EMM.  When scanning, only half of season 1 is scanned to library and all season 2.  For the missing episodes, the log states:

WARNING: VIDEO::CVideoInfoScanner:: Process directory 'path of file.mkv' does not exist - skipping scan.

The nfos are present for all episodes, again, all created at the same time using EMM.  Why would these episodes be skipped?

Edit: I scan using "local information only".  I can also navigate to the missing episodes and play them from within Kodi, they just won't scan to library...
Reply
#2
Debug Log that captures your scan.

tv show nfo and 1 episode nfo file uploaded to Kodi Paste Site
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#3
(2020-10-23, 21:01)Karellen Wrote: Debug Log that captures your scan.

tv show nfo and 1 episode nfo file uploaded to Kodi Paste Site

https://paste.kodi.tv/uyederevus - tv show nfo

https://paste.kodi.tv/zafozomago  - nfo of episode that scanned

https://paste.kodi.tv/cupemigicu - nfo of episode that did not scan

I'll post debug later but looking at the two different episode nfos the only difference I can see is the one that didn't scan had <displayseason> and <displayepisode>.  I manually removed and tried to scan that episode only but still failed.

Edit: https://paste.kodi.tv/qodabagaxe.kodi - debug log
Reply
#4
Thanks. I see the does not exist - skipping scan for episodes 4, 5, 7, 9 and 10 of season 1, but no idea why. As usual I will put it down to a MySQL glitch and one that I cannot solve as it works fine using the local SQL database setup.

Navigate to Videos>Files and drill all the way down to the missing episodes. Highlight one of the episodes, call up the context menu and select Scan Item.

Does it scan?

Also, you will need to remove those banned addons for further assistance
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#5
(2020-10-24, 00:03)Karellen Wrote: Thanks. I see the does not exist - skipping scan for episodes 4, 5, 7, 9 and 10 of season 1, but no idea why. As usual I will put it down to a MySQL glitch and one that I cannot solve as it works fine using the local SQL database setup.

Navigate to Videos>Files and drill all the way down to the missing episodes. Highlight one of the episodes, call up the context menu and select Scan Item.

Does it scan?

Also, you will need to remove those banned addons for further assistance

Thanks as always Karellen for taking a look.  Offending addons removed (per PM).

I had already tried to scan at the episode level but have done so again...  Steps taken:
  1. Navigated to episode file and tried to scan item
  2. Next screen says no cast or information available so scrolled across to refresh
  3. When asked if wanted to ignore local data try internet, select yes 1st time and no 2nd but to no avail
New debug: https://paste.kodi.tv/wimewocidu.kodi
Reply
#6
If you are not getting too tired of creating logs, could you provide another one.

This time enable Component Logging and select SMB library, JSON-RPC, Windowing, libCEC and Database and repeat that previous log exactly the same way.

I have a suspicion it has something to do with the hash which seems to be missing, but no idea why that would happen.

https://kodi.wiki/view/Log_file/Easy#Ena...ic_logging

Thanks.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#7
(2020-10-24, 21:39)Karellen Wrote: If you are not getting too tired of creating logs, could you provide another one.

This time enable Component Logging and select SMB library, JSON-RPC, Windowing, libCEC and Database and repeat that previous log exactly the same way.

I have a suspicion it has something to do with the hash which seems to be missing, but no idea why that would happen.

https://kodi.wiki/view/Log_file/Easy#Ena...ic_logging

Thanks.

More than happy to keep supplying logs if they help with the issue.  Thanks for spending the time on this one; very much appreciated.

https://paste.kodi.tv/enowarilav.kodi
Reply
#8
Unfortunately that provided nothing extra.

I am at a loss as to what is causing the problem, but I do think it is linked to the missing hash.

A couple of things to try...

1. Delete the show from the library, delete the nfo files and let Kodi scrape the whow
2. Delete the show from the library, Rename the tv show folder from Doggystyle to Doggystyle (2018) and scrape into library.

Let us know if either of those work.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#9
(2020-10-25, 22:32)Karellen Wrote: Unfortunately that provided nothing extra.

I am at a loss as to what is causing the problem, but I do think it is linked to the missing hash.

A couple of things to try...

1. Delete the show from the library, delete the nfo files and let Kodi scrape the whow
2. Delete the show from the library, Rename the tv show folder from Doggystyle to Doggystyle (2018) and scrape into library.

Let us know if either of those work.
Hi Karellen

I went straight to option 2 and it worked!  Woohoo!!!  Cool

Thank you so much for your help.  I'm sure it was driving us both nuts.  I'll try to remember what we did, if it ever reoccurs.  I am going to insert the year when adding a new TV shows going forward.
Reply
#10
(2020-10-28, 20:24)Hairy Hippy Wrote: I went straight to option 2 and it worked!  Woohoo!!!  Cool
Great to hear. FYI, adding the year was irrelevant. What I tried to do is force Kodi to see a new folder and a "new" tv show. This would cause Kodi to write a new path in the database without the corrupted hash.

Enjoy!!
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply



Logout Mark Read Team Forum Stats Members Help
Scan not scrapping all episodes0
This forum uses Lukasz Tkacz MyBB addons.