display type
#1
hi bart, see my photo- i can not disable this ''lijst''. my favorite  display type is this ''tall list''. i succeeded to disable all others types  except this one. pls tell /show me on your screenshot - how  can i do it?
regards slawomir
Image
Reply
#2
(2021-02-23, 16:14)slawomir Wrote: hi bart, see my photo- i can not disable this ''lijst''. my favorite  display type is this ''tall list''. i succeeded to disable all others types  except this one. pls tell /show me on your screenshot - how  can i do it?
regards slawomir
Image
@slawomir , unfortunately, you cannot disable List.  At least one viewtype needs to be enabled in the skin, and List is the default view type, so I have removed the capability to disable it.

Regards,

Bart
Amber Maintainer
Main HTPC: Intel Core i7, 32GB, nVidia GTX1080, Windows 10 AVR: Yamaha RX-V683 TV: LG CX Kodi: 19.1 Skin: Amber
Reply
#3
(2021-02-23, 16:20)bsoriano Wrote:
(2021-02-23, 16:14)slawomir Wrote: hi bart, see my photo- i can not disable this ''lijst''. my favorite  display type is this ''tall list''. i succeeded to disable all others types  except this one. pls tell /show me on your screenshot - how  can i do it?
regards slawomir
Image
@slawomir , unfortunately, you cannot disable List.  At least one viewtype needs to be enabled in the skin, and List is the default view type, so I have removed the capability to disable it.

Regards,

Bart

hi, i see but it does not work the way i wish coz when i open something it goes automatically  to ...list not to tall list so i must  change it every time... .why this list must be  the default type what   is unnecessary in practice  ...why something is not automatically   opened with tall list ,why then with list?  pls adjust it as all  is possible,right? slawomir
Reply
#4
(2021-02-23, 16:39)slawomir Wrote:
(2021-02-23, 16:20)bsoriano Wrote:
(2021-02-23, 16:14)slawomir Wrote: hi bart, see my photo- i can not disable this ''lijst''. my favorite  display type is this ''tall list''. i succeeded to disable all others types  except this one. pls tell /show me on your screenshot - how  can i do it?
regards slawomir
Image
@slawomir , unfortunately, you cannot disable List.  At least one viewtype needs to be enabled in the skin, and List is the default view type, so I have removed the capability to disable it.

Regards,

Bart

hi, i see but it does not work the way i wish coz when i open something it goes automatically  to ...list not to tall list so i must  change it every time... .why this list must be  the default type what   is unnecessary in practice  ...why something is not automatically   opened with tall list ,why then with list?  pls adjust it as all  is possible,right? slawomir
@slawomir , to see if I understand correctly, if you go to your Movies, and set the view to Tall List, go back out to the main menu, and then go back to your Movies, they are now shown in List view? Please confirm.  If that is the case, then there is another issue in your system, because once you set a view for a type of content, Kodi remembers that view and you do not have to set it again.  Thanks.

Regards,

Bart
Amber Maintainer
Main HTPC: Intel Core i7, 32GB, nVidia GTX1080, Windows 10 AVR: Yamaha RX-V683 TV: LG CX Kodi: 19.1 Skin: Amber
Reply
#5
(2021-02-23, 17:23)bsoriano Wrote:
(2021-02-23, 16:39)slawomir Wrote:
(2021-02-23, 16:20)bsoriano Wrote: @slawomir , unfortunately, you cannot disable List.  At least one viewtype needs to be enabled in the skin, and List is the default view type, so I have removed the capability to disable it.

Regards,

Bart

hi, i see but it does not work the way i wish coz when i open something it goes automatically  to ...list not to tall list so i must  change it every time... .why this list must be  the default type what   is unnecessary in practice  ...why something is not automatically   opened with tall list ,why then with list?  pls adjust it as all  is possible,right? slawomir
@slawomir , to see if I understand correctly, if you go to your Movies, and set the view to Tall List, go back out to the main menu, and then go back to your Movies, they are now shown in List view? Please confirm.  If that is the case, then there is another issue in your system, because once you set a view for a type of content, Kodi remembers that view and you do not have to set it again.  Thanks.

Regards,

Bart

hi, its  not  that  simple/easy  ,my example- i add an series to my favorites- i open an series ,its episodes are in list ! so  i must adjust it to tall list! next time these episodes are in tall list, its good that  kodi or your skin  keeps it. other example- all my addons are only in tall list which is chosen by me. here i dont see -list! strange and happliy!  i open a film from an addon - this addon  finds films - different  sources - and this ? summary is  in list! so i must change it into the tall list...in short- the content  of the addon opens in list not in tall list...as u see ,its extra ...work ...now you know more ...regards slawomir
Reply
#6
(2021-02-23, 18:17)slawomir Wrote:
(2021-02-23, 17:23)bsoriano Wrote:
(2021-02-23, 16:39)slawomir Wrote: hi, i see but it does not work the way i wish coz when i open something it goes automatically  to ...list not to tall list so i must  change it every time... .why this list must be  the default type what   is unnecessary in practice  ...why something is not automatically   opened with tall list ,why then with list?  pls adjust it as all  is possible,right? slawomir
@slawomir , to see if I understand correctly, if you go to your Movies, and set the view to Tall List, go back out to the main menu, and then go back to your Movies, they are now shown in List view? Please confirm.  If that is the case, then there is another issue in your system, because once you set a view for a type of content, Kodi remembers that view and you do not have to set it again.  Thanks.

Regards,

Bart

hi, its  not  that  simple/easy  ,my example- i add an series to my favorites- i open an series ,its episodes are in list ! so  i must adjust it to tall list! next time these episodes are in tall list, its good that  kodi or your skin  keeps it. other example- all my addons are only in tall list which is chosen by me. here i dont see -list! strange and happliy!  i open a film from an addon - this addon  finds films - different  sources - and this ? summary is  in list! so i must change it into the tall list...in short- the content  of the addon opens in list not in tall list...as u see ,its extra ...work ...now you know more ...regards slawomir
@slawomir , unfortunately, it would seem that the addon you are using does not set the content type correctly, so Kodi (or Amber) does not remember correctly the viewtype.  I think there is a solution.  

You can "lock" a specific view for an addon, using the new media views selector.  You will need to have the addon script.skinvariables, version 0.2.4 or higher.  You can get this addon from jurialmunkey's repo: https://github.com/jurialmunkey/reposito...ey-2.0.zip  Once you have that installed and enabled, activate the following setting in Amber:

Image

And then click on "Configure Media Views":

Image

In the following dialog, go all the way to the end and select "Add Plugin View":

Image

Then find your addon and select it.  For the purposes of the example, I am selecting YouTube:

Image

Now you will select which type of content for the addon you want to always have which view.  Since it seems your addon is not setting the content type correctly, my recommendation is that you select videos, none, files, movies and episodes for your addon to have the view type Tall List.  I think that way you will be covering all the bases.  In the following screenshots, I will choose that for Videos from YouTube, I want to have the view type Tall List:

So, select Videos:

Image

And then select the view type you want (in this case, Tall List):

Image

I also went ahead and added that for YouTube, content None, to also have Tall List.  So now, when I go to YouTube (every single time, even after Kodi restarts), I get this:

Image

And this:


Image

As you can see, even the list of options for YouTube shows up in Tall List, since I set that view for content type None for YouTube.

I think this will allow you to have Tall List for your addon all the time, without having to change it every time.  Please test, and let me know how it goes.  Thanks.

Regards,

Bart
Amber Maintainer
Main HTPC: Intel Core i7, 32GB, nVidia GTX1080, Windows 10 AVR: Yamaha RX-V683 TV: LG CX Kodi: 19.1 Skin: Amber
Reply
#7
hi , thanks a lot , as always so kind of u,  for this advice. i tested it. it works  only in one addon. i have quite a few different video addons  and it would take a lot of time to adjust it them the way  u showed me.  there is also a disadvantage - this has influence on other addons which dont work in my previous system . so i came back to my last way. as i earlier  said -the best option is- we have chosen our favorite display type , and if there is no default type , like this list always - then it would be no problem coz  skin/kodi recognizes two types- this permanent list and other one chosen by us/me - and thats why , as i think, it works  a bit  messy ...u said -'' At least one view type needs to be enabled in the skin, and List is the default view type'' ...this one display type can be this one which we have chosen, right? why must exist this default  type? why in this case must be this list a default type not that one we wish, as my favorite - tall list? regards  slawomir
Reply
#8
(2021-02-25, 11:58)slawomir Wrote: hi , thanks a lot , as always so kind of u,  for this advice. i tested it. it works  only in one addon. i have quite a few different video addons  and it would take a lot of time to adjust it them the way  u showed me.  there is also a disadvantage - this has influence on other addons which dont work in my previous system . so i came back to my last way. as i earlier  said -the best option is- we have chosen our favorite display type , and if there is no default type , like this list always - then it would be no problem coz  skin/kodi recognizes two types- this permanent list and other one chosen by us/me - and thats why , as i think, it works  a bit  messy ...u said -'' At least one view type needs to be enabled in the skin, and List is the default view type'' ...this one display type can be this one which we have chosen, right? why must exist this default  type? why in this case must be this list a default type not that one we wish, as my favorite - tall list? regards  slawomir
@slawomir , I understand the issue for you and multiple addons.  Please test the latest from GitHub, I have now allowed disabling List view.  Please let me know if this now works as you would like.  Thanks.

Regards,

Bart
Amber Maintainer
Main HTPC: Intel Core i7, 32GB, nVidia GTX1080, Windows 10 AVR: Yamaha RX-V683 TV: LG CX Kodi: 19.1 Skin: Amber
Reply
#9
(2021-02-26, 18:15)bsoriano Wrote:
(2021-02-25, 11:58)slawomir Wrote: hi , thanks a lot , as always so kind of u,  for this advice. i tested it. it works  only in one addon. i have quite a few different video addons  and it would take a lot of time to adjust it them the way  u showed me.  there is also a disadvantage - this has influence on other addons which dont work in my previous system . so i came back to my last way. as i earlier  said -the best option is- we have chosen our favorite display type , and if there is no default type , like this list always - then it would be no problem coz  skin/kodi recognizes two types- this permanent list and other one chosen by us/me - and thats why , as i think, it works  a bit  messy ...u said -'' At least one view type needs to be enabled in the skin, and List is the default view type'' ...this one display type can be this one which we have chosen, right? why must exist this default  type? why in this case must be this list a default type not that one we wish, as my favorite - tall list? regards  slawomir
@slawomir , I understand the issue for you and multiple addons.  Please test the latest from GitHub, I have now allowed disabling List view.  Please let me know if this now works as you would like.  Thanks.

Regards,

Bart
bart, i see we have a new update. what a  great idea with these colours-thanks  a lot for this-  but for me and others not english speaking is an interesting puzzle  - what is what ...anyway i could find my favourite colours...1.how i can lighten the background of my bookmarks - i did something wrong -which? stripe in the settings i need to use...send me a screenshot,pls. 2.this new update did not change anything concerns this ? division of display types. like i said -for example -  a series has tall list and when i open ?a  summary of the episodes -these are in list, so u must click on tall list..the system does not keep the earlier chosen display type...once u said its rather complicated...i dont know how i can test this from github? i only know- how to download a file there . 3.  does yr skin can change the keyboard on kodi as i need the function : to see  my password while i  typing, an eye to open/close ...its very important when we must log in ...i think it depends on kodi, right? very  kind regards slawomir
Reply
#10
hi bart , kljolum posted his reply in amber  ,pls  have a look- i opened there the new thread about my new case but yesterday I ...discovered the reason of it. your latest update changed this ? function to ? standard and I did not realize it might be a reason as I did not expect the new update will change it- this one - subtitle button opens...was now - nee-no ...once u helped me in this problem and I changed it from - nee into ja -yes but last days it has changed as I already said..is   update a reason or not...not only of this example but other things? i think it is as I had - ja and now nee....now I changed into ja -yes and its ok  regards slawomir
Image
Reply



Logout Mark Read Team Forum Stats Members Help
display type0
This forum uses Lukasz Tkacz MyBB addons.