Unable to get 5.1 sound from player. But works with vlc
#1
I have an odroid h2+. It has an alc662 audio chip and a intell Celeron j4115. It is connected with an optical cable to my Sonos Playbar.

But for the love of God i can not get 5.1 sound over the standard player of Kodi. 5.1 sound is no problem in vlc... And I had vlc as an external player, but since matrix that doesn't work well anymore with streams. So, I'm back to the original player of Kodi.

I tried literally every setting. And most of the times there isn't any sound at all. Just when I keep everything "stock" i get sound, but just 2.0. When I enable passthrough and enable [dolby digital capable receiver] still 2.0 sound. When I enable Dolby AC3 decoding it simply does not start playing...

I never had this issue with a different Windows pc... That was of course different hardware. But still.

Any help is greatly appreciated!
Reply
#2
(2021-05-05, 20:52)Bestevaer Wrote: I have an odroid h2+. It has an alc662 audio chip and a intell Celeron j4115. It is connected with an optical cable to my Sonos Playbar.

But for the love of God i can not get 5.1 sound over the standard player of Kodi. 5.1 sound is no problem in vlc... And I had vlc as an external player, but since matrix that doesn't work well anymore with streams. So, I'm back to the original player of Kodi.

I tried literally every setting. And most of the times there isn't any sound at all. Just when I keep everything "stock" i get sound, but just 2.0. When I enable passthrough and enable [dolby digital capable receiver] still 2.0 sound. When I enable Dolby AC3 decoding it simply does not start playing...

I never had this issue with a different Windows pc... That was of course different hardware. But still.

Any help is greatly appreciated!

Ok, I got it to work with realtek drivers from AAF Optimus. These are modded audio drivers for realtek soundcards.

But I encounter a new problem. I had to set my audio source to Wasapi and the passthrough as well. Direct sound will freeze Kodi. But with Wasapi I'm unable to use my windows volume control to control the volume.

Is there a setting which will override Kodi volume? Or maybe a script?

Again, any help would be greatly appreciated!
Reply
#3
Wasapi is a professional low latency audio layer designed to bypass the standard Windows 10 audio layer.

The volume control has no effect. Google Wasapi; there are many audio sites explaining the audio technicalities.

ASIO4All is a professional low latency audio layer designed by Steinberg Media as a replacement for buggy and non-existent Windows 10 ASIO drivers.

https://www.asio4all.org/

According to the audio tests, ASIO4All works similar to Wasapi, yet the Windows 10 volume control works.

Select ASIO4All as the default audio driver in your soundcard.
Reply
#4
(2021-05-07, 01:10)JonasStax Wrote: Wasapi is a professional low latency audio layer designed to bypass the standard Windows 10 audio layer.

The volume control has no effect. Google Wasapi; there are many audio sites explaining the audio technicalities.

ASIO4All is a professional low latency audio layer designed by Steinberg Media as a replacement for buggy and non-existent Windows 10 ASIO drivers.

https://www.asio4all.org/

According to the audio tests, ASIO4All works similar to Wasapi, yet the Windows 10 volume control works.

Select ASIO4All as the default audio driver in your soundcard.
Thanks for your reply.
But when I install the asio4all, nothing pops up in my system. From windows or kodi...
Any other tips?
Reply
#5
(2021-06-07, 11:07)Bestevaer Wrote: But when I install the asio4all, nothing pops up in my system
In Kodi settings; ensure you have expert mode 'on' go to audio and choose audio output device, you should have a listing for different devices, your secondary display should be available if the driver was properly installed.
Reply



Logout Mark Read Team Forum Stats Members Help
Unable to get 5.1 sound from player. But works with vlc0
This forum uses Lukasz Tkacz MyBB addons.