Broken v19.1 Disc playback isn't working
#1
Since upgrading from Kodi 18 to Kodi 19, playback of optical discs hasn't been working for me.

There was a bug in the the 19.0 release, but even after upgrading to 19.1 the Play Disc button appears to have no effect at all.
The DVDs are detected, as the Disc menu only appears when they are inserted. The Load/Eject button works to eject the drive. The DVDs play in VLC (and were playing in Kodi until updating)

I've taken a debug log but I don't see any playback being attempted in it.

paste.kodi.tv was down at this time so I've put the debug log in pastebin. I started kodi, pressed play disc around 3 times with about 10 seconds between presses and stopped kodi: https://pastebin.com/SwDLhV3H
Reply
#2
Unfortunately, Arch Linux is a Linux OS for which we have no direct support (there is only the installation of Kodi in Ubuntu via our PPA), as the Arch Linux developers are packaging their own releases of Kodi, and they might incorporate changes/fixes to their Kodi build suiting their OS.

Perhaps asking on the Arch forums will get you are a more definitive answer on the disc playback matter.
Got a Kodi problem? Provide a full Debug log (wiki) | Usefull pages: First time user (wiki) | Troubleshooting (wiki) | Free content (wiki) | Forum rules (wiki) | VPN policy (wiki)
Reply
#3
See if the disc is already mounted after you inserted it. For Fedora (which is what I'm using), discs aren't automounted. IIRC Kodi "sees" the disc but is not able to mount it. If you mount the disc manually, the play disc opion should work again, if the needed packages are installed.
Reply
#4
(2021-05-16, 19:58)DaVu Wrote: See if the disc is already mounted after you inserted it. For Fedora (which is what I'm using), discs aren't automounted. IIRC Kodi "sees" the disc but is not able to mount it. If you mount the disc manually, the play disc opion should work again, if the needed packages are installed.

This is indeed the issue. After running mount /dev/sr0 ~/anything -t udf -o ro,user then playing with Kodi works.

This feels like a definite regression compared to Kodi 18, was there another thread about this to follow?

Thank you very much DaVu.
Reply
#5
As far as I´m aware it has always been like that. Not too sure, tbh
Reply



Logout Mark Read Team Forum Stats Members Help
v19.1 Disc playback isn't working0
This forum uses Lukasz Tkacz MyBB addons.