[RELEASE] VDR (LinVDR) plugin for XBMC - Video Disk Recorder

First of all thanks for this job.
I gave it a try, but no image for the moment.
I also had to hard code the server IP in the settings file
Now I can see the channel list.
When I select a channel, I have a popup annoucing the start of the streaming. When the green bar is full I can very furtively see the navigation (play, ffwd, rew ...) buttons on my screen, and then it returns to the channel list.
In the log I can see that there is some connection with vdr, that the streaming starts, and then I see something like :
Onkeypressed 14, action is 7 (I don't have my machine in front of me), while I did'nt pressed any key
Afterwards I see messages that the audio and video threads are stopped.
I can't see any error message

any idea?


Vu+ Solo2 with BH
2x Rpi's openelec 3.2.4
Please check if you can stream from VDR to VLC.
Just open the URL http://<vdr-server>:<port>/1 with VLC
yes that's working also in firefox with mplayer plugin
I also did try with http://serverip:3000/PES/1 and it is also working


Vu+ Solo2 with BH
2x Rpi's openelec 3.2.4
OK next try Smile
Create a text file test.strm and write your http://serverip:3000/PES/1 in it.
Try to play that file with xbmc. If thats working, we have a problem as I only call that url in the plugin. If its not working, you have a problem with xbmc itself.
Sorry for the delay but I have been quite busy theses days
I tried to play the file as you explained, but it is the same result.
As I don't know where to look, I posted a log in http://pastebin.com/m5c4ab9f3.
I can see an error on line 17, but don't know what it is, and if it is important.
Again it seems on line 107 that key 11 is pressed, but I don't press any key at that moment.


Vu+ Solo2 with BH
2x Rpi's openelec 3.2.4
I found the reason, not yet the solution.
I found out that when I start XBMC via the menu, with the mouse, everything is working wel. On my tv, I use a remote, that starts a script to start xbmc. When I do it that way, your plugin (and others) is not working.
Probably, the fact that I starts with a scripts, start it in a new shell. Does that have something to di with it ?


Vu+ Solo2 with BH
2x Rpi's openelec 3.2.4
WOW that is a handy plugin!
Nice work jack! Smile
Oh, had missed this plugin completely Smile.

Anyway. There is now support for the streamdev vtp protocol in xbmc. Or atleast partial such. However I'm not sure that is the way to go.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.

VDRfan Wrote:I've recently created a python plugin to handle VDR recordings in a more fancy way. Unfortunately its targeted to run on local file systems (or mounted ones) only at the moment, but i'll try to make it smb capable.
I am very interested in your plugin, not in the smb support, because I use nfs.
Did you publish it somewhere? I tried hard but I didn't find something in the
I know, the thread is a little bit old, but this plugin would really be nice to have.
I don't think there is a need for smb support in your plugin, there is fusesmb,
that should be enough for all.

I will review it once again and add it to the official xbmc-addons repository in a few days.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
VDRfan Wrote:I will review it once again and add it to the official xbmc-addons repository in a few days.
Great news, thanks!

Very interesting plugin.

I can't get it working with Ubuntu 8.04
VDR 1.6.0-6ctvdr1
streamdev 0.3.4-1

with XBMC SVN (8.10final1svn17369-hardy1)

Any suggestions? I edited the settings xml file.
Streaming with VLC/WebBrowser is possible, and the vdr confs are all correct (i use vdr since several years). I can't even see a Channel list Sad

Gamester17 Wrote:Long term here is something that you should find interesting:

I'm sorry to say this Gamester17, but why this isn't getting the importance that it deserves? I'm not being sarcastic, I'm just curious what the dev team have as a roadmap.
It seems there are some fantastic work underway:

Haven't tried this already, but will do it with next patch set. If we can get the streamdev patches upstream this would be a rock solid solution.

Hi jack83,

That is what I search as well. I tried your script but it doesn't work. I used the script from the first post.

I run Gen2VDR with streamdevserver and it works fine with VDR Zapper on Win boxes.
On the Xbox I run XBMC and the XStream script is working. Also the m3u file with channels.

What have I to consider that your plugin is working ?

I tried as a script and a plugin.

Thank you for your help.
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
[RELEASE] VDR (LinVDR) plugin for XBMC - Video Disk Recorder00
This forum uses Lukasz Tkacz MyBB addons.