ESI [email protected] soundcard + ALSA
#1
OS: ubuntu 8.04LTS
ALSA: 10.0.16
XBMC

This card has two chipsets as far as I can see. IEC1724 and IEC958.

"aplay -l" gives me the following output:
Code:
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: AD198x Analog [AD198x Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: AD198x Digital [AD198x Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI  [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Juli [ESI [email protected]], device 0: ICE1724  [ICE1724]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Juli [ESI [email protected]], device 1: IEC1724  IEC958 [IEC1724 IEC958]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I get sound when playing mp3 or radiostreams with Rhythmbox.

How can I get sound inside XBMC now? Video is working at the right speed btw.

DrE
Reply
#2
This card works out of the box for me and XBMC.
Do you have navigation sounds inside XBMC?

Might be a good idea to try to uninstall pulse-audio.
You could also try XBMC Live to verify yours is working.

Cheers.
If you have problems please read this before posting

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.

Image

"Well Im gonna download the code and look at it a bit but I'm certainly not a really good C/C++ programer but I'd help as much as I can, I mostly write in C#."
Reply
#3
Topfs2 Wrote:This card works out of the box for me and XBMC.
Do you have navigation sounds inside XBMC?

Might be a good idea to try to uninstall pulse-audio.
You could also try XBMC Live to verify yours is working.

Cheers.

Thanks,

Do you know what packets are connected to the pulseaudio-thingy? I guess something must take over the mixing after pulseaudio as well. Esound I pressume? (esound-0.2.40.tar.bz2 is the latest I can find, but only esound-0.2.38 exist as a package in ubuntu as far as I can see, and 0.2.38 is rather old)

You can imagine me beeing just a little bit n00bish to the whole install/uninstall phenomenon in Linux Wink

Did you use the optical output as well, or analog out? If optical, what is your settings under "Sound" in ubuntu and under "Audio" in XBMC?

DrE
Reply
#4
Id guess sudo apt-get remove libpulse0 but that seems to take away alot other packages that doesnt rely on pulseaudio.

Otherwise youcould probably force ALSA in sound-preferences in System - Settings

I only use analog sorry Smile
If you have problems please read this before posting

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.

Image

"Well Im gonna download the code and look at it a bit but I'm certainly not a really good C/C++ programer but I'd help as much as I can, I mostly write in C#."
Reply
#5
I got it to work now. Had to set hardware "0,1" as default in a .asoundrc file and make both audio settings in xbmc "default" (not iec958) Smile

Next problem: I have an old heavy "high end" DAC that does not support AC3 and DD. I dissable AC3 and DD support in XBMC, but everytime I restart the program (or the computer for that matter) they are enabled.

Playing a movie with surround makes my speakers turn on their head of noise because of this "forced AC3/DD support" in XBMC.

Is there anything I can do to stop it?
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
ESI [email protected] soundcard + ALSA00