Thread Rating:
  • 0 Vote(s) - 0 Average
Ninja Video and other plugins
From day one ( along time ago ) I have been having trouble with loads of plugins, just about all of them excpet AOL video, Apple movie trailers and Monkey Video which I can say works but still only 75%. Give or take a few others that I wish to not even deal with.

Why is it that I see so much about plugins but they never work. I dont know what it is but can someone who uses lots of the lugins on average tell me how they get them to work?

Ninja Video for example gets me to one point, I get to where I select what videos I want to watch but then it just goes back to that screan after I select the video's folder.
My guess the problem is not in the plugin itself, but webste change pretty often and so plugin need to be updated in order to work with modified website, and for that someone has to do it ... It takes time and energy, and since there are nt too much developpers around, plugins/scripts update take time too.
In your case if when you press on a video and you are back to the list, I think it is because the video playing failed (wrong url, or pb while reading ...)

Repositories Installer: select and install unofficial repositories / TAC.TV: watch videos on TAC.TV
Installer Passion-XBMC: Download and Install Add-ons (pre-Dharma only)

Im going to look into ways of updating them for my own purposes but I gotta ask, whats the purpose of releasing them with XBMC if chances are that by the time you install it the plugins wont work?

Quote:In your case if when you press on a video and you are back to the list, I think it is because the video playing failed (wrong url, or pb while reading ...)

How can I fix that? Can I fix that?
I mean it is not magic, you cannot have any guarantee (I not talking for all the developer here, just expressing my opinion Smile ) that a website is not going to change and so breaking a plugin or script designed for the old version of the website.
It is just bad luck. Some website seems to have changes more often than the other one, but that is not in the control of the developer.

For answering to your question, I cannot say for sure, since I am mot the developer of the plugin you have mentioned, but I don't think there is a quick fix (it could be quick, depend on the changes done on the webpage ...).
If the URL is wrong (my guess on your pb), it is because the content of the webpage has change or worse, the design of the website (for instance they use cookie now, etc).
That means someone has to analyze those changes and find a solution if it is possible.
As I said it is not magic, script and plugin we are using on XBMC are the result of hard work of developer who are nice enough to share it with us.

I am sure you are more than welcome to fix it, I don't know what is your level in Python and developpement of script on plugin on XBMC, but for sure you will find help here.

Repositories Installer: select and install unofficial repositories / TAC.TV: watch videos on TAC.TV
Installer Passion-XBMC: Download and Install Add-ons (pre-Dharma only)

I am deeply sorry that my efforts have displeased you, please feel free , never to use any of my plugins. Thank you.

As the message seems to have reached it`s intended, the above has been edited.

I never stipulated that " they dont work and probably never will again "

I simply stated that they did when released, and will be fixed over time.

Xbmc works out of the box, the plugs work when they are created and if the website owners change no code, the video hosts don`t change encryption - they still will.

I didn`t take offence, i was just pointing out that Ninja which you tried to use wasn`t working any more as i had already explained in the main thread for it. So why complain about something that you know won`t work ?

Seemed to have tickled a nerve, brother for the slang responses.

Tv-shack is fine try that , or not, whichever you prefer.

Get the latest Version of veoh proxy from Hagens google code page Kinstinct - If i may inquire, what plugin are you going to use it for ?


I always wish to help if i can, sometime it frustrates me when comments are made without reading the initial thread.
Also, you didn`t really go into detail about which plugins caused faults - just NV which we know won`t work until the code is cracked.

Try the Mythbusters plugin i am putting up now - It`s fresh and the site is stable. If that doesn`t work you may have a system problem.
There will always be a few that take for granted what you do for free for the community.

Slightly off topic what version of veoh proxy is best to use and where to d/l?

As your sig link doesn't show veoh proxy, just the title fix veoh and knowing the latest xbmc 8.10 final changes have made plugins/scripts broken.

Thanks for your patience and help Voinage, Sfaxman, Rwparris, Rodeo, Coolblaze et al.
You are a arogant fool.

I never said anything to anyone that should be labled as offensive jerk.

Obviously, regardles if they worked before and just dont now someone, after all the releases of XBMC feels they are worth the while adding into things and creating things especialy for them ( and scripts ) like the repo installer.

What exactly do you feel I could be doing wrong? Your Valiant plug in Douchness, please explain exactly what it is that could cause me to be having problems with a fresh install on something that is said to work "out the box"?

Thank you Temhil, I will look around and do some searching but I already found someone that blatenly states hes not worth asking for helpWink Seriously, if you admit that they dont work and probably never will again,... what the hell did I say wrong to offend him? What a douche!
The Ninja plug-in is well documented that it's not working but does work for some with flash files (with flash version), the last time I tried it worked anyway, although because I now use Fastpasstv, TV Shack, Quicksilverscreen, Movie6 and Pirate City which all work out of the box for me (but not always for others), I don't need to use it atm but I do check any progress, some plug-ins work one day then not the next, then work fine the day after, don't know why but that's technology for you.

A plugin can work on the day of release but not work the next day if the relevant site changes, it's a fact of (plug-in) life accept it or move on.

The devs of plug-ins want positive feedback to iron out any bugs not pointless rants, it's reciprocal, not, I want, no one is interested in helping a person who can cross the road but pretends to be blind.

I'm off to watch something now, mmm! Fastpass or Quicksilver or....
Quote:what the hell did I say wrong to offend him? What a douche!
Your post was inconsiderate and ungrateful. Regarding 'his' douchieness: while I cannot, personally, speak to anyone's hygienic rituals; I think we can all appreciate that he is, at least, a pleasant smelling vagina. Wink

Quote:I am deeply sorry that my efforts have displeased you, please feel free , never to use any of my plugins. Thank you.

I don't post much, but I do read these forums quite a bit... I have to say that the, rather selfless, developers around here--namely Voinage--have brought me more entertainment than I could have ever asked for... Sadly, I don't have a success/failure percentage handy.
Thank you Voinage for editing your post and sounding a bit less aggressive.

I will take the rest of your advice and forget about what was said previous to it being edited.

Agentlame, you have no clue what the hell you are saying. Nothing in my post sounded rude or inconsiderate in anyway. Wanna talk about rude and inconsiderate? What exactly did you have to suggest,.. I dont see anything at all!

Since I started using XBMC ( day one for me was a a long time ago!!! Sorry about that ) I have gotten very few plug ins to work. What else could I say?

I have asked questions in the past on other forums with no luck so I gave up and in fact one guy argued with me up and down but would not give them a shot himself, finally he did and found I was correct!!!! Now I started coming here which is a whole other world for plug-ins and other stuff for XBMC so I figured I would ask!

Voinage, I have gave the ones you posted a shot ( before editing your post ) and I didnt get any of them to work properly. Now, its not like I just dont get any response so I know it really shouldt be anything I am doing. I get to a certain page and then nothing happens when I select the folder.

For example " Quick Silver screen ". I select any one of the eleven catagories and it take me to another listing of folders for shows/movies/what have you. Then I click on the video I would like to view and it takes me to a diferent screen. I clikc on the icon for that video and it gives a error but closes the box before I can see what it is.
Myth busters is working! Thanks so far.

I will go ahead and go back through my list of non-working plug-ins and post them for you Voinage. First, just so no one gets all search Nazi on meBig Grin I will search through the most up to date threads to see if they have already been reported or are no longer going to be worked on period. I must apologize myself in a way cause I was not aware of there being previous threads on these topics recently posted ( Ninja Video for example:p ).

On a side note, one thing that got me was the fact that even Video Monkey worked, but only I say about 65%, and no just cause I say its not fully working does not mean that I am being unappreciativeBig Grin!
J, glad one worked for you.

You need to download veohproxy and copy it to your scripts folder.
Run it. It states (Running)

Then go to Quicksilver screen select the file and run the Video.

The proxy acts as a server fro the Video.

Pretty much every question has come up a few times and the answers are in the search.

Rest easy, Brother.
I have been using Veoh for some time now. I wonder if I should try to re-install it. I wounder if somewhere in the mist of giving up on plug-ins and updating XBMC something happened?

EDIT: Re-installed veoh via your link in your sig and still nothing. So far its Moviealien, Pirate City, and the Quciksilverscreen along with others you mentioned before that are not working for me.

Now I dont understand what could be wrong with my system but here are my specs.

1.4 Halo XBOX softmodded, stock HDD and XBMC as my dash. No other apps installed and I always use the latest builds of XBMC.
moviealien is dead i will not update that.

Quicksilver is fine for me.
Piratecity is fine.

All the others are working also. Hmmmm

You may need to clean your Z drive.

filemanager ---- addsource.

press a

select ' z ' press a
select ' symbols ' press a
then ' : ' press a
then done.

Select all and delete.

Try your plugins now.
I thought with XBMC as the only dash you dont have a Z?

Sounds like a round about way of accessing it so am I wrong by assuming its something hidden but not really intentionally hidden?

I clear all my other cache manually otherwise with every start up. What should I set all my cache settings to in XBMC?

Seriously, I dont even watch cable TV anymore. I use XBMC for everything!
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
Ninja Video and other plugins00