•   
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 105
  •   
[WINDOWS] External Player Support Thread
#46
ashlar Wrote:Two questions:

1) So it could be worth it to try with hidexbmc set to true and forceontop set to false? Or viceversa? Or do they both have to be true?

2) Is there any work being done with the overall focus problem? As I mentioned before, i think that having XBMC taking hostage the whole machine is too limiting for a lot of other purposes, different from the external player situation. Web browing, torrents monitoring... there's a lot of stuff that could be reached by alt-tabbing and now is unreachable.

this should solve the alt-tab issue, try and play around, i'm still at work so can't help at the moment....
Reply
#47
Jester Wrote:Upped new version XBMCSetup-Rev17060-ext.exe

new parameter:
Code:
<hidexbmc>true</hidexbmc>

What forceontop now does is change the xbmc window from TOPMOST to NOTOPMOST before the player is launched and back again afterwards

thx to moby-uk

@Jester

Are these changes in the SVN?
Reply
#48
tvont Wrote:@Jester

Are these changes in the SVN?

not yet, but once tested/checked i hope they will be...
Reply
#49
Jester Wrote:not yet, but once tested/checked i hope they will be...

Could you then *PLEASE* post the diff? Whould like to test on OSX
Reply
#50
tvont Wrote:Could you then *PLEASE* post the diff? Whould like to test on OSX

http://trac.xbmc.org/ticket/5672
Reply
#51
Nope. Built with 17061, patch applied OK but still focus on XBMC.

Tested:

<forceontop>false</forceontop>
<hidexbmc>true</hidexbmc>

<forceontop>true</forceontop>
<hidexbmc>true</hidexbmc>

Does this work on windows with VLC or any other player?
Maybe you are missing some controls regarding the focus of XBMC. When I switch to windowed mode on MAC, even there the XBMC window remains in front of the player (which opens and plays)
Reply
#52
tvont Wrote:Nope. Built with 17061, patch applied OK but still focus on XBMC.

Tested:

<forceontop>false</forceontop>
<hidexbmc>true</hidexbmc>

<forceontop>true</forceontop>
<hidexbmc>true</hidexbmc>

Does this work on windows with VLC or any other player?
Maybe you are missing some controls regarding the focus of XBMC. When I switch to windowed mode on MAC, even there the XBMC window remains in front of the player (which opens and plays)

we'll look into this, however for now (sorry) the focus is for win32
to keep things clear, i suggest you open a thread for this in the MAC section or else we'll loose track...
Reply
#53
nightyy Wrote:Using build17036-ext I get the following error in the logs, although the advancedsettings.xml is positioned correctly at the specified path:

are you running Vista?
If so, try deleting the cached copy that vista likes to hold onto..
should be in c:\users\<account name>\appdata\local\virtualstore somewhere...
For troubleshooting and bug reporting please make sure you Image Read Me First
Reply
#54
Jester Wrote:we'll look into this, however for now (sorry) the focus is for win32
to keep things clear, i suggest you open a thread for this in the MAC section or else we'll loose track...

So I did...but, as you are the only one I know who is working on a fix for that, I hope, you get it to work outside win32.

Feel free any time to ask me to try on OSX.
Reply
#55
@Jester
tried on Vista...VLC gains focus after pressing CTRL-ALT-DEL, then ESC...Focus comes back to XBMC when the player is finished.
Think, here is something missing too

In windowed mode it works smooth.
Reply
#56
i'm currently using this:

Code:
<advancedsettings>
<video>
  <defaultplayer>externalplayer</defaultplayer>
</video>
<externalplayer>
  <filename>c:\player\mplayerc.exe</filename>
  <args>/fullscreen /shutdown</args>
  <forceontop>true</forceontop>
  <hidexbmc>false</hidexbmc>
  <hideconsole>false</hideconsole>
  <hidecursor>false</hidecursor>
</externalplayer>
</advancedsettings>

outcome: alt-tab works but only with the externalplayer running (so during video playback)

hidexbmc works, flag set to true hides the XBMC program (doesn't display it on the taskbar)
Reply
#57
Jester Wrote:i'm currently using this:

Code:
<advancedsettings>
<video>
  <defaultplayer>externalplayer</defaultplayer>
</video>
<externalplayer>
  <filename>c:\player\mplayerc.exe</filename>
  <args>/fullscreen /shutdown</args>
  <forceontop>true</forceontop>
  <hidexbmc>false</hidexbmc>
  <hideconsole>false</hideconsole>
  <hidecursor>false</hidecursor>
</externalplayer>
</advancedsettings>

outcome: alt-tab works but only with the externalplayer running (ie during video playback)

hidexbmc works, flag set to true hides the XBMC program (doesn't display it on the taskbar)

The alt-tab "problem" is due to the fact that the XBMC window is "TOPMOST" which means it's above anything else that isn't "TOPMOST", most windows aren't so they are below XBMC even if they have focus; this was a change that went in in the "intel" patch.

The last experimental change to the externalplayer that Jester kindly built for me only changes the TOPMOST-ness of the XBMC window for the duration that the external player is running. For me, at least, the effect of having forceontop=true and hidexbmc=false is that when the externalplayer is launched

1) the taskbar becomes briefly visible above the XBMC window
2) the external player (in my case windows media player) appears over XBMC
3) WMP makes itself fullscreen
...
4) I close WMP
5) XBMC is below it

In terms of "fixing" the wider alt-tab "problem" IMVHO there's nothing wrong with XBMC making its window topmost, however, if it loses focus, which AFAICT (Win32 window management isn't my thing) can only happen if the user presses alt-tab then it should make itself NOTOPMOST until it regains focus.
Reply
#58
tvont Wrote:So I did...but, as you are the only one I know who is working on a fix for that, I hope, you get it to work outside win32.

Feel free any time to ask me to try on OSX.

Sorry tvont, I dont't have a Mac so I can't look at the OSX situation. We I get it working reasonably on Windows then I may find some time to look at Linux; that may help you.
Reply
#59
tvont Wrote:@Jester
tried on Vista...VLC gains focus after pressing CTRL-ALT-DEL, then ESC...Focus comes back to XBMC when the player is finished.
Think, here is something missing too

In windowed mode it works smooth.

Fullscreen is the main problem. My latest experimental works for me, on Vista, using Windows Media Player as the externalplayer, I'll give VLC as try when I get chance.
Reply
#60
moby-uk Wrote:The alt-tab "problem" is due to the fact that the XBMC window is "TOPMOST" which means it's above anything else that isn't "TOPMOST", most windows aren't so they are below XBMC even if they have focus; this was a change that went in in the "intel" patch.

The last experimental change to the externalplayer that Jester kindly built for me only changes the TOPMOST-ness of the XBMC window for the duration that the external player is running. For me, at least, the effect of having forceontop=true and hidexbmc=false is that when the externalplayer is launched

1) the taskbar becomes briefly visible above the XBMC window
2) the external player (in my case windows media player) appears over XBMC
3) WMP makes itself fullscreen
...
4) I close WMP
5) XBMC is below it

In terms of "fixing" the wider alt-tab "problem" IMVHO there's nothing wrong with XBMC making its window topmost, however, if it loses focus, which AFAICT (Win32 window management isn't my thing) can only happen if the user presses alt-tab then it should make itself NOTOPMOST until it regains focus.

thanks for that,

I'll update the intel vsync trac ticket with this info, so made captnbry or somebody can change the patch (now in SVN) so it reads to focus state (if that even can be done....or key combo) so it makes its NOTOPMOST when to user alt-tabs...
Reply
  •   
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 105
  •   



Logout Mark Read Team Forum Stats Members Help
[WINDOWS] External Player Support Thread11
This forum uses Lukasz Tkacz MyBB addons.