•  Previous
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 10
  • Next 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
[MAC] XBMCHelper (XBMC's IR-helper) new Beta version (with Logitech Harmony support)
#61
Just do that but also launch frontrow...
Reply
#62
Um, I downloaded your new links there on the last page.

My understanding was this would enable one to scroll left to right?

Well Its not. It seems to be as before with no changes?
Reply
#63
Mmm I rebooted my system and now same to work except first startup that I need to do by hand because xbmc isn't open but the service are launched.

Code:
$ ps aux | grep XBMC
DAddYE     263   0.1  0,0   599820    464 s000  S+    9:14pm   0:00.00 grep XBMC
DAddYE     207   0.0  0,1   355672   2608   ??  S     9:11pm   0:00.05 /Applications/XBMC.app/Contents/Resources/XBMC/tools/osx/XBMCHelper  -x
D
Reply
#64
garyi Wrote:Um, I downloaded your new links there on the last page.

My understanding was this would enable one to scroll left to right?

yeah, mine, too Tongue

garyi Wrote:Well Its not. It seems to be as before with no changes?
Please make sure you replaced XBMCHelper _and_ Keymap.xml.
What did you expect, what do you see? Is right/left working, just not the repeat stuff? Please be as detailed as you can, so we're able to fix something

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules. If you don't have the time to read them, please don't take the time to post in this forum!
For troubleshooting and bug reporting please make sure you read this first.
Reply
#65
hey DAddYE,

DAddYE Wrote:Mmm I rebooted my system and now same to work except first startup that I need to do by hand because xbmc isn't open but the service are launched.

hm, XBMC launches here with 'Menu' :/
You say after reboot, XBMC does not start by pressing 'Menu', but after XBMC was started/closed one time, it works?

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules. If you don't have the time to read them, please don't take the time to post in this forum!
For troubleshooting and bug reporting please make sure you read this first.
Reply
#66
Hi,

Quote:but after XBMC was started/closed one time, it works?

Yes after XBMC was started then closed if I press "menu" then works!

But some times (don't know why) also open frontrow...
Reply
#67
new version of XBMCHelper (v0.4) uploaded.
changes:
-proper app exit
-release remote on exit (so others, e.g. Sofacontrol, are notified to grab it)
-warn if IR cannot be opened exclusively

This may fix the occasional Frontrow starts.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules. If you don't have the time to read them, please don't take the time to post in this forum!
For troubleshooting and bug reporting please make sure you read this first.
Reply
#68
Hi MaestroDD

I did install both helper and the keymap and I did run chomd to enable the helper.

I expected it to allow me to hold left or right and scroll to occur just as up and down does.

However for me it does not it goes left or right once and sits there.

I use a harmony 1000. It does work in PLEX. I only mention this to say that I have not made any harmony software changes that would prevent this from working.

I am going to try your version above there and see if I have anymore luck.
Reply
#69
Is there any way to make it more responsive?
Right now it's quite the delay between each button press and gui interaction.
I know this might be a problem with the remote rather than xbmc.
Reply
#70
Ok, now I feel really stupid.

Where is the XBMC.app folder you guys are talking about?? are you talking about the xbmc folder in application support? cause I do see an xbmchelper file in there but it much small than the one I downloaded from the first page of this thread.

Is that the one or am I completely lost here?
Reply
#71
Nevermind, found my answer.
Reply
#72
hey modplug,

modplug Wrote:Is there any way to make it more responsive?
Right now it's quite the delay between each button press and gui interaction.
I know this might be a problem with the remote rather than xbmc.

I see the same here. And the AppleRemote for reference feels way snappier. The code isn't really straight forward, few indirections that can be removed, though I'm not sure that will help much.
Another thing to look into may be the Harmony configuration tool. There's some option to setup delays. Haven't played with it yet...

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules. If you don't have the time to read them, please don't take the time to post in this forum!
For troubleshooting and bug reporting please make sure you read this first.
Reply
#73
There is something you can try. it improves things a bit but not loads.

Open harmony software, click on devices, then on PLEX, and click trouble shoot.

In the next menu is something regarding delays, then the next menu you need to select 'my device is sending to many commands' the next menu you should find yourself on about 5 knock it down to 2. And then upload to your harmony.

Sorry I don't have the software available right now, but thats the gist of it.
Reply
#74
garyi Wrote:There is something you can try. it improves things a bit but not loads.

Open harmony software, click on devices, then on PLEX, and click trouble shoot.

In the next menu is something regarding delays, then the next menu you need to select 'my device is sending to many commands' the next menu you should find yourself on about 5 knock it down to 2. And then upload to your harmony.

Sorry I don't have the software available right now, but thats the gist of it.

Plex->Troubleshoot->PLEX responds to some commands either [...]
Setting it to 0 did the trick for me, and Harmony feels way snappier now.

Thanks for pointing this out!

The reason why it doesn't get even faster seems to be the timeout the Harmony uses to recognize hold-commands. IMHO this could be lowered...

cheers,
mdd

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules. If you don't have the time to read them, please don't take the time to post in this forum!
For troubleshooting and bug reporting please make sure you read this first.
Reply
#75
sorry but the keymap didn't work with the lastest stable version of babylon?

exit and back button are mapped as up/bottom

Thanks!
Reply
  •  Previous
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 10
  • Next 



[MAC] XBMCHelper (XBMC's IR-helper) new Beta version (with Logitech Harmony support)00