•   
  • 1
  • 33
  • 34
  • 35(current)
  • 36
  • 37
  • 192
  •   
  Thread Closed
[RELEASE] iPlayer - BBC Video and Music Plugin (UK only!)
Hitcher Wrote:Nothing plays basically.
Just tried recording something through the web interface provided by get_iplayer,cgi, it recorded the stream okay. (This is on a linux machine.)

Haven't tried via xbox, telly is tied up by other viewing.
...didn't you know there's an important prime ministerial debate going on...? Eh!




(Okay, I give in, yes it was me watching it. Can we really abide another five years of that irritating 5cotch man?)
spicemuseum Wrote:(Okay, I give in, yes it was me watching it. Can we really abide another five years of that irritating 5cotch man?)

Given the number of people who seem hell bent on throwing him a life raft with Nick Cleggs face on it it would seem yes.

What was that screeching sound, oh yes, the thread going off topic Laugh
I just tried exobuzz's XBMC build r29124 on my xbox and unfortunately it appears to have stopped working. It shows the same symptoms as the standard build, i.e. can get program listings but when trying to play a program it appears to cache the stream but then fails to play. This is different to the situation a few weeks ago when it would start to play on the standard build but would pause after a few seconds.
spicemuseum Wrote:Just tried recording something through the web interface provided by get_iplayer,cgi, it recorded the stream okay. (This is on a linux machine.)

Haven't tried via xbox...
...I have now. Using the workaround to stream via my linux server's get_iplayer.cgi, iPlayer on XB0X works as before. i.e. many, but not all items play (for example, about 6 of the 10 Timmy Time episodes play).
get_iplayer with rtmpdump works fine here also, but my linux xbmc patched with the new librtmp also doesn't work. Here is the log:

http://malus.exotica.org.uk/~buzz/xbmc.log

note this part after the handshake

Code:
17:13:32 T:2855947120 M:1444196352    INFO: RTMP_Connect1, handshaked
17:13:32 T:2855947120 M:1444196352    INFO: Invoking connect
17:13:32 T:2855947120 M:1444212736    INFO: RTMP_ClientPacket, received: invoke 134 bytes
17:13:32 T:2855947120 M:1444212736    INFO: (object begin)
17:13:32 T:2855947120 M:1444212736    INFO: Property: <Name:           no-name., STRING:    _error>
17:13:32 T:2855947120 M:1444212736    INFO: Property: <Name:           no-name., NUMBER:    1.00>
17:13:32 T:2855947120 M:1444212736    INFO: Property: NULL
17:13:32 T:2855947120 M:1444212736    INFO: Property: <Name:           no-name., OBJECT>
17:13:32 T:2855947120 M:1444212736    INFO: (object begin)
17:13:32 T:2855947120 M:1444212736    INFO: Property: <Name:              level, STRING:    error>
17:13:32 T:2855947120 M:1444212736    INFO: Property: <Name:               code, STRING:    NetConnection.Connect.Rejected>
17:13:32 T:2855947120 M:1444212736    INFO: Property: <Name:        description, STRING:    [ AccessManager.Reject ] : Access denied!>
17:13:32 T:2855947120 M:1444212736    INFO: (object end)
17:13:32 T:2855947120 M:1444212736    INFO: (object end)
17:13:32 T:2855947120 M:1444212736    INFO: HandleInvoke, server invoking <_error>
17:13:32 T:2855947120 M:1444212736   ERROR: rtmp server sent error
17:13:32 T:2855947120 M:1444212736    INFO: RTMP_ClientPacket, received: invoke 18 bytes
17:13:32 T:2855947120 M:1444212736    INFO: (object begin)
17:13:32 T:2855947120 M:1444212736    INFO: Property: <Name:           no-name., STRING:    close>
17:13:32 T:2855947120 M:1444212736    INFO: Property: <Name:           no-name., NUMBER:    0.00>
17:13:32 T:2855947120 M:1444212736    INFO: Property: NULL
17:13:32 T:2855947120 M:1444212736    INFO: (object end)
17:13:32 T:2855947120 M:1444212736    INFO: HandleInvoke, server invoking <close>
OK. I looked into it a bit. The auth parameter looked suspicious (auth=auth=" so I patched the IPlayer plugin so it sends auth= and it worked - I guess the beeb changed the XML somewhat so it had auth= in the xml. I'm just guessing mind as I didn't check that yet..

http://malus.exotica.org.uk/~buzz/xbmc/IPlayer.zip

get_iplayer also shows the auth=auth= but seems to work, which is a bit confusing.

Hope it works for you too.

[edit] quick note: Use this with my last xbox build. That works for me. Not all videos seem to work, but the majority do. I think this might related to a bbc update .. (http://www.bbc.co.uk/dna/mbiplayer/NF733...ad=7446313 - but I've not looked into it further)
Good to see this plugin working again !

Quote:Not all videos seem to work, but the majority do.

Same here - strange how the non working video's will play on my pc & Wii though Huh
exobuzz's latest xbox xbmc build, with patched iPlayer works fine for me, with the the exception of not playing certain programs. The latest episode of Doctor Who won't play, but a previous episode will... strange.

Thanks for your work exobuzz... much appreciated Nod
mobile Wrote:exobuzz's latest xbox xbmc build, with patched iPlayer works fine for me, with the the exception of not playing certain programs. The latest episode of Doctor Who won't play, but a previous episode will... strange.

Thanks for your work exobuzz... much appreciated Nod

if more recent videos need some additional changes to play, I will look into it (perhaps they have an additional level of authentication for the stream url). I guess we need to wait and see. Maybe the IPlayer plugin author can help with this a bit. I posted my patch to their bugtracker anyway (although there may well be a better way to fix it).
latest librtmp format patch for iplayer_2010-03-05, this requires xbmc to be patched with the latest librtmp from rtmpdump. Thanks to exobuzz for figure out the correct "auth" string.

http://trac.xbmc.org/attachment/ticket/8....patch.txt
exobuzz Wrote:OK. I looked into it a bit. The auth parameter looked suspicious (auth=auth=" so I patched the IPlayer plugin so it sends auth= and it worked - I guess the beeb changed the XML somewhat so it had auth= in the xml. I'm just guessing mind as I didn't check that yet..

http://malus.exotica.org.uk/~buzz/xbmc/IPlayer.zip

get_iplayer also shows the auth=auth= but seems to work, which is a bit confusing.
What's also confusing is that Dink released a bug-fix version of the plugin today (http://code.google.com/p/xbmc-iplayerv2/...-04-25.zip) after a discussion with you about the auth issue, but when I look at iplayer2.py in Dink's brand-new bug-fix plugin, it still shows the old line:
Code:
self.connection_href = "rtmp://%(ip)s:1935/%(application)s?_fcs_vhost=%(server)s&auth=%(auth)s&aifp=v001&slist=%(identifier)s" % params
I'm not a python coder so I may have completely misunderstood this. Can someone explain?
That line is commented out. it has

Code:
#self.connection_href = "rtmp://%(ip)s:1935/%(application)s?_fcs_vhost=%(server)s&auth=%(auth)s&aifp=v001&slist=%(identifier)s" % params
self.connection_href = "rtmp://%(ip)s:1935/%(application)s?_fcs_vhost=%(server)s&%(auth)s" % params

so the second line is run, not the first.
exobuzz Wrote:That line is commented out. it has

Code:
#self.connection_href = "rtmp://%(ip)s:1935/%(application)s?_fcs_vhost=%(server)s&auth=%(auth)s&aifp=v001&slist=%(identifier)s" % params
self.connection_href = "rtmp://%(ip)s:1935/%(application)s?_fcs_vhost=%(server)s&%(auth)s" % params

so the second line is run, not the first.
I can see what you did with the zip you posted, but I'm referring to the latest bugfix iplayer2.py posted by Dink.
[FX: double checking]
Ignore my post, I've clearly been at the Fonseca Guimarens 1985* a bit too much this evening.
Both yours and Dink's latest bugfix zips have the errant statement commented out replaced with the "working" auth statement.

Next step is to work out what's different about some iPlayer content that it refuses to play with either your special XB0X builds, or using the get_iplayer workaround.



* wonderfully feminine, apparently.
spicemuseum Wrote:What's also confusing is that Dink released a bug-fix version of the plugin today (http://code.google.com/p/xbmc-iplayerv2/...-04-25.zip) after a discussion with you about the auth issue
Yes, iPlayer back up and running (bar certain episodes). Big Grin
Just to note, that the new fix is slightly different from mine. This is because the BBC xml now contains the slist and other data in the auth line. it's all in one, hence the shorter line. I hadn't noticed this. The libRTMP IPlayer patch that s7mx1 posted could be updated accordingly to take this into account (although it works even with the parameters repeated of course)
  •   
  • 1
  • 33
  • 34
  • 35(current)
  • 36
  • 37
  • 192
  •   
  Thread Closed
 
Thread Rating:
  • 13 Vote(s) - 4.38 Average



Logout Mark Read Team Forum Stats Members Help
[RELEASE] iPlayer - BBC Video and Music Plugin (UK only!)4.3813
This forum uses Lukasz Tkacz MyBB addons.