Due to maintenance, our forum will be offline for a short while on Monday June 1st, around 22:00 UTC.

[LIVE] Problem with Thermaltuake DH101 + Soundgraph iMON LCD under XBMC Live 9.04.1
In December 2008 I bought a new and shiny big Plasma-TV and as a nearly first-day user of XBMC for XBOX I also wanted to run XBMC on my HTPC. I liked the Thermaltake DH-101 because of its integrated IR und LCD, bundled with a NVIDIA 9400 and a Intel E8400 for 1080p. Back in the old days everybody knew what you can do and how you have to move throught the XBMC-functions to avoid a crash in all the different releases. So I was prepared for this journey once again, but after over half a year, I now need your help with LIRC... :confused2:

I followed about 6 threads in different forums and the reason why I started a new one is because I don't like threads with hundreds of post about different hardware and linux versions where normal users get lost instantly... I will update this post with all the information and solutions I can find out, to help others getting it working as fast as possible. I'm not a total noob on linux, but I definitly lose myself in technical details and locations. So, here is my (at least) 10th try to set up LIRC, this time on a freshly installed XBMC Live 9.04.1:

followed the ubuntu documentation guide Setting Up LIRC For The IMON VFD and LCD Display:

Check the model device

lsusb | egrep -i 'soundgraph|imon'
Output: Bus 004 Device 003: ID 15c2:0038 SoundGraph Inc.

Remove existing LIRC
sudo /etc/init.d/lirc stop
sudo apt-get remove lirc lirc-modules-source lcdproc
Output: Stopping remote control daemon(s): LIRC [OK]
Removing lirc ...
* Stopping remote control daemon(s): LIRC [fail]

Install dependencies
sudo apt-get install dialog setserial linux-libc-dev libc6 libc6-dev automake autoconf gcc gcc-4.2 gcc-4.2-base libgcc1 libtool patch dkms
Output: A lot Smile But everything looks fine

Download source
There's no part about jaunty, so I just followed the first instruction... don't know if thats correct
sudo apt-get install libasound2 libasound2-dev lirc lirc-modules-source
Output: Setting up lirc-modules-source (0.8.4a-0ubuntu5) ...
Adding Module to DKMS build system
Doing initial module build
Installing initial module
Warning! Cannot do version sanity checking because multiple lirc_mceusb2.ko
modules were found in kernel 2.6.28-11-generic.
Warning! Cannot do version sanity checking because multiple lirc_mceusb.ko
modules were found in kernel 2.6.28-11-generic.

I googled the warnings, but didn't found anything... so I move on.

sudo rm /etc/lirc/hardware.conf
sudo nano /etc/lirc/hardware.conf
and paste
# /etc/lirc/hardware.conf
#Chosen Remote Control
REMOTE="Soundgraph iMON IR/LCD"
REMOTE_MODULES="lirc_dev lirc_imon"

#Chosen IR Transmitter

#Enable lircd

#Don't start lircmd even if there seems to be a good config file

#Try to load appropriate kernel modules

# Default configuration files for your hardware if any

#Forcing noninteractive reconfiguration
#If lirc is to be reconfigured by an external application
#that doesn't have a debconf frontend available, the noninteractive
#frontend can be invoked and set to parse REMOTE and TRANSMITTER
#It will then populate all other variables without any user input
#If you would like to configure lirc via standard methods, be sure
#to leave this set to "false"

sudo nano /etc/lirc/lircd.conf
and paste
begin remote

  name     iMON-PAD
  bits           32
  eps            30
  aeps          100

  one             0     0
  zero            0     0
  gap          235965
  min_repeat      1
  toggle_bit      0

      begin codes
          AppExit                  0x288195B7
          Record                   0x298115B7
          Play                     0x2A8115B7
          SlowMotion               0x29B195B7
          Rewind                   0x2A8195B7
          Pause                    0x2A9115B7
          FastForward              0x2B8115B7
          PrevChapter              0x2B9115B7
          Stop                     0x2B9715B7
          NextChapter              0x298195B7
          Esc                      0x2BB715B7
          Eject                    0x299395B7
          AppLauncher              0x29B715B7
          MultiMon                 0x2AB195B7
          TaskSwitcher             0x2A9395B7
          Mute                     0x2B9595B7
          Vol_Up                   0x28A395B7
          Vol_Down                 0x28A595B7
          Ch_Up                    0x289395B7
          Ch_Down                  0x288795B7
          Timer                    0x2B8395B7
          1                        0x28B595B7
          2                        0x2BB195B7
          3                        0x28B195B7
          4                        0x2A8595B7
          5                        0x299595B7
          6                        0x2AA595B7
          7                        0x2B9395B7
          8                        0x2A8515B7
          9                        0x2AA115B7
          0                        0x2BA595B7
          ShiftTab                 0x28B515B7
          Tab                      0x29A115B7
          MyMovie                  0x2B8515B7
          MyMusic                  0x299195B7
          MyPhoto                  0x2BA115B7
          MyTV                     0x28A515B7
          Bookmark                 0x288515B7
          Thumbnail                0x2AB715B7
          AspectRatio              0x29A595B7
          FullScreen               0x2AA395B7
          MyDVD                    0x29A295B7
          Menu                     0x2BA385B7
          Caption                  0x298595B7
          Language                 0x2B8595B7
          MouseKeyboard            0x299115B7
          SelectSpace              0x2A9315B7
          MouseMenu                0x28B715B7
          MouseRightClick          0x688481B7
          Enter                    0x28A195B7
          MouseLeftClick           0x688301B7
          WindowsKey               0x2B8195B7
          Backspace                0x28A115B7
          Space                    0x2B9B15F7
          Up                       0xEB53F9B7
          Left                     0x6ABAFFBF
          Down                     0x6F9ECBB7
          Right                    0x69A281B7

      end codes

end remote

check permissions
ls -l /etc/lirc
Output: -rw-r--r-- 1 root root 1108 2009-07-09 09:32 hardware.conf
-rw-r--r-- 1 root root 1139 2009-07-09 09:26 hardware.conf.old
-rw-r--r-- 1 root root 3347 2009-07-09 09:36 lircd.conf
-rw-r--r-- 1 root root 571 2009-04-21 09:01 lircd.conf.dpkg-old
-rw-r--r-- 1 root root 121 2009-04-21 09:01 lircmd.conf

is_lcd parameter
Another part of the guide I can't follow. There is no options file in this folder.
ls /etc/modprobe.d/
Output: alsa-base.conf blacklist.conf blacklist-framebuffer.conf blacklist-oss.conf dkms.conf
blacklist-ath_pci.conf blacklist-firewire.conf blacklist-modem.conf blacklist-watchdog.conf

And if there would be one, what to do with the 0038 device?

Shutdown and reboot
sudo reboot
sudo /etc/init.d/lirc restart
* Stopping remote control daemon(s): LIRC [fail]
* Loading LIRC modules [ OK ]
* Unable to load LIRC kernel modules. Verify your
* selected kernel modules in /etc/lirc/hardware.conf
ls -l /dev/lirc*
Output: ls: cannot access /dev/lirc*: No such file or directory

So its not working... I read so many different guides I totally lost the overview, in other guides (like the one found here) you have to compile, patch and ln somewhere, here I have to many .ko files... but the only thing in common is: it's not working Smile

neverending gratitude for everyone who read the post. even more for those who can help me...

I'm also interested here. Does anybody have an idea?
I have the same 15c2:0038 device in a Silverstone case. I have it working in ubuntu but I'm still trying to get it working within xbmc.

I couldn't get it to work with lirc 0.8.4a either. I'd suggest trying 0.8.5 (which is what I finally got to work). Many people also report success with the cvs version of lirc, but when I tried it (over a month ago) I couldn't get the cvs to work - the cvs seems to be fairly unstable and bugs are introduced and fixed fairly often.

Instead of giving a full installation howto I'll point you to a thread on ubuntu forums which I found very helpful:

The instructions in the first post are for installing the cvs version. You need to have previously installed a version of lirc (0.8.4a should be OK) which you will then remove for those instructions to work.

Later in the thread I've made a few posts about installing 0.8.5 - basically download the 0.8.5 source off the lirc website and follow the instructions in the first post of the thread - but omit the downloading/installing of the cvs version (step 3) and instead install the 0.8.5 version using a standard:
sudo checkinstall

Worked for me in Jaunty. Hope that makes sense and helps you.
Oh, I should also mention you will need the correct lircd.conf for your remote. From what you posted it looks like you have the imon pad remote.

I found the lircd.conf here:

worked with my imon pad remote but it will depend which version of the imon pad you have.
Did anyone actually get anywhere here?? Just trying to nut this out myself right now...
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
[LIVE] Problem with Thermaltuake DH101 + Soundgraph iMON LCD under XBMC Live 9.04.100
This forum uses Lukasz Tkacz MyBB addons.