•  Previous
  • 1
  • 16
  • 17
  • 18
  • 19
  • 20(current)
Thread Rating:
  • 0 Vote(s) - 0 Average
Linux - HOW-TO install XBMC for Linux on Asrock ION 330 with full Ubuntu Desktop
You can try 'dpkg-reconfigure lirc-modules-source'. (and maybe remove the "old" modules manually if it does not work)
freaksworth is not connected to or in any other way affiliated with XBMC, Team XBMC, or the XBMC Foundation.
freaksworth Wrote:You can try 'dpkg-reconfigure lirc-modules-source'. (and maybe remove the "old" modules manually if it does not work)

i will give it a shot thanks
didnt work
vikjon0 Wrote:Now updated for Karmic!

USB disks does not work correctly in Karmic. Stay with 9.04 until a stable Lucid is out.

I have now finished the setup of my brand new Asrock ION 330 and though someone could have some use of my notes.

Killasample plays fine, it drops 4-6 frames. I am not sure if that is considered a problem.

My setup is more or less the same as the wiki:
+ some ION 330 specific stuff

Installation Log:
Change shared memory => 512
Upgrade BIOS => 1.60 (Download DOS version, unzip and put on USB => Smart Flash in BIOS)
Remove the boot logo
Enable "good night LED" if you want all light of on the box.

Other than that no changes to BIOS (No over clocking)


1) Install Ubuntu 9.04 (or 9.10) (user/pwd xbmc/xbmc)
The easiest method is to install the desktop cd. I dont do that, instead I do a minimal install +
sudo apt-get install xorg gdm gnome-core network-manager-gnome gnome-system-tools gnome-utils x11-xserver-utils

Since the disk is pretty big you should probably create a separate partition for media. This way you can re-install without wiping the media. You need much less than 10G for the system but since we have plenty of it I normally use 8-10 for the system and 3-4 for swap. Create and format a partition of the remaining space and remember the file system (ext2 or ext3). Do not mount it at this point.

2) Install all updates

3) Enable auto-login for XBMC

4) install ssh
sudo apt-get install ssh

*from now on I do everthing over ssh from my winxp laptop using putty.exe

Since my MS MCE Remote model 1039 does not work in xbmc without LIRC I installed it

1) sudo apt-get install -y lirc
Select Windows MCE Remote (new)

2) Test Remote & Lirc
Type: IRW
in terminal and press home MCE Home button. This should return "Home" in terminal

a)Add sources 9.10
sudo apt-get install python-software-properties
sudo add-apt-repository ppa:team-xbmc/ppa
* I will add add-ons soon

b)Add sources 9.04 (old and not verified)
sudo nano /etc/apt/sources.list
deb http://ppa.launchpad.net/xbmc-addons/ppa/ubuntu jaunty main
deb http://ppa.launchpad.net/team-xbmc/jaunty-ppa/ubuntu jaunty main

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 318C7509 9317790E

3) install
sudo apt-get update
sudo apt-get install xbmc xbmc-standalone

sudo apt-get install xbmc-skin-*
sudo apt-get install xbmc-eventclients-*
sudo apt-get install xbmc-scripts-*

NVIDIA Drivers
* For 9.10 Karmic I am using the incudded version 185 driver

Edit: Install nvidia PPA instead to avoid problem when upgrading kernel

1) Add source
sudo nano /etc/apt/sources.list
deb http://ppa.launchpad.net/nvidia-vdpau/ppa/ubuntu jaunty main

3) Add key
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com CEC06767

4) Install
sudo apt-get update
sudo apt-get install linux-headers-generic nvidia-glx-185

5) Config
sudo nvidia-xconfig -s --no-logo --force-generate

Policy kit to allow Power management
*9.10 karmic: sudp apt-get install policykit
*Not sure if this can be skipped for 9.10 Karmic or not

sudo polkit-auth --user xbmc --grant org.freedesktop.hal.power-management.suspend
sudo polkit-auth --user xbmc --grant org.freedesktop.hal.power-management.hibernate
sudo polkit-auth --user xbmc --grant org.freedesktop.hal.power-management.reboot
sudo polkit-auth --user xbmc --grant org.freedesktop.hal.power-management.shutdown
sudo polkit-auth --user xbmc --grant org.freedesktop.hal.power-management.reboot-multiple-sessions
sudo polkit-auth --user xbmc --grant org.freedesktop.hal.power-management.shutdown-multiple-sessions

Additional policy settings for 9.10 Karmic

sudo apt-get install policykit-1 devicekit-power

sudo nano /var/lib/polkit-1/localauthority/50-local.d/custom-actions.pkla
[Actions for xbmc user]

XBMC Config
1) Start XBMC in Gnome

2) Change same settings
Settings, appearance, screen: Fullscreen

3) If you want to use sound over HDMI:
In latest version of xbmc just select hdmi in menu

If sound is playing too fast try with custom:
plug:hdmi or plughw:0,3

ALSA config
1) sudo alsamixer
Unmute and set volume (MM means muted and OO On)
Hit "m" to toggle mute on/off.
Do not forget to unmute HDMI if you are going to use that

2) Store Settings
sudo alsactl store 0

3) If any problem with store, remove pulse audio and try again
sudo apt-get remove pulseaudio

Fix navigation sound with HDMI (not needed anymore?)

Create a file in home directory:
nano .asoundrc


pcm.!default {
type plug
slave {
pcm "hdmi"

Wifi WPA2 in XBMC session (USB adaptor)
1) Left click on network icon and select network & Connect
2) Right click on network icon , edit connecttions, wireless, select network, Edit - Click Always allow - Check Available to all users
- check remember autorization & enter password
3) Reboot and make sure that no dialog is necessary to connect wifi => Should work fine in the XBMC session.

There is a bug in karmic network-manager. When mking connection available for all users this just causes the connection to disappear
set "managed=true" in [ifupdown] section in /etc/NetworkManager/nm-system-settings.conf

XBMC session
To boot directly into the XBMC session:

1) Logout - F10 - select Session - XBMC
First time select "just this time" when function verified repeat and set to defalt session

2) Return to login by exiting XBMC

3) Back to Gnome
F10 - Select session - Gnome

Suspend/ Resume on Remote
Seem to work out of the box (in 9.04 Juanty)
Resume by pressing Power button on remote.

Update System
sudo apt-get update
sudo apt-get upgrade

xorg fixes
HW cursor fix
sudo sed -i '40i\ Option "HWCursor" "False"' /etc/X11/xorg.conf

ENABLE 1080p 24Hz (screen section)
sudo sed -i '50i\ Option "DynamicTwinView" "False"' /etc/X11/xorg.conf
sudo sed -i '50i\ Option "FlatPanelProperties" "Scaling = Native" /etc/X11/xorg.conf

Make sure it ended up in the correct sections (I am not sure that this sed stuff is working):
sudo nano /etc/X11/xorg.conf

Mount a partition
View partitions:
sudo fdisk -l
Hopefully you can find your unmounted partition. (if not or if you did not create the partition you need to install gparted)
In my case the partition is /dev/sda3
Create a mount point (in this case a folder in the root):
sudo mkdir /storage
Edit the fstab:
sudo cp /etc/fstab /etc/fstab_backup
sudo nano /etc/fstab
/dev/sda3 /storage ext2 defaults 0 0
ext2 since I remember selecting that when I created the partition.
sudo mount -a
5) set permissions
sudo chown -R xbmc:xbmc /storage
sudo chmod -R 755 /storage

1) I have also installed NX server to access the GUI while using xbmc in the console.
2) I only use xbmc in the standalone session now. If it should be used in Gnome irexec and some addition scripting is necessary to make it play nice.
3) I use deluge bittorrent client in a NX session in the background. Transmission did not work for me. With deluge it is back to normal.

Looking for some help..

I was sent your procedure by jacksback.

I have been trying to install xbmc on Ubuntu 9.10 (Karmic Koala). I am following the proceedure from the link below. The issue I am having is with the PPAs. The system does not seem to see them. I have tried everything I can think of at this point short of reinstalling Ubuntu.

I get the message xbmc: Depends: xbmc-data xxxxx but is not going to install E: Broken packages.....

Yes the multiverse repository is enabled.
I have tried to manually added them in /etc/apt/sources.list

The mother board is a
Zotac Synergy Edition Atom N230 1.6GHz Mini-ITX Motherboard IONITX-E-E
With 2 Gig of memory and 160 Gig STAT drive

Link to the procedure:


Is there something I am missing?
Hey moultonr

Not too sure why you having issues with repositories but maybe a reinstall is the best option. I too have a Zotac board but with Intel CPU and onboard Graphics. I found that 10.10 was better suited for my board. After installing I followed the instructions on the Tvheadend thread and successfully installed XBMC first time. Maybe you have some older repositories that are interfering with your update so a fresh install will clear them.

Good Luck
Hey jacksback,

Would you happen to have the link to the guide that you followed? (I'm in a similar situation whereby I have a zotac board but I'm having a heck of a time getting it to work properly)
Recently reinstalled with 12.04 (OMG unity sucks)
I only got sound working using the custom plughw:0,3 setting (after unmuting in alsamixer) but had no sound in ubuntu. (need some webbrowsing working aswell).

Ubuntu sound preferences had no HDMI option.
This page hinted on two solutions: http://forums.boxee.tv/showthread.php?t=9617 to use pulseaudio instead

a) add to /etc/pulse/default.pa
load-module module-alsa-sink device=hw:0,3
b) install pavucontrol
This lets you configure HDMI as default output.
c) just use default in xbmc
Hey guys,

Brand new not only to this forum but to XBMC, linux and Asrock 330! Smile

I was orginally planning to run Plex on a Mac Mini but managed to get an old asrock 330 for a cheap price and now want to install ubuntu & xbmc on it.

Have a couple of questions:

1) Is there a guide for dummies (me) on how to install ubuntu and xbmc?
2) Does it support the orginal remote that you get with asrock?
3) Currently all of my media is stored on 3-4 external USB drives. Do I need to do anything with them for XBMC to find them? (perhaps change formatting on them?)

1) This is such a guide, but out of date
2) Not this guide, but it will work more of less out of the box in a current Ubuntu (I think)
3) Just plug them in but if you want to use them in the library you have to manually mount them on UUID to prevent Ubuntu to change the order of the disks.

I recommend you to try the xbmcbuntu release. You will find it on xbmc.org.

I've just published a howto & .asoundrc for the Asrock 330, to have simultaneous output to both SPDIF and HDMI, and AC3 5.1 sound without passthrough (so volume can be controlled inside XBMC).


Works pretty good for me, hope it helps. I use it for XBMC standalone sessions.
If you interested in icon editing, try IconLover icon editor.
If you interested in icon editing, try IconLover icon editor.
  •  Previous
  • 1
  • 16
  • 17
  • 18
  • 19
  • 20(current)

HOW-TO install XBMC for Linux on Asrock ION 330 with full Ubuntu Desktop00