Thread Rating:
  • 0 Vote(s) - 0 Average
Samsung Television with DLNA client and XBMC UPnP Media Server?
I'm trying to stream audio from my iMac to a samsung tv (LE40B750) by DLNA. I can see all files and folders, but when I try to open a file it says "file format not supported".
I know that for Mediatomb there exists a similar problem and there you need to change the configuration file to use custom headers like:

<add header=" Streaming">
<add header=" DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=017000 00000000000000000000000000">

Is it possible to do something similar for XBMC? And if yes, where can I change this?

Thanks in Advance!
can't make it run with beta1 :/ it is a bug?
my samung tv show dlna categories Video Files, Video Library ..but after entering folder there is an error ontv ..maybe i have to add folder to shown under upnp server? how to do this?
DLNA is a standard for streaming audio and video over the network - and should be used as such.

You should be able to setup the UPNP streaming option in xbmc and pick the library files up in the television - not the interface though.

I would personally prefer a standalone server with lightweight UPNP server if you want to use that - but mostly i would prefer as previous speaker said - a little ion box connected with hdmi and a separate remote
Hi, were u able to correct the problem and manage to get ur movies on ur tv to stream to the samsung tv? I get the same error message. I tested the movie via a usb stick, and it worked fine, but when i stream it, i get the error response like u.

Please help.

Hey there,
I just bought a new Samsung UE32C6700 and I'm really happy with it.
Now I want to stream videos from XBMC to the TV using AllShare (Samsungs DLNA-Certified App).
I enabled UPNP with Settings -> Network -> Share Videos On, Allow Controll via UPNP on, Allow Programs on other Systems to controll XBMC on.

With the latest stable version (9.11) on my linux, the XBMC UPNP-Server doesn't even show up in the upnp-inspector running on the same computer, and so the TV doesn't detect it either, although the logs says
Quote:19:55:34 T:139952344565824 M:3268313088 NOTICE: starting upnp server
19:55:34 T:139952344565824 M:3268186112 NOTICE: starting upnp renderer
Firewalls etc disabled. Maybe I'll try that again later (wait a longer time or so, don't know).

On my Windows-Laptop I have a nightly-build ("NOTICE: Starting XBMC, Platform: Windows 7, 64-bit (WoW) build 7600. Built on Jul 11 2010 (SVN:31718, compiler 1500)"). I tried the same here, and XBMC does show up in the upnp-inspector and after some time even in AllShare on the TV, but I'm unable to access any videos from here. I always get "Request couldn't be executed." (own translation) when trying to access the video- or music-library. debug-log:
Quote:20:33:07 T:4924 M:2058293248 DEBUG: UPnP Translated id to 'videodb://'
20:33:07 T:4924 M:2058293248 INFO: Received UPnP Browse DirectChildren request for object 'videodb://'
20:33:07 T:4924 M:2058293248 DEBUG: Loading fileitems [videodb://]
20:33:07 T:4924 M:2058289152 DEBUG: -- items: 2, directory: videodb:// sort method: 0, ascending: false
20:33:07 T:4924 M:2058289152 DEBUG: Building UPnP response with filter '*', starting @ 0 with 1 requested
20:33:07 T:4924 M:2058289152 DEBUG: Preparing upnp object for item 'videodb://1/'
20:33:07 T:4924 M:2058264576 DEBUG: Building didl for object 'videodb://1/'
20:33:07 T:4924 M:2058264576 DEBUG: Returning UPnP response with 1 items out of 2 total matches
There are 83 videos on a SMB-share, accessing and viewing them directly with XBMC works fine.

Another strange thing: My Router (TP-Link TL-R460) has a "UPnP-Forward"-Feature:
Quote:The Universal Plug and Play (UPnP) feature allows the devices, such as Internet computers, to access the local host resources or devices as needed. UPnP devices can be automatically discovered by the UPnP service application on the LAN.
It's enabled, but the device list doesn't show any device.. But because upnp-inspector detects the TV and the XBMC from Windows, I'm sure this is just a bug from the router-firmware.

I googled a lot (and I have to say the UPnP-Wiki-Page is a great way to find software, but not to set it up or to debug it (at least not for xbmc as a upnp-server)), but haven't found any hint.

Does anybody here has set this up properly? how? Is there a bug in the nightly-build so that sharing is not possible (I saw this report, maybe its related to it? (But then it would be a grave issue, not just a small one))?

Greets and Thanks,
I'm considering purchasing a new 50" Plasma TV and Samsung has two models: one with ethernet (7000 series) that has AllShare Samsung apps and another model (680) without. So obviously, the 680 is cheaper.
I have a PS3 for media and games but I'm considering XBMC over it as it supports MKV.

I want to know if I go with the TV without the ethernet will that impact me by any chance? I'm new to all of this.

XBMC will connect to your TV thru the Video inputs so the network is irrelevant as far as XBMC is concern, however, I'd still go with the net option if affordable for future expansions.
buy the cheaper Tv and use HDMI cable to connect to your TV.

Thank you for your help.

I checked the prices two and both TV have ethernet connectivity. One with Samsung [email protected] apps and the other without.

Has anyone used it? and how does those apps compare to XBMC ?
I have a Samsung Bluray player with [email protected] apps on it. Is is nice for Netflix, and they have some movie rental services. But it is really a completely different beast then XBMC. I see XBMC is really used to play things you have locally, movies, music, and pictures. The [email protected] stuff seems more internet based. While I see them as different, the XBMC UI is much better than the Samsung. It could just be my player, but it really lags, and for comparison sake Netflix on the Xbox 360 works much better.

If you can afford it, I would follow Czechmarty's advice and get the one with the [email protected] just to have more options in the future. You may still want to use it to rent movies or watch Netflix on.
Thank you for your reply jschoen. I decided to go with the [email protected] TV as the price difference was $150 or so and as you said and Czechmarty, it would be good investment in the future. I will probably rely on XBMC for all of my local media. XBMC addons compliment the local with some internet capability.

I wish XBMC would come integrated with Samsung TV rather than their slow yahoo based widgets.
ChocoboX Wrote:Thank you for your reply jschoen. I decided to go with the [email protected] TV as the price difference was $150 or so and as you said and Czechmarty, it would be good investment in the future. I will probably rely on XBMC for all of my local media. XBMC addons compliment the local with some internet capability.

I wish XBMC would come integrated with Samsung TV rather than their slow yahoo based widgets.

Congrats on your purchase mate! I hope the new TV will serve you well. I'm sure after Dharma will settle down, there will be more addons for internet as well in XBMC. The Netflix is very nice addition for the TV.
I recently got a Samsung C550 TV w/ ethernet. It has a very rudimentary media player based on pnp. I set up an app called Media Tomb on my Unraid server, and can get access to my entire video library on the Samsung. It plays pretty much anything I throw at it, including 1080p MKV files. However, the interface and functionality are nowhere near as nice as XBMC.
I was also looking at the Samsung (LED) 5/6/7 series with the Ethernet and was wondering about something.

Is/would it be possible to access one`s XBMC library via a browser interface?
Thus an XBMC web server if you will...

It would be awesome if it 'streamed' content to devices/machines instead of just using it as a remote control function.

k never mind
It`s rather slow and buggy but would like to see some more development.
Kodi - Windows 7_x64 14.2 Helix
OpenELEC - Generic x86_64 v5.0.8
OpenELEC - Raspberry Pi2 v5.0.8
Ember media manger (thx DanCooper)
Media Companion v3.620b (thx Vbat99)
Rashad TVRenamer 0.7 Beta 2/EPnamer v1.45

I have a Samsung LE32C550 TV with Allshare. It plays MOST of the files I've tried to stream though I've had some MKV's that just wouldn't start. Also on MKV's there's no real Fast Forward or Rewind which can be quite annoying. It's a bedroom TV and I accidentally hit the Ch+ button the other day when trying to turn the Volume down at the end of Karate Kid. That turned the movie off so I was then forced to get out of bed and watch the last 10 minutes in the living room on the Popcorn hour. Not good.

Also I had to do some Linux jiggery-pokery on my Synology NAS as I don't keep my Movies etc in standard DLNA folders so the Samsung couldn't find them. XBMC took a few seconds for me to point to the correct folders.

The GUI on the Samsung insn't a patch on XBMC either.

Just my 2p worth.

Samsung Television with DLNA client and XBMC UPnP Media Server?00