Problem installing xbmc
#1
Hi, I'm new using Ubuntu so bear with me. I've installed Ubuntu 9.04 and I was trying to install xbmc by following guides. However, I got an error during installation:

Depends: xbmc-common but it is not going to be installed
Depends: xbmc-skin-pm3 but it is not going to be installed
Depends: xbmc-pm3 but it is not going to be installed

How do I solve this problem?
Reply
#2
you're missing libass

Code:
wget https://launchpad.net/~team-xbmc/+archive/jaunty-ppa/+files/libass-dev_0.9.6-1xbmc1_i386.deb

wget https://launchpad.net/~team-xbmc/+archive/jaunty-ppa/+files/libass3_0.9.6-1xbmc1_i386.deb

sudo dpkg -i libass-dev_0.9.6-1xbmc1_i386.deb

sudo dpkg -i libass3_0.9.6-1xbmc1_i386.deb

should fix it, altho i did have another dependency issue too
Reply
#3
Hi thanks for replying but I still couldn't get xbmc to install!

Heres the outcome:

[email protected]:~$ wget https://launchpad.net/~team-xbmc/+archiv...1_i386.deb
--2009-11-07 13:53:47-- https://launchpad.net/~team-xbmc/+archiv...1_i386.deb
Resolving launchpad.net... 91.189.89.222, 91.189.89.223
Connecting to launchpad.net|91.189.89.222|:443... connected.
HTTP request sent, awaiting response... 302 Moved Temporarily
Location: http://launchpadlibrarian.net/35196206/l...1_i386.deb [following]
--2009-11-07 13:53:48-- http://launchpadlibrarian.net/35196206/l...1_i386.deb
Resolving launchpadlibrarian.net... 91.189.89.228, 91.189.89.229
Connecting to launchpadlibrarian.net|91.189.89.228|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 47020 (46K) [application/x-debian-package]
Saving to: `libass-dev_0.9.6-1xbmc1_i386.deb'

100%[======================================>] 47,020 --.-K/s in 0.08s

2009-11-07 13:53:48 (591 KB/s) - `libass-dev_0.9.6-1xbmc1_i386.deb' saved [47020/47020]

[email protected]:~$ wget https://launchpad.net/~team-xbmc/+archiv...1_i386.deb
--2009-11-07 13:54:07-- https://launchpad.net/~team-xbmc/+archiv...1_i386.deb
Resolving launchpad.net... 91.189.89.223, 91.189.89.222
Connecting to launchpad.net|91.189.89.223|:443... connected.
HTTP request sent, awaiting response... 302 Moved Temporarily
Location: http://launchpadlibrarian.net/35196207/l...1_i386.deb [following]
--2009-11-07 13:54:08-- http://launchpadlibrarian.net/35196207/l...1_i386.deb
Resolving launchpadlibrarian.net... 91.189.89.229, 91.189.89.228
Connecting to launchpadlibrarian.net|91.189.89.229|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 43774 (43K) [application/x-debian-package]
Saving to: `libass3_0.9.6-1xbmc1_i386.deb'

100%[======================================>] 43,774 --.-K/s in 0.07s

2009-11-07 13:54:08 (587 KB/s) - `libass3_0.9.6-1xbmc1_i386.deb' saved [43774/43774]

[email protected]:~$ sudo dpkg -i libass-dev_0.9.6-1xbmc1_i386.deb
[sudo] password for xbmc:
dpkg: error processing libass-dev_0.9.6-1xbmc1_i386.deb (--install):
package architecture (i386) does not match system (amd64)
Errors were encountered while processing:
libass-dev_0.9.6-1xbmc1_i386.deb
[email protected]:~$ sudo dpkg -i libass3_0.9.6-1xbmc1_i386.deb
dpkg: error processing libass3_0.9.6-1xbmc1_i386.deb (--install):
package architecture (i386) does not match system (amd64)
Errors were encountered while processing:
libass3_0.9.6-1xbmc1_i386.deb
Reply
#4
ok you didnt say which processor etc
you need the amd64 ones

Code:
wget https://launchpad.net/~team-xbmc/+archive/jaunty-ppa/+files/libass-dev_0.9.6-1xbmc1_amd64.deb

wget https://launchpad.net/~team-xbmc/+archive/jaunty-ppa/+files/libass3_0.9.6-1xbmc1_amd64.deb

sudo dpkg -i libass-dev_0.9.6-1xbmc1_amd64.deb

sudo dpkg -i libass3_0.9.6-1xbmc1_amd64.deb
Reply



Logout Mark Read Team Forum Stats Members Help
Problem installing xbmc0
This forum uses Lukasz Tkacz MyBB addons.