•   
  • 1
  • 200
  • 201
  • 202(current)
  • 203
  • 204
  • 315
  •   
  Thread Closed
Release [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
Sorry if this has been mentioned already, but has anyone noticed that some videos have a small amount of static when playing?
login don't work.
LOG http://pastebin.ca/2326822
Login failed - false.

Debug log - http://pastebin.com/05bCNGyJ

By the way guys - suggesting pastebin.ca as a place to put debug logs (on this page: http://code.google.com/p/youtubexbmc/wik...oginIssues) - not a good idea. On my machine, opening XBMC then using the button on my remote which shortcuts to YouTube plugin and making the login fail again for the log is enough to produce a log far too big for the measly 150000 bytes limit, which triggers this "helpful" message:

"We did say the maximum allowable file size is 150,000 bytes. You sent us a file that is too big. Sorry, it is being ignored."

Then due to some problem with pastebin.ca's somewhat broken uploader, XBMC wouldn't open again because the log wasn't writable. Windows 7 reported Firefox still had it open. Simple enough to delete without closing Firefox due to me having Unlocker installed to do DLL hacks, but still annoying. So yeah, I'd ditch pastebin.ca to be honest!
(2013-02-22, 21:08)cw-kid Wrote: YouTube Video Download Location:

I added a SMB path in to the YouTube add-on settings for the download location. However when I download a YouTube video it does not save it in my path on the server.

Instead I find the Video files are on the XBMC PCs local drive in this folder:

/home/xbmc/.xbmc/userdata/addon_data/script.module.simple.downloader

Anyway to fix this?

Thanks

It looks like it is fixed in the latest beta, unfortunately it is a pain for me to try it on OpenElec, but hopefully it will be fixed in the next non beta also. Give it a try.
https://code.google.com/p/youtubexbmc/wi...BetaPlugin

Full Changelog
Version 2.5.0 (Beta)

Added new option to select playback and download quality with dialogs
Added Caching and alphabetically sorting of My playlists, My contacts and My subscriptions
Added "Play all" context menu on certain folders
Added "Shuffle and Play All" Context menu on certain folders
Added "Play All from video position in certain folders (ie. playlists and other non-infinite folders)
Added Playback of YouTube Live streams
Added Caching of playlist and option to reverse playlist order
Added playback of WebM streams if user enables it on his/her profile
Added Date for sorting
Added "Auto-magic" re-login on token verfication failure
Added 2 new feeds: "most shared" and "trending videos" that gives a better "pulse" of youtube videos.
Added YouTube live scraper under explore youtube
Added YouTube Top 100 music chart scraper
Added YouTube Music and Artist scraper
Added YouTube My Watch Later scraper
Added YouTube My liked Video scraper
Added socket timeout since that makes now appears to work on windows
Added New download dialog showing queue and progress completion.
Added support for xbmcvfs in downloads. (ie. download to temp folder then let xbmc move to final location)
Added support for using embedded link to get video information, and hopefully improve playback stability
Changed Login to use new Client Login url
Changed Playback function now shows a more user friendly error message on failure
Changed Download function now shows a progress-bar
Changed Download function will now only download one file at a time and queues multiple files.
Changed "Disco Top 25 / 50" to "YouTube weekly top 100" scraper since disco top 50 was removed from YouTube
Changed plugin will now play a video from file-system if the file is still in the download folder (Partially working as this has revealed XBMC bug.)
Changed more videos by user, and related videos so you no longer have to be logged in for them to work.
Refactor: Simplify playback code
Refactor: Large scale refactor to make code more maintainable
Fixed Age Verification for 18+ content was broken by YouYube.
Fixed notifications on empty folders
Fixed Playback of very low resolution videos
Fixed scraper pagination
Fixed Disco scraper it was broken again.
Fixed add remove favorites
Fixed add remove subscription
Fixed broken Movies Scraper (from patch by [email protected])
Fixed problems when downloading a file to a network drives (thanks to [email protected])
Fixed download subtitles when download a video
Fixed XBMC not refreshing folder after download completes.
(2013-03-01, 00:06)carax Wrote: login don't work.
LOG http://pastebin.ca/2326822
Same here. Login stopped working for me yesterday (this was after I did a clean install). Getting the error "Login Failed - False".
(2013-03-02, 17:21)XeroKool Wrote:
(2013-03-01, 00:06)carax Wrote: login don't work.
LOG http://pastebin.ca/2326822
Same here. Login stopped working for me yesterday (this was after I did a clean install). Getting the error "Login Failed - False".

Same error here Sad
I tried to download a video, and the download dialog hung. I'm guessing that it hung because there was a login prompt because of explicit language (or at least that's what happened when I tried it in my browser) for the video in question. The problem now is that XBMC hangs on exit presumably because Youtube is stuck. I think the video is still in the queue. I've tried disabling the add-on, uninstalling and reinstalling, and it still hangs. How do I get that video out?
(2013-03-02, 22:16)dgrayfromdc Wrote: I tried to download a video, and the download dialog hung. I'm guessing that it hung because there was a login prompt because of explicit language (or at least that's what happened when I tried it in my browser) for the video in question. The problem now is that XBMC hangs on exit presumably because Youtube is stuck. I think the video is still in the queue. I've tried disabling the add-on, uninstalling and reinstalling, and it still hangs. How do I get that video out?

Another problem seems to have popped up, my Web Server fails on startup. This has the side-effect of making XBMC remote unable to connect.

Tried uninstalling and removing all settings I could find for both youtube and simple downloader. Reinstalled, simple downloader came back, but now I'm having the same problem so many others seem to be experiencing, failure to log into youtube.

None of these problems appeared until the download hung. What's happening here? Is it an add-on thing or a Frodo thing?
hi
so since thursday i have been getting this error, login failed false...
i reinstalled raspbmc 2x , removed the plugin 2x, removed the userdata settings.xml...all to no avail...running the newest version, 4.2
http://pastebin.com/P7qFwH3P
installed from repository, installed from zip, running raspbmc newest version..it was working on thursday Feb 28 2013, but now no..please help
Wait for an update. This addin breaks all the time. Google likes to change things.
(2013-03-03, 15:58)kadeschs Wrote: Wait for an update. This addin breaks all the time. Google likes to change things.

Yeah I really wish they wouldn't. It must break features across platforms, not just for XBMC. It's exactly this sort of thing which killed the IMDb plugin and left us with the somewhat inferior TMDb instead.

"eden-pre repo, so head over to XBMC's download page and download the latest nightly if you want to help out with testing or just want an upgrade to your YouTube experience Smile "

What does this mean, that 4.5 beta is currently for Eden only? Or that it's only for post-Frodo nightlies? The phrasing makes it hard to tell.
It's broken for me too, I logged out and couldn't log back in again.

This is getting silly. Why does this Youtube plugin constantly need updating, yet the plugin on my WD TV Live still connects without an update.

Isn't it about time that somebody sat down with Youtube and released an official plugin that they'd update.

I realize that we'd have to put up with adverts, but that's better than this.
(2013-03-03, 17:25)zackpliskin Wrote:
(2013-03-03, 15:58)kadeschs Wrote: Wait for an update. This addin breaks all the time. Google likes to change things.

Yeah I really wish they wouldn't. It must break features across platforms, not just for XBMC. It's exactly this sort of thing which killed the IMDb plugin and left us with the somewhat inferior TMDb instead.

"eden-pre repo, so head over to XBMC's download page and download the latest nightly if you want to help out with testing or just want an upgrade to your YouTube experience Smile "

What does this mean, that 4.5 beta is currently for Eden only? Or that it's only for post-Frodo nightlies? The phrasing makes it hard to tell.

It really does. I have several devices that come with some sort of YouTube plugin, where is either stops working completely, or can't play half of the videos. I especially hated that most plugins wouldn't play Vevo content for the longest time.
(2013-03-03, 19:42)replica9000 Wrote:
(2013-03-03, 17:25)zackpliskin Wrote:
(2013-03-03, 15:58)kadeschs Wrote: Wait for an update. This addin breaks all the time. Google likes to change things.

Yeah I really wish they wouldn't. It must break features across platforms, not just for XBMC. It's exactly this sort of thing which killed the IMDb plugin and left us with the somewhat inferior TMDb instead.

"eden-pre repo, so head over to XBMC's download page and download the latest nightly if you want to help out with testing or just want an upgrade to your YouTube experience Smile "

What does this mean, that 4.5 beta is currently for Eden only? Or that it's only for post-Frodo nightlies? The phrasing makes it hard to tell.

It really does. I have several devices that come with some sort of YouTube plugin, where is either stops working completely, or can't play half of the videos. I especially hated that most plugins wouldn't play Vevo content for the longest time.

Come to think of it that's one of my main gripes with the internet as it stands right now - constant updates needed, or at least the end user is nagged and nagged only to upgrade and find a) more stuff is broken than the version before yet nothing else is fixed (hello Flash Player) or b) it removes perfectly good features that people liked and used.

With something massively cross-platform owned by one of the web's largest businesses, these problems should have been mostly defeated back in 2010, rather than still being with us in 2013. Keep it simple, that's what they should do, keep the API consistent across platforms. That way they'd be more forced to be careful when making changes because it would break a feature across ALL platforms. That would result in more angry users, lost ad revenue and a valuable lesson about not tinkering endlessly at end user's expense. Honestly, how hard is it for Google developers to get this right?

</rant>
Rainbow 
Hi guys,

First of all, I wanna to thank you for such great add-on. So - thank you. Smile

I'm using two-factor authentication for all Google services since couple of months. For the security reasons I also need to use application passwords (in the meaning of Google two-factor authentication) in XBMC. I've tried many times to authenticate with it in XBMC's yt plugin, however no success. Before I'll ask anybody for help I was trying to find any official information about the support of this authentication method for this add-on. Unfortunately - not found.

Could you please tell me or just confirm are the application passwords for this add-on working? Is two-factor authentication supported?

I cannot find any error in log, just a warning saying:

Code:
_fillLoginInfo missing values for login form

So I guess it's form-related issue..

// edit:In a fact - I can see now that there is clearly a global issue..

Many thanks for any confirmation or suggestion.

Kind regards,
Kokos
  •   
  • 1
  • 200
  • 201
  • 202(current)
  • 203
  • 204
  • 315
  •   
  Thread Closed
 
Thread Rating:
  • 28 Vote(s) - 4.14 Average



Logout Mark Read Team Forum Stats Members Help
[depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only4.1428