TVDB are updating their site. Their site currently has a number of bugs that have broken the TVDB scraper and any add-on that relies on TVDB data. TVDB are working to rectify the problems.

  •   
  • 1
  • 213
  • 214
  • 215(current)
  • 216
  • 217
  • 315
  •   
  Thread Closed
Release [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
(2013-05-22, 12:54)slinuxgeek Wrote:
(2013-05-17, 20:27)ace5342 Wrote:
(2013-05-16, 11:29)slinuxgeek Wrote: I could not find source for greasemonkey and I think it may not be related to youtube plugin code for xbmc.

I just want that search should start on click of a button in video library window, instead of by clicking on an item in panel control.
Right now there is a search icon item in panel if we click it, it displays all previous searches and another icon for new search clicking on that displays Dialog keyboard to enter search string to search.
I want to achieve same on click of a button.

I have been looking for a similar thing (one call or two at the most to go from the xbmc menu to the youtube search menu with the dialog box ready for input) using JSON RPC.

can you post here if you do find a solution as i could prob make what you want work for me.

Hi ace5342,

I did it through small script:
On click of the button I am calling this script:
PHP Code:
import xbmc
import CommonFunctions 
as common

def Main
():
    print 
"*************************Begin YouTube Search*****************************"
    
    
query common.getUserInput('Search YouTube''')
    if 
query:
        
xbmc.executebuiltin('ReplaceWindow(video,plugin://plugin.video.youtube/Explore Youtube/?feed=search&path=/root/search&search=' query ',return)')
        
    print 
"******************************END********************************"

if __name__ == '__main__':
    
Main() 
So basically I am trying to open the virtual folder with that folder path which is of same format when YouTube search displays a search result.
That will take some moment to draw result and there will not be any user feedback like working dialog displayed, but if you know little scripting you can achieve that too.

Thank you for the reply slinuxgeek i will give it a go when i get home.
(2013-05-13, 23:27)Donny Wrote: If it helps anybody, I was having problems using the, "play from here" option in youtube playlists. I searched, but none of the fixes I found worked for me.

I was able to get it to work by changing my playlist to public from private on the youtube webpage.

Hope it helps someone, God knows you have all helped me.
-Donny

Nice Cool
Image [RELEASE] Metroid
Image [RELEASE] IrcChat
Hi ace5342,
I recently found better way of doing that without using script, see below button <onclick>:
You can add this button in MyVideoNav.xml and with a meaningful value for x,y and width, height according to your skin.
PHP Code:
<control type="button">
    <
label>Search...</label>
    <
onclick>XBMC.Container.Update(plugin://plugin.video.youtube/Explore Youtube/?feed=search&path=/root/search)</onclick>
    
<visible>SubString(Container.FolderPath,plugin://plugin.video.youtube/,left)</visible>
</control
Thanks
Thanks for this info slinuxgeek. I seam to be having some difficulty with it I have tried placing it in MyVideoNav.xml in several places but I fail to find it in the menu options on XBMC. I am assuming it would appear in the video section?

EDIT

It's sorted now the problem was to do with the loading of the xml after I switched theme and then back it was working thanks again slinusgeek.
How to clear the Flush youtube subscriptions channel's thumbnail?

Does anyone know how to clear/ Flush youtube subscriptions channel's thumbnail?, as you all know those subscriptions folder pickup the latest video as the thumbnail subscriptions folder and stay there forever, but sometime those thumbnail do not best represent those channel , but some how the addon store those thumbnail forever, even I
un-unsubscribe and unsubscribe again 3 months later , it still use the same old thumbnail picture !! why , how can I fix this. Can I individually only some channel thumbnail and keep others?
I am using Win7 / XBMC Version 11, thanks
(2013-05-22, 20:50)tinfox Wrote:
(2013-05-21, 23:54)DFergATL Wrote: I can no longer play any videos in youtube, nor can I log into youtube anymore either. Was fine yesterday. Just an other day of XBMC. I have gotten to the point where I dread turning it on when I get home from work. Every two or three days something else stops working.
Same here.

And here.
Last night (well, this morning) I noticed that some videos would play and others wouldnt, I'm assuming this is a change on youtubes behalf affecting the plugin. Checked on the tracker mentioned in the first post and there is a mention of a not playing problem. The "auto build" log doesnt appear to have any jobs associated with it so not sure but I'm supposing a change will be needed. Not had a chance to check the logs yet but if there's no word by this evening I'll have a poke about!
(2013-03-25, 03:19)pmolson Wrote: Thanks Bro, your workaround does work for watching youtube vids on the youtube addon, but it's NOT working when you try to view those same vids using LivesStreams Sad And btw, ver 4.4.4 is out and exhibits the same behavior. It works fine on YT addon, but comes back with "playback failed: unable to locate video url" error or just turns for a while then gives you a "playback failed" error when trying to view a YT vid on LiveStreams Sad

^^^ i'm having the exact issue in the quoted post.. has anyone ever fix this? i'm using atv2 xbmc v12 and youtube add on 4.4.4

here are some logs...

09:54:48 T:19024 ERROR: urlresolver: youtube: video id not found
09:54:48 T:19024 NOTICE: inresolver=http://www.youtube.com/embed/9cAdBADK9o4?rel=0
09:54:48 T:19024 NOTICE: pinoy=plugin://plugin.video.youtube/?action=play_video&videoid=
09:54:48 T:19272 NOTICE: Thread XBPyThread start, auto delete: false
09:54:48 T:19272 NOTICE: -->Python Interpreter Initialized<--
09:54:48 T:19272 NOTICE: YouTube-4.4.4
09:54:48 T:19272 NOTICE: CommonFunctions-2.5.1
09:54:50 T:19272 NOTICE: links: 'dict'
09:54:50 T:19024 WARNING: Attempt to use invalid handle -1
09:54:55 T:19008 NOTICE: Storing total System Uptime
09:54:55 T:19008 NOTICE: Saving settings
09:54:55 T:19008 NOTICE: stop all
09:54:55 T:19008 NOTICE: ES: Stopping event server
09:54:55 T:19008 NOTICE: stopping zeroconf publishing
09:54:56 T:13492 NOTICE: ES: UDP Event server stopped
09:54:56 T:19008 NOTICE: stop sap announcement listener
09:54:56 T:19008 NOTICE: clean cached files!
09:54:56 T:19008 NOTICE: unload skin
09:54:56 T:18336 NOTICE: StorageServer-2.5.0 Closed down
09:54:56 T:19008 NOTICE: stop python
09:54:56 T:19008 NOTICE: stopped
09:54:56 T:19008 NOTICE: destroy
09:54:56 T:19008 NOTICE: closing down remote control service
09:54:56 T:19008 NOTICE: unload sections
09:54:56 T:19008 NOTICE: destroy
09:54:56 T:19008 WARNING: Attempted to remove window 10013 from the window manager when it didn't exist
09:54:56 T:19008 WARNING: Attempted to remove window 10014 from the window manager when it didn't exist
09:54:56 T:19008 WARNING: Attempted to remove window 10015 from the window manager when it didn't exist
09:54:56 T:19008 WARNING: Attempted to remove window 10016 from the window manager when it didn't exist
09:54:56 T:19008 WARNING: Attempted to remove window 10017 from the window manager when it didn't exist
09:54:56 T:19008 WARNING: Attempted to remove window 10018 from the window manager when it didn't exist
09:54:56 T:19008 WARNING: Attempted to remove window 10019 from the window manager when it didn't exist
09:54:56 T:19008 WARNING: Attempted to remove window 10021 from the window manager when it didn't exist
09:54:56 T:19008 WARNING: Attempted to remove window 10107 from the window manager when it didn't exist
09:54:56 T:19008 WARNING: Attempted to remove window 10115 from the window manager when it didn't exist
09:54:56 T:19008 WARNING: Attempted to remove window 10104 from the window manager when it didn't exist
09:54:56 T:19008 NOTICE: closing down remote control service
09:54:56 T:19008 NOTICE: unload sections
09:54:56 T:19008 NOTICE: application stopped...


thanks a lot in advance.
(2013-05-09, 16:12)patria o muerte Wrote: Hello everyone,I have a problem with this addon.
Whenever I want to start any download it shows me the "preparing download" message and does nothing more.
What can it be?
I have an android box with 12.2 frodo.
Thanks

I'm having the same problem on W7 and 12.2. Show 'perparing download' and nothing more. It worked ok a month ago. Any sugestion?

{}s
i don't think anybody's working on the plugin right now... mouth or otherwise
Anyone know how to get the plugin working with the new multiple youtube accounts type of login? I have one login for 2 separate youtube channels, but authentication fails probably because youtube asks which account to use after the initial authentication now.
Hello,

I had problem with the plugin crashing due to ValueError: Extra data when trying to watch some subscribed videos. It happened during parse of json data in YouTubePlayer.py method extractFlashVars.
For some reason the json parser doesnt like extra data. The extra data was html tags at the end. Dunno why though.
I'm running XBMC 12.1 on Ubuntu 13.04. Plugin version 4.4.4

Resolved it with this code:

Code:
def extractFlashVars(self, data):
        flashvars = {}
        found = False

        for line in data.split("\n"):
            if line.strip().find(";ytplayer.config = ") > 0:
                found = True
                p1 = line.find(";ytplayer.config = ") + len(";ytplayer.config = ") - 1
                p2 = line.rfind(";")
                if p1 <= 0 or p2 <= 0:
                    continue
                data = line[p1 + 1:p2]
                break

        self.common.log(u"searching for crap at end")
        pos = data.find("};")
        if pos != -1:
            self.common.log(u"found crap at end")
            data=data[:pos+1]
            self.common.log(u"crap trimmed")
        if found:
            try:
                data = json.loads(data)
            except ValueError:
                self.common.log(u"Unable to parse")
                self.common.log(pos)
                self.common.log(data)
                raise
            flashvars = data["args"]

        self.common.log(u"flashvars: " + repr(flashvars), 2)
        return flashvars
I'm having trouble with when I want to fast forward on the video in youtube but the app stalls. Like for example if I want to start at 5 mins into a video, the app stalls and nothing happens.
I have a problem with the You Tube app. I wanted to watch the anime Dirty Pair from Manga's channel on You Tube. Its mature content and I get URL Not Found Error message from inside the app. Of course I can watch it via the browser, that's not what I want.

I searched and found its a 4oD issue or something with all sort of mature or age consent content.

Is there a fix?
(2013-05-30, 20:30)kronski Wrote: Hello,

I had problem with the plugin crashing due to ValueError: Extra data when trying to watch some subscribed videos. It happened during parse of json data in YouTubePlayer.py method extractFlashVars.
For some reason the json parser doesnt like extra data. The extra data was html tags at the end. Dunno why though.
I'm running XBMC 12.1 on Ubuntu 13.04. Plugin version 4.4.4

Good Job, thanks for the fix.
  •   
  • 1
  • 213
  • 214
  • 215(current)
  • 216
  • 217
  • 315
  •   
  Thread Closed
 
Thread Rating:
  • 28 Vote(s) - 4.14 Average



Logout Mark Read Team Forum Stats Members Help
[depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only4.1428