[Linux] Optical Digital Out - /(%$VG$§
#1
Its time to freak out for me Sad

First of all, I'm not a linux newbie and I allways managed to handle my problems by myself. But "ODO" on my htpc was such a pain in the ass, that I decided to stay on windows cause i couldnt get things work on linux.

I have an Asus P5kpl/1600 mainboard with an "VIA VT1708 B" sound chip and i really know this chip is the mainproblem.
I was so happy when i was reading the news about dharma and many many sound-fixes, so i decided to try RC2.
But after some testing ( ok, only just tryed some basic mixer-settings and stuff ) I still cant get it work. There is just NO LIGHT on the digital output.

So .. here I am, without any big Idea, asking for your help. Huh


aplay output will follow

aplay -L

Code:
[email protected]:~$ aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
default:CARD=Intel
    HDA Intel, VT1708B Analog
    Default Audio Device
front:CARD=Intel,DEV=0
    HDA Intel, VT1708B Analog
    Front speakers
surround40:CARD=Intel,DEV=0
    HDA Intel, VT1708B Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=Intel,DEV=0
    HDA Intel, VT1708B Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Intel,DEV=0
    HDA Intel, VT1708B Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Intel,DEV=0
    HDA Intel, VT1708B Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Intel,DEV=0
    HDA Intel, VT1708B Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Intel,DEV=0
    HDA Intel, VT1708B Digital
    IEC958 (S/PDIF) Digital Audio Output
hdmi:CARD=HDMI
    HDA ATI HDMI, ATI HDMI
    HDMI Audio Output

aplay -l

Code:
[email protected]:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: VT1708B Analog [VT1708B Analog]
  Subdevices: 2/2
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
card 0: Intel [HDA Intel], device 1: VT1708B Digital [VT1708B Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
[email protected]:~$
Reply
#2
what have you set your audio settings too, and do you have everything unmuted?
Reply
#3
Audiosettings:

Optical/Coax
5.1
AC3 [X]
DTS [X]

Audio Out: HDA Intel iec958
Passthrough: HDA Intel iec958

Everything unmuted actually .. tried to mute the "analog outputs" and stuff and unmute only the "digital output" ... no go till now.

I only need to get optical passthrough working cuase i always use 5.1/Dts movies. But what i have tried for now with dharma or with any xbmc release before, i dont get any light on the optical output. ( no hw problem cause with windows it works fine )

For any kind of Music there is a nice CD-Player working Big Grin
Reply
#4
You should get the digital sound to work in linux first.

- try running alsamixer and muting unmuting some items.
- try speaker-test -c

hope it helps
Reply
#5
"iecset" told me my settings for "data" was wrong, (non-audio ) wich i changed/fixed. Also i think hw:0,1 should be my digital out so with following command i should get some "sound":

aplay -D hw:0,1 /usr/share/sounds/alsa/Front_Center.wav -> no sound

alsamixer:

Image

Speakertest ... will follow

I dont understand this:

Code:
@XBMCLive:/home/xbmc# speaker-test -Dhw:0,1

speaker-test 1.0.22

Playback device is hw:0,1
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Channels count (1) not available for playbacks: Invalid argument
Setting of hwparams failed: Invalid argument
Reply
#6
hi,

as described in a other thread from me (http://forum.xbmc.org/showthread.php?tid=86641)
i have nearly the same problem...

only difference, i get the DTS sound working without XBMC with "aplay" and a DTS-WAV-File....
but when i try to get DTS sound in XBMC it does not work....
analog or digital sound like AC3 works...

and my alsamixer Screen looks nearly the same...I also can not put the trigger at SPDIF to 100%...is this normal?

Has someone a solution or knows the problem??

thx duck
Reply
#7
I dont wanne be "bad" or something, but i really think ur problem is way to much different frome mine, to post solutions in ONE topic. So plz use ur own topic instead.

I dont get ANY digital out working ... i just get no light on the optical out.
Reply
#8
Ok, i "solved" this problem by myself. I still dont have any optical digital output, but i found an "spdif_out" connector on the mainboard. So i soldered a coax-cable, connected it and actually i am watching Jurassic Park III for testing. Digital 5.1 Works Big Grin

Tomorrow i will try to install Dharma RC2 on my "Non-Testing HDD" and take a look for the settings i have to set to get it working again Big Grin


May be its not the best solution to use a selfmade coax-spdif instead of an optical.
But as far as there is no way to get the optical work, the coax spdif IS a solution.
Reply
#9
Any update to this problem or solution?
Reply
#10
On a thread from 2k10? Stop writing into outdated, totally not relevant threads from 6 years ago.

If you have issues with your spdif, open a new thread and post the information the post "read this before posting" wants. All the dharma configuration is in no way relevant to any version of kodi after v14 anymore.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
[Linux] Optical Digital Out - /(%$VG$§00