•   
  • 1
  • 4
  • 5
  • 6
  • 7
  • 8(current)
[ATV1] HOW-TO install Sam's image to internal Apple TV harddrive
Observer Wrote:Sam

You Rock ! Success (from OSX adding a few macport tools fuse-ext2 and gptsync) !

Seems my initial attempts were being hampered by a doggy USB flash drive that would crap out half way though with I/O Read errors.

I guess when this line (below) in the ubuntu.sh script got stuck downloading the Root Image file...0k per sec for an hour....
Code:
wget "http://download.stmlabs.com/atv-images/ubuntu/hardy/core/Root.img.gz"
My only choice is to reboot and start again..it would be great however if the script had some checking to see if any of the images are already downloaded (comparing size/timestamp etc) , the wget -c & -N options may help here? This would also help if one was installing a series of ATV's...

Also is there some specific file structure on the swap partition requiring an image download or can this be created by issuing commands ?

BTW it would be cool if you published the download/update stats from your web server. From there there are a bunch of other "features" you could offer.

Just need to fix my judder, Alsa/SPDIF and some other video freeze and VC-1 container issues and I have a solution.

Please keep up the great work and I for one will continue to support you.

Great that it works. The script downloads every time for absolute freshness. If you wanted to image a series of aTVs, you'd have to reimage the USB every time or deal with a nasty Ubuntu udev rule (net-persistent-rules), as each aTV has a different NIC, thus different MAC, thus comes up as a different ethX which must be registered as auto in /etc/network/interfaces.

I'm not sure what you mean by stats? If it interests you to know, over a terrabyte has crossed the network in images since March 28th, although this seems to be steadying out now.

I'll keep maintaining the image -- there's some good stuff waiting for you like PVR support, and a small update I'll be pushing out soon. Stay tuned
Reply
Hi Sam,

First off thank you for the img.

I have done something bad I think, i ran

sudo apt-get update
and
sudo apt-get upgrade

and know I have a pink screen Blush any advice how I can fix it without reimaging the drive again Sad
Current setup:
Amlogic M3/MX + Linux + BOXiK Skin + Pioneer vsx520 + Dali Lektor 6

Previous setup:
Revo 3700 + flirc + OpenElec nightlies + Quartz + Pioneer vsx520 + Dali Lektor 6
atv1 + Crystalbuntu + XBMC nightly + xperience1080
Reply
Sorry. Unless I knew specifically what package was upgraded that caused the problem, I can't solve it. You'd best reimage.
Reply
Sad 
On my old Xbox with xbmc, large pictures show fine and smooth. Even slideshow works well! In SD resolution though.

Unfortunately my Apple TV 1 (CrystalHD) with Sam's image (THANKS SAM!!) slideshow isn't working well with bigger images shot with my Canon 550D. 5184 x 3456 or even pictures with 3648 x 2736 pixels
The slideshow shows the first picture but skips the second by showing a black screen. It's very slow too...
This even happens when I try them from the internal disk, so it's not a nas problem with me.

Tested on 1280x720 (60) and 1920x1080 (60)..

Is this a know issue? Does anyone else have the same problem?

Djgodlike
The Netherlands
Reply
Is it possible to have wireless access once this is installed?
Reply
If you installed a crystalHD decoder card, then you removed your wireless card in the process - so no. If you did not, then yes - but - you will be limited to watching SD video (the odd 720p may work, but not well in my experience).
Reply
thnmnt Wrote:If you installed a crystalHD decoder card, then you removed your wireless card in the process - so no. If you did not, then yes - but - you will be limited to watching SD video (the odd 720p may work, but not well in my experience).

Ok, so the only instructions that I have been able to find are, http://dereenigne.org/computers/linux/ap...mment-1304

And that doesn't seem to work all the way, does anyone have any process that they did that worked, that they also would be willing to walk me through?

I didn't install the CrystalHD on this ATV, I need the wireless connection because it is in my bedroom in my apartment, therefore I can't being running cat cable through out the place.
Reply
  •   
  • 1
  • 4
  • 5
  • 6
  • 7
  • 8(current)



Logout Mark Read Team Forum Stats Members Help
[ATV1] HOW-TO install Sam's image to internal Apple TV harddrive2
This forum uses Lukasz Tkacz MyBB addons.