Thread Rating:
  • 2 Vote(s) - 5 Average
Problems with HD .ts files

I'm not sure whether someone already described the following problem.
XBMC (ATV2) can only play .ts files, when the are NOT recorded from an HD-tv channel.

I tried it with different HD channels like "Sky Cinema HD", "ORF 1", "das Erste".
TS-Files from none HD-channels work perfectly.
XBMC tries to start the HD-ts-file and I can hear the sound but the video is not displayed.

Even when I use makemkv to convert the HD-ts-file to an mkv-file, the problem still remains.

I guess this is an XMB for ios specific problem, as it does not occur on my xmbc for windows version.

I can confirm this problem. This is not only the case when opening a recorded file, but also when streaming these TV channels directly. Here are some information about the codec:

From ffmpeg:
Input #0, mpegts, from '***':
  Duration: 01:36:01.19, start: 84251.924567, bitrate: 12077 kb/s
  Program 11100
    Stream #0.0[0x177a]: Video: h264 (High), yuv420p, 1280x720 [PAR 1:1 DAR 16:9], 56.33 fps, 50 tbr, 90k tbn, 100 tbc
    Stream #0.1[0x1784](deu): Audio: mp2, 48000 Hz, 2 channels, s16, 256 kb/s

From MPC:
ID                               : 3F3
Complete name                    : ***
Format                           : MPEG-TS
File size                        : 8.10 GiB
Duration                         : 1h 35mn
Overall bit rate                 : 12.1 Mbps

ID                               : 6010 (0x177A)
Menu ID                          : 11100 (0x2B5C)
Format                           : AVC
Format/Info                      : Advanced Video Codec
Format profile                   : [email protected]
Format settings, CABAC           : Yes
Format settings, ReFrames        : 5 frames
Duration                         : 1h 35mn
Bit rate mode                    : Variable
Bit rate                         : 11.2 Mbps
Maximum bit rate                 : 11.5 Mbps
Width                            : 1 280 pixels
Height                           : 720 pixels
Display aspect ratio             : 16:9
Frame rate                       : 50.000 fps
Color space                      : YUV
Chroma subsampling               : 4:2:0
Bit depth                        : 8 bits
Scan type                        : Progressive
Bits/(Pixel*Frame)               : 0.244
Stream size                      : 7.53 GiB (93%)
Color primaries                  : BT.709-5, BT.1361, IEC 61966-2-4, SMPTE RP177
Transfer characteristics         : BT.709-5, BT.1361
Matrix coefficients              : BT.709-5, BT.1361, IEC 61966-2-4 709, SMPTE RP177

ID                               : 6020 (0x1784)
Menu ID                          : 11100 (0x2B5C)
Format                           : MPEG Audio
Format version                   : Version 1
Format profile                   : Layer 2
Duration                         : 1h 35mn
Bit rate mode                    : Constant
Bit rate                         : 256 Kbps
Channel(s)                       : 2 channels
Sampling rate                    : 48.0 KHz
Video delay                      : -1s 33ms
Stream size                      : 176 MiB (2%)
Language                         : German

I can also confirm that this works perfectly on XBMC for Mac or Windows.

If it helps I can upload a short recording that does not work on the AppleTV2.

Hope this can be fixed :-)

Here is the log file:
The Build I am using is XBMC PRE-10.0 GIT:b0b7aa9 (Compiled : Mar 5 2011) which is the latest unofficial build from this thread in this forum.

Thanks for helping :-)


I can also confirm the pronlem. When I try to play HD TV content or stream HD TV from a dreambox (tuxboxclient) I have the same effect. Some noise but no picture.
I had this problems some time aggo with streaming from a vdr to xbmc. I think the explanation was, that xbmc uses the first frames to determine if the stream is video or audio, and with HD contents this determination fails so xbmc should use mor frames fore this determination. Maybe that the reason, but I'm no expert.

thanks for helping
I have exactly the same problem. Is there already a solution for this issue?
Here are some additional information in order to investigate the reasons for the problem:


Sample-File (1 min, 93 MB, H264, MPEG-4 AVC part 10, 720p):

The video is recorded with a VU+ Duo PVR (very similar to Dreambox).
The file works with xbmc for mac. SD-Recording (mpeg2) play fine on the ATV2.

Is there any hope that you can solve this problem?
I think this is the related Ticket:

So you have already tried to solve this problem, Davilla?
frogger23 Wrote:I think this is the related Ticket:

So you have already tried to solve this problem, Davilla?

try asking in the trac ticket and provide updates logs/file etc. as the ticket is 4 months old
Hi together,

I have the same problem as the upper writers.

I have a dreambox and the recordings from HD-Channels doesn't play on the apple TV2 with XBMC - the 'normal' recordings works very good.

Is there any solution, maybe wit a plugin to solve the request to play ts-files in 1080p per an ATV2 with XBMC or with another player?

Thanks for your help.

Greetings from
Same problem. HD.ts only sound
think its a known limitation of the atv2 hardware, at least it was a while ago when i was testing with my vu+ duo
No...........I also watch .mkv with much more higher bitrate then .ts file
hollemanjan Wrote:No...........I also watch .mkv with much more higher bitrate then .ts file

nothing to do with bitrate more to do with .ts not being offloaded to the software acceleration/gpu
Have not to do with hardware.......................i play HD. mkv of 22Gb without problems.......... The HD stream of dreambox is less. Have to do with format not with hardware.
hollemanjan Wrote:Have not to do with hardware.......................i play HD. mkv of 22Gb without problems.......... The HD stream of dreambox is less. Have to do with format not with hardware.

It's the hardware. Bitrate means nothing. Codec means everything. Read FAQ.

Problems with HD .ts files52