Volume change stops movie playback.

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
suco Offline
Junior Member
Posts: 2
Joined: Apr 2012
Reputation: 0
Post: #1

Up to now, XBMC worked perfectly for me. However, today a very strange behavior started...
Whenever I play a movie and want to augment the volume of the movie, the playback stops. I have a Thinkpad, and I augment the volume by pressing the built-in controls of the laptop.
This is reproducible with different movies.

This error also occurs when I change the volume of the notebook via a autohotkey script.

I tried to deactivate all 'stop'-shortcuts in the keyboard.xml, but it didn't have any results.

I've got no idea what other options I might have to fix this error... any help would be very much appreciated. Smile

Ps: I forgot some information:
- XBMC: Eden
- OS: Windows 7 64
- PC: Thinkpad T520
(This post was last modified: 2012-04-14 04:24 by suco.)
find quote
Ned Scott Offline
Retired Team-Kodi Member
Posts: 31,445
Joined: Jan 2011
Reputation: 556
Location: Arizona, USA
Post: #2
If you can get us a debug log (wiki) then we might be able to see what XBMC is doing when the key is pressed.

Full disclosure: I work for WeTek. However, this is my personal account, and my words and opinion are my own.

find quote
suco Offline
Junior Member
Posts: 2
Joined: Apr 2012
Reputation: 0
Post: #3
The behavior stopped when I disabled all keyboard shortcuts for 'stop' in keyboard.xml.

Strangely, I tried to reproduce the error for the debug log by replacing the modified keyboard.xml with the original keyboard.xml. Now, the error does not occur.
find quote