Xbmcbuntu 13 Testing Thread

  Thread Rating:
  • 3 Votes - 4.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
vip723 Offline
Junior Member
Posts: 3
Joined: Mar 2014
Reputation: 0
Location: Warsaw
Post: #16
(2014-03-19 19:25)wsnipex Wrote:  yes, till we fix this and build a new iso, please manually uninstall pulse:
Code:
sudo apt-get remove pulseaudio libasound2-plugins

Thanks wsnipex. Got audio passthrough. And seems to be working fine if the framerate/stream type is matching receiver spec.

Talking about framerate... I know there are some issues with 29.97 videos due to "Radeon Audio clock running wrong speed" but in my case it is causing the video very stattering and low quality (horizontal layers appearing) particulary when combined with DTS-HD audio. I've captured xbmc.log while watching 29.97 video with DTS stream. Will appreciate if someone could have a look in a spare time... Smile

23.97fps seems to be running fine - @ least when display is set to sync to video.

GPU: Asus Radeon HD6450 + HDMI output -> Yamaha RX-V775
CPU: AMD Athlon II X2 240e, dual core, socket AM3, 2.8GHz, 2MB L2 cache, 45W
Mainboard: Gigabyte MA78GS2H rev 1.1

dmesg: http://paste.ubuntu.com/7122689/
xbmc.log: http://paste.ubuntu.com/7122690/
Xorg.0.log: http://paste.ubuntu.com/7122697/
DISPLAY=:0 vdpauinfo: http://paste.ubuntu.com/7122699/
dpkg -l |grep mesa: http://paste.ubuntu.com/7122701/
(This post was last modified: 2014-03-20 02:01 by vip723.)
find quote
KeithLM Offline
Fan
Posts: 304
Joined: Dec 2009
Reputation: 7
Post: #17
(2014-03-19 07:53)wsnipex Wrote:  about pulse being installed: There seems to be some dependency pulling that in, looking into it.

@KeithLM: can you try if this works for you?

in /etc/init/xbmcbuntu-wait.conf
-start on (starting lightdm or starting ubiquity)
+start on (starting lightdm or starting ubiquity and net-device-up IFACE!=lo)

OK, I did that, rebooted a few times to test, and it seems to both work as expected, and be quicker than my method. Thanks.
find quote
wsnipex Offline
Team-Kodi Member
Posts: 3,964
Joined: Jun 2011
Reputation: 96
Post: #18
@vip723:
The file the file you played is VC1, can you check that its not interlaced? Mediainfo will tell you.

can you add this line under [SeatDefaults] in
Code:
xserver-command=/usr/bin/X -bs -nolisten tcp
It should hopefully get rid of tearing.


@KeithLM: just to make sure, you did remove your changes from /etc/init/lightdm.conf, right?
(This post was last modified: 2014-03-20 08:43 by wsnipex.)
find quote
David1977 Offline
Fan
Posts: 692
Joined: Jan 2011
Reputation: 9
Location: Germany
Post: #19
Oh...cool...will give it a try.
find quote
vip723 Offline
Junior Member
Posts: 3
Joined: Mar 2014
Reputation: 0
Location: Warsaw
Post: #20
Thx again wsnipex,
I've applied the changes @ [SeatDefaults] following your recomendation and played 4 different files for 2 minutes each and collected XBMC log: http://paste.ubuntu.com/7124650/

File A
Format=VC-1; Format profile=Advanced@L3; Codec ID=V_MS/VFW/FOURCC / WVC1; Codec ID/Hint=Microsoft; Bit rate=16.0 Mbps; Width=1 920 pixels; Height=1 080 pixels; Display aspect ratio=16:9; Frame rate mode=Variable; Original frame rate=29.970 fps; Color space=YUV; Chroma subsampling=4:2:0; Bit depth=8 bits; Scan type=Progressive; Compression mode=Lossy + DTS + no subtitles

Watching experience: the picture seems to be very clear but not smooth - stuttering. This is the file I've send the log before. Not sure if I can see any significant difference on this one after applying [SeatDefault] "mod". I've noticed that for this file osd codec info displays mostly pc:none and from time to time pc:14 (it is never 1 but there are also no skips or drops reported. It might do something with Frame rate mode=Variable?).

File B
Format=AVC; Format/Info=Advanced Video Codec; Format profile=High@L4.1; Format settings,CABAC=Yes; Format settings,ReFrames=4 frames; Codec ID=V_MPEG4/ISO/AVC; Bit rate mode=Variable; Maximum bit rate=38.0 Mbps; Width=1920 pixels; Height=1080 pixels; Display aspect ratio=16:9; Frame rate mode=Constant; Frame rate=29.970fps; Standard=NTSC; Color space=YUV; Chroma subsampling=4:2:0; Bit depth=8 bits; Scan type=MBAFF; Color primaries=BT.709; Transfer characteristics=BT.709; Matrix coefficients=BT.709; + audio DTS-HD MA + no subtitles

Watching experience: still tearing but here I can see a great improvment after applying the [SeatDefaults] "mod". No picture "layers" visible anymore. No frame skips/drops occure @ osd codec info.


File C
Format=AVC; Format/Info=Advanced Video Codec ; Format profile=High@L4.1; Format settings,CABAC=Yes; Format settings,ReFrames=5 frames; Codec ID=V_MPEG4/ISO/AVC; Bit rate=14.8 Mbps; Width=1 920 pixels; Height=796 pixels; Display aspect atio=2.40:1; Frame rate mode=Constant; Frame rate=23.976 fps; Color space=YUV; Chroma subsampling=4:2:0; Bit depth=8 bits; Scan type=Progressive; Bits/(Pixel*Frame)=0.403; Stream size=15.5 GiB (89%); + DTS + ass subtitles

Watching experience: the picture seems to be very clear but not smooth - stuttering from time to time. Frame skips counted @ osd codec info when stuttering happens.


File D
Format=AVC; Format/Info=Advanced Video Codec; Format profile=High@L4.1; Format settings,CABAC=Yes; Format settings,ReFrames=5 frames; Codec ID=V_MPEG4/ISO/AVC; Bit rate=11.1 Mbps; Width=1 920 pixels; Height=800 pixels; Display aspect ratio=2.40:1; Frame rate mode=Constant; Frame rate=23.976 fps; Color space=YUV; Chroma subsampling=4:2:0; Bit depth=8 bits; Scan type=Progressive; Bits/(Pixel*Frame)=0.303; Stream size=6.82 GiB (86%); Writing library=x264 core 125 r2208 d9d2288; Encoding settings=cabac=1 / ref=5 / deblock=1:-3:-3 / analyse=0x3:0x113 / me=umh / subme=10 / psy=1 / psy_rd=1.00:0.05 / mixed_ref=1 / me_range=32 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=0 / chroma_qp_offset=-2 / threads=8 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=4 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=23 / scenecut=40 / intra_refresh=0 / rc=2pass / mbtree=0 / bitrate=11150 / ratetol=1.0 / qcomp=0.70 / qpmin=0 / qpmax=69 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / pb_ratio=1.30 / aq=2:1.00 + DTS + srt subtitles

Watching experience: Perfect! Smile

Forgive me the long post but I just had the feeling that gathering/passing more info can get us closer to the promissed land = the perfect XBMC Smile
(This post was last modified: 2014-03-20 13:39 by vip723.)
find quote
KeithLM Offline
Fan
Posts: 304
Joined: Dec 2009
Reputation: 7
Post: #21
(2014-03-20 08:41)wsnipex Wrote:  @KeithLM: just to make sure, you did remove your changes from /etc/init/lightdm.conf, right?

Yes, I did. Not at first though, and naturally I had problems as a result.
find quote
xbs08 Online
Posting Freak
Posts: 1,741
Joined: May 2008
Reputation: 7
Location: Portugal
Post: #22
Thanks great work guys!

  • Intel NUC Kit DN2820FYKH
  • Crucial DDR3L SO-DIMM 4GB
  • SanDisk ReadyCache 32GB SSD
  • Microsoft MCE model 1039 RC6 remote
find quote
theslime Offline
Junior Member
Posts: 39
Joined: Oct 2011
Reputation: 1
Post: #23
Cool! I just installed the iso on a single partition (and apt-get upgraded). Playback is pretty smooth, but I'm seeing a bit of consistent (but not constant) horizontal flickery tearing near the top of the screen, which is a bit of a dealbreaker. But that's what testing builds are for. Logs:

xbmc@xbmc:~$ dmesg | pastebinit
http://paste.ubuntu.com/7127256/
xbmc@xbmc:~$ pastebinit ~/.xbmc/temp/xbmc.log
http://paste.ubuntu.com/7127257/
xbmc@xbmc:~$ pastebinit /var/log/Xorg.0.log
http://paste.ubuntu.com/7127259/
xbmc@xbmc:~$ DISPLAY=:0 vdpauinfo | pastebinit
http://paste.ubuntu.com/7127260/
xbmc@xbmc:~$ dpkg -l |grep mesa | pastebinit
http://paste.ubuntu.com/7127261/

Hardware: Shuttle XS35GSv3 with AMD Radeon HD 7410m GPU.

I'm usually running a recent (a couple of days old) OpenElec nightly, which is smooth as silk on the same hardware, even running from a battered old USB 2 pendrive. Strangely, every other distro has given me issues, even following Fritsch's Radeon how-to mostly to the letter (had to improvise since the mini.iso doesn't recognise my network card) gave me occasional stutters.

(The only kinda stable system I've had before Radeon OSS driver was XBMCbuntu 12.04, which only used to work if I downgraded Catalyst to 12.6.)

While OpenElec is smooth as silk (the first smooth experience on this nightmare of a computer), I want more server capabilities than OpenElec offers, so I have high hopes for this thread. Hope my logs help a little bit. Smile

And thanks for the great work so far!
find quote
wsnipex Offline
Team-Kodi Member
Posts: 3,964
Joined: Jun 2011
Reputation: 96
Post: #24
updated ISO available http://mirrors.xbmc.org/releases/XBMCbun..._amd64.iso see 1st post for changelog
find quote
Questionario Offline
Junior Member
Posts: 42
Joined: Aug 2009
Reputation: 0
Post: #25
- disabled X11 backing store
what does that mean? should I re-install it if I already removed pulseaudio?
works fine for me on amd hardware (E-350) with DTS-HD btw
find quote
uNiversal Offline
Out of Memory
Posts: 5,775
Joined: Oct 2012
Reputation: 143
Location: Binary pulsar
Post: #26
@Questionario

Doesn't mean you need to start libraries from scratch though. Its up to you if you reinstall or not, but, if it helps testing and provide better iso then ya. Personally in your case if you dont notice anymore issues, you could test resinatll say when xbmcbuntu goes RC as your issue has been addressed.
(This post was last modified: 2014-03-21 23:17 by uNiversal.)
find quote
nickr Offline
Donor
Posts: 9,596
Joined: May 2009
Reputation: 174
Location: Christchurch NZ
Post: #27
(2014-03-21 22:55)Questionario Wrote:  - disabled X11 backing store
what does that mean?
the clearest explanation I could find was
http://kign.blogspot.co.nz/2008/06/backing-store.html but quite how it relates to XBMC I am not sure.

If I have helped you or increased your knowledge, click the plus button and increase my reputation :)
find quote
teeedubb Offline
Donor
Posts: 2,697
Joined: Mar 2010
Reputation: 63
Location: Down Under
Post: #28
Some good info here: http://forum.xbmc.org/showthread.php?tid...pid1627161
find quote
nickr Offline
Donor
Posts: 9,596
Joined: May 2009
Reputation: 174
Location: Christchurch NZ
Post: #29
1. The background screen when installing looks debian not ubuntu.

2. when running as a live cd it doesn't appear to be possible to log in to a xbmcbuntu session. There are no alternatives in the "sessions" part of the login screen.

3. Despite not clicking "download updates during install" it seems to be doing so - currently "Retrieving file 56 of 90"

If I have helped you or increased your knowledge, click the plus button and increase my reputation :)
(This post was last modified: 2014-03-22 07:07 by nickr.)
find quote
ghostelement Offline
Fan
Posts: 444
Joined: Sep 2010
Reputation: 3
Location: Portland, Oregon
Post: #30
+1 On this SQL library speed issue. Using an SSD causes XBMC to launch before network is available, and forces a reload in order to use it. Any chance a new build can include a fix for this?[

(2014-03-19 04:51)KeithLM Wrote:  I'm experimenting with this on my NUC and it's working fairly well, however I have one problem, since I'm using an SSD XBMC is starting before the network is fully up, preventing it from connecting to my sql server. At least that's what I suspect to be happening because XBMC comes up real quick. Restarting XBMC after the system has started gets it connected. Also I added "net-device-up IFACE!=lo" to /etc/init/lightdm.conf and then it successfully connected on boot. Can anybody offer a solution that won't get wiped out when installing future system updates?

I'm seeing a bit of tearing also. But I know there's threads on that so I'll look into those problems real quick. I had installed XBMCbuntu 12 then updated to 13 beta 2 and didn't notice any video issues, so I don't know if that's a new problem with the 64-bit version or what.

Initially it would only provide two channel sound. Removing PulseAudio fixed that issue. In fact it's better than what I had before since with the previous install DTS-HD wouldn't work. Why is PulseAudio installed? Isn't that nothing but trouble? Any time I see someone with audio trouble and PulseAudio the first piece of advice is remove Pulse. As soon as I rebooted after removing Pulse it was instant success. XBMC even had it on the correct device.

My bluetooth keyboard isn't working with this install, it did before. So that's another minor issue I have to look into.

Update
Tweaking the various video settings, sync and the like, seems to have eliminated any tearing problems. And running "apt-get install bluez-utils" has got my keyboard up and running. All-in-all this is a damn good build.

[Image: tgdb-buttonlogosmall.png]
thegamesdb.net - An open video games database.
scottbrant.net - Blog
(This post was last modified: 2014-03-22 07:32 by ghostelement.)
find quote
Post Reply