Kodi on FreeBSD - build and run fails

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
dave2015 Offline
Junior Member
Posts: 10
Joined: Apr 2015
Reputation: 0
Post: #1
Anyone successfully running 16.0, latest ports version, on FreeBSD?

It builds on my 9.3 box but crashes out with:

libpng warning: iCCP: known incorrect sRGB profile
Segmentation fault (core dumped)
cat: /proc/sys/kernel/core_pattern: No such file or directory
usage: dirname string [...]
cat: /proc/sys/kernel/core_pattern: No such file or directory
usage: dirname string [...]
find: -maxdepth: -name: value must be positive
Crash report available at /home/dave/kodi_crashlog-20160417_131543.log

On two 10.3 boxes it just doesn't build:

pkg-static: libdcadec-0.2.0 conflicts with libdca-0.0.5_1 (installs files into the same place). Problematic file: /usr/local/bin/dcadec
*** Error code 70

So, I pkg delete -f libdca-0.0.5_1 (lots of stuff depends on this, without -f lots of other stuff would be deleted
next I pkg install libdcadec
the portupgrade -c kodi, which goes a lot further in the build but fails at:

Jsonbuilder: tools/depends/native/JsonSchemaBuilder/bin/JsonSchemaBuilder
gmake -C xbmc/interfaces/json-rpc ServiceDescription.h
gmake[3]: Entering directory '/usr/ports/multimedia/kodi/work/xbmc-a5f3a99/xbmc/interfaces/json-rpc'
../../../tools/depends/native/JsonSchemaBuilder/bin/JsonSchemaBuilder schema/version.txt schema/license.txt schema/methods.json schema/types.json schema/notifications.json
/usr/local/lib/compat/libstdc++.so.6: version GLIBCXX_3.4.11 required by /usr/ports/multimedia/kodi/work/xbmc-a5f3a99/tools/depends/native/JsonSchemaBuilder/bin/JsonSchemaBuilder not found
Makefile:39: recipe for target 'ServiceDescription.h' failed
gmake[3]: *** [ServiceDescription.h] Error 1
gmake[3]: Leaving directory '/usr/ports/multimedia/kodi/work/xbmc-a5f3a99/xbmc/interfaces/json-rpc'
codegenerator.mk:76: recipe for target 'xbmc/interfaces/json-rpc/ServiceDescription.h' failed
gmake[2]: *** [xbmc/interfaces/json-rpc/ServiceDescription.h] Error 2
gmake[2]: Leaving directory '/usr/ports/multimedia/kodi/work/xbmc-a5f3a99'
*** Error code 2

All help will be appreciated, just say if more info is needed.
(This post was last modified: 2016-04-17 14:28 by dave2015.)
find quote
dave2015 Offline
Junior Member
Posts: 10
Joined: Apr 2015
Reputation: 0
Post: #2
OK, it appears to be a dependency conflict.

KODI 16.0 depends on libdcadec.
Other stuff, including KDE depend oin libdca

Libdcadec and libdca are incomptabile and won't both install at the same time as they place files in the same place.

As a quick test I just did a make deinstall on libdca, a make install on libdcadac and a make install kodi. I'm remoted into the desktop at the moment so can';t test it and it's too late now. I'll check what works/doesn't work tomorrow and if necessary remove lobdcadec and put libdca back. Maybe the two DTS libraries are compatible or one or the other will act as a drop in replacement for the other if I "fool" one or the others dependencies :-)

----------------------------------------------------------------------------------------------
cat /usr/ports/multimedia/libdca/pkg-descr
libdca is a free library for decoding DTS Coherent Acoustics streams.

libdca is still in early development stage so don't expect too much from it.

WWW: http://www.videolan.org/developers/libdca.html
---------------------------------------------------------------------------------------------
cat /usr/ports/multimedia/libdcadec/pkg-descr
dcadec is a free DTS Coherent Acoustics decoder with support for HD extensions.

Supported features:
Decoding of standard DTS core streams with up to 5.1 channels
Decoding of DTS-ES streams with discrete back channel
Decoding of High Resolution streams with up to 7.1 channels and extended bitrate
Decoding of 96/24 core streams
Lossless decoding of Master Audio streams with up to 7.1 channels, 192 kHz
Downmixing to stereo and 5.1 using embedded coefficients

Features not implemented:
Decoding of DTS Express streams
Applying dynamic range compression and dialog normalization

WWW: https://github.com/foo86/dcadec
(This post was last modified: 2016-04-20 02:43 by dave2015.)
find quote
wsnipex Offline
Team-Kodi
Posts: 6,339
Joined: Jun 2011
Reputation: 163
Post: #3
You can disable dcadec(hd auduo decoding) by removing it from ffmpegs configure flags in tools/depends/target/ffmpeg
find quote
dave2015 Offline
Junior Member
Posts: 10
Joined: Apr 2015
Reputation: 0
Post: #4
Thanks for the help, but unfortunately either I don't know what I'm doing or I'm misunderstanding what you mean.


edit /usr/ports/multimedia/kodi/Makefile (made copy first!)
remove line libenca.so:converters/enca \

EDIT: That line above should, of course, be
libdcadec.so:multimedia/libdcadec \


make fetch extract

edit /usr/ports/multimedia/kodi/work/xbmc-a5f3a99/tools/depends/target/ffmpeg/Makefile
change ffmpg_config += --enable-libdcadec
to ffmpg_config += --disable-libdcadec

make

gets past the json part and reaches:

configure: loading site script /usr/ports/Templates/config.site
(lots of Checking... lines)
configure: Using Python 2.7
== Wayland disabled. ==
(more checking... lines)
checking vorbis/vorbisfile.h usability... yes
checking vorbis/vorbisfile.h presence... yes
checking for vorbis/vorbisfile.h... yes
checking for LIBDCADEC... no
configure: error: libdcadec not found
===> Script "configure" failed unexpectedly.

Tried
cd /usr/ports/multimedia/kodi/work/xbmc-a5f3a99/tools/depends/target/ffmpeg/FFmpeg-2.8.6-Jarvis-16.0
./configure

In "Enabled Decoders", we still see
adpcm_thp dvdsub libdcadec
(This post was last modified: 2016-04-23 14:32 by dave2015.)
find quote