Kodi Community Forum

Full Version: Java error in android app?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I'm new to all of this, but I had the remote up and working beautifully for a few days, and then, without changing anything, I get this error message when trying to connect from my Samsung Galaxy Spica:

i/o exception (java.io.filenotfoundexception)

Any help would be much, much appreciated.
Weird. Do you have a more complete logfile? It's difficult to tell more with only that information.
Thanks a lot for the response. I'm learning as I go, but I think I've managed to get the relevant log info here: http://pastebin.com/cySw90up

Again, any help would be much appreciated.

Hmm that's weird. Can you try to paste the following URL into the browser of a PC connected to your LAN as well as into your Android browser?


Does it display something?
On the PC I get: Google Chrome could not connect to

And on the Android: Web page not available

I've uninstalled and reinstalled in both places, but still nothing.
That means that either your XBMC host changed its IP address (you on DHCP?) or XBMC isn't running. Make sure you have the right IP and XBMC is up, then also the remote should work again.
OK, now when I enter your code on the PC with XBMC running, I get this: invalid request

I’m running Vista with a standard setup and can’t even tell you if I’m on DHCP (which probably means I’m not) – just WIFI on a home router.

I’ve carefully rechecked IP address (cmd>ipconfig>IPv4 Address…. - and it hasn't changed) username, password, port, etc. on both PC and phone, and I’m still getting the same error.

Thanks very much for your time.

P.S. I first noticed the problem after I installed Transdroid (also using the 8080 port). When the XBMC Remote problem started, I uninstalledTD (seeing how it was the only thing that had changed), but that didn’t fix anything. Maybe irrelevant…but I’m working off common sense here, not computer sense.
What if you disable user/password authentication?
I was getting all the same error messages. Turns out I had a torrent running in the background using port 8080. Just had to change the XBMC port to 9090.

It was killing me because I had the remote working on a borrowed iPed (no-one would lend me a half decent android device) a few weeks ago and wouldn't work on my brand new Galaxy S.

Can I just say, I nearly justified buying my new phone solely on the official XMBC remote, can't wait for V 1.0.0. It would be cool if you could show your library to mates off line, it's hard to do XBMC justice with word of mouth.
That finally did it! Thank you! The remote function was working but not the library, but now it does.
For the life of me I can't find a way to disable user/password authentication. Can you help me please?
Just leave the password field blank in both the xbmc and the remote.
@ThisGuy: Thanks, that's a good hint. Will put it into the FAQ.
Thanks for the help, changing port solved this for me too!
I have the same issue, with all of the above suggetions failing.
Pages: 1 2