Kodi Community Forum
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0) (/showthread.php?tid=298462)



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - arcane - 2018-10-18

(2018-10-18, 01:14)gwilly7 Wrote:
(2018-10-18, 00:09)arcane Wrote: Hello,

I just tried to run the latest builds (#1016 and #1017) on a Ryzen 3 2200G. Unfortunately, this did not work because the Xorg server could not be started:

Failed to start Xorg Server.
See 'systemctl status xorg.service' for details.
Dependency failed for Fluxbox Window Manager.

...
 I am using a 2400G and not having any issues.  I am using the 1016x build currently.  
Sorry, my bad. I just switched the hardware and forgot to change / delete the Xorg configuration I added ages ago. It was working fine with a fresh install and after I deleted the old Xorg configuration my old installation now runs without problems as well.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-10-18

New LibreELEC.tv Leia build #1018: Generic
(Supercedes previous build)

SHA256 Checksum: 8fd69cebc3b42a06aff614cbd0db7ee924dbe1ec615ed8b313e8192cb05e2944 (Generic)

# uname -a
Linux NUC 4.18.15 #1 SMP Thu Oct 18 21:04:39 BST 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20181018210245-#1018-g86e23ee [Build #1018]

# Kodi version
(18.0-BETA4 Git:d6218df). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (86e23ee, changelog) and tip of XBMC master (d6218df, changelog) with the following modifications: Build Highlights:
  1. New 4.18.15 kernel
  2. xf86-video-nvidia: update to xf86-video-nvidia-410.66
Build Details:
  1. LibreELEC.tv:
    • Xorg server 1.20.2 (PR:3030, 1 commit, 1 file changed)
    • kodi: add kodi-remote script (PR:3019, 1 commit, 2 files changed)
    • linux: XBox DVD Remote uses 12 bits scancodes (PR:3039, 1 commit, 3 files changed)
  2. XBMC:
    • fixed: KODI_BUILD_DIR mirroring of custom data (PR:14641, 1 commit, 1 file changed)
    • added: copyright years to version.txt (PR:14638, 1 commit, 6 files changed)
  3. inputstream.adaptive:
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:3006 (perma): linux (Generic/RPi): update to linux-4.18.15
    • Added: [env] PR:3038 (perma): xf86-video-nvidia: update to xf86-video-nvidia-410.66
    • Updated: [pkg] PR:14625 (perma): Allow a clean shutdown on window system failure



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-10-19

(2018-10-18, 13:30)Milhouse Wrote: Damn, I can reproduce the panic with 1015y - apologies for not testing this beforehand as I thought it was a fairly minor change.

I'll let the r8169 developer know.

@Celox I've got a new patch to test with 4.19-rc8, and this time I've booted #1018y and can confirm it doesn't panic, and it does resume from S3 - just need to see if it now resumes from S5 as well. Thanks!

#1018y: Generic


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - wellsecond - 2018-10-19

(2018-09-03, 20:31)Milhouse Wrote:
(2018-09-03, 19:22)wishyou Wrote: Hi @Milhouse

Just a quick question, how does the alpha-builds related to your builds now, are they similar?
I.e. can I switch from a mid-august build to the alpha-release without issues?

Wish
At this time the latest 8.90.004 alpha build is fairly close to the latest test build, although the Alpha build uses an older kernel (still 4.18.y though, so that shouldn't make to much difference) and lacks various other changes/updates present in these test builds. Alpha/Beta builds will always trail these test builds by varying amounts, from days to weeks. Obviously as time passes between an alpha (or beta) build and the latest test build, the number of differences (mainly Kodi bug fixes, package and kernel updates) steadily increases until most of those changes appear in the next alpha/beta build at which point the differences reduce (ideally to zero, but that will probably only happen once I stop creating test builds).

I don't actively maintain a list of the differences between the latest official Alpha/Beta release and these test builds - if you need a specific feature you could probably determine from GitHub whether it is present in the Alpha/Beta, or not.

Edit: You can switch from these test builds to the official release, the only issue might be wth PVR add-ons as you'll then be relying on the online repository for PVR add-on updates (latest are always included in my builds) and hopefully those are now fairly recent. 
How can I switch from the test build to the official release?


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - menno - 2018-10-19

(2018-10-07, 22:36)fritsch Wrote:
(2018-10-04, 14:02)menno Wrote:
(2018-10-03, 15:33)Milhouse Wrote: Those with the artefact problem, can you please test the following builds:

1002b: Generic - same as #0813
1002c: Generic - 1002b + PR14291
1002d: Generic - 1002c + PR14282
1002e: Generic - 1002d + PR14295

1002b should not have the artefact issue, while 1002e should have the artefact issue. I'm not expecting c & d to have it, but who knows for sure so please test them too.

Assuming the issue is confirmed as starting with 1002e then I might try and narrow it down to the specific commit with additional test builds.

Edit: We still need a debug log from an affected build which may reveal some specific GL/mesa behaviour that is hardware dependent.
I didnt have time to do all of them, bu I can confirm D does not have artifacts for me (asus chromebox 2014)    

Do you have custom configured OVERSCAN values? E.g. in kodi's gui calibration? Can you reset them please?   
 Hi Fritsch,
Woud this be considered custom settings?
Code:
    <resolutions>
        <resolution>
            <description>[email protected] 60.00 - Full Screen</description>
            <subtitles>1015</subtitles>
            <pixelratio>1.000000</pixelratio>
            <refreshrate>60.000000</refreshrate>
            <output>HDMI1</output>
            <xrandrid>0x48</xrandrid>
            <overscan>
                <left>21</left>
                <top>13</top>
                <right>1826</right>
                <bottom>1054</bottom>
            </overscan>
        </resolution>
        <resolution>
            <description>HDMI1: 1920x1080 @ 60.00Hz</description>
            <subtitles>1042</subtitles>
            <pixelratio>1.000000</pixelratio>
            <refreshrate>60.000000</refreshrate>
            <output>HDMI1</output>
            <xrandrid>0x48</xrandrid>
            <overscan>
                <left>0</left>
                <top>0</top>
                <right>1920</right>
                <bottom>1080</bottom>
            </overscan>
        </resolution>

I do remember back in the days you had some special settings for this chipset and hw scaling and something i believe with 20% etc, I cannot find that in the current version though anymore. This is a snippit from guisettings.xml


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - fritsch - 2018-10-19

Quote:                <left>21</left>
                <top>13</top>
                <right>1826</right>
                <bottom>1054</bottom>

This makes no sense at all ... but explains your issue.

Remove that and fix your TV settings.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-10-19

(2018-10-19, 05:09)wellsecond Wrote: How can I switch from the test build to the official release?

Just drop the official release tar or img.gz file in your update folder and reboot.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - menno - 2018-10-19

(2018-10-19, 10:20)menno Wrote:
(2018-10-07, 22:36)fritsch Wrote:
(2018-10-04, 14:02)menno Wrote: I didnt have time to do all of them, bu I can confirm D does not have artifacts for me (asus chromebox 2014)    

Do you have custom configured OVERSCAN values? E.g. in kodi's gui calibration? Can you reset them please?    
 Hi Fritsch,
Woud this be considered custom settings?
Code:
    <resolutions>
        <resolution>
            <description>[email protected] 60.00 - Full Screen</description>
            <subtitles>1015</subtitles>
            <pixelratio>1.000000</pixelratio>
            <refreshrate>60.000000</refreshrate>
            <output>HDMI1</output>
            <xrandrid>0x48</xrandrid>
            <overscan>
                <left>21</left>
                <top>13</top>
                <right>1826</right>
                <bottom>1054</bottom>
            </overscan>
        </resolution>
        <resolution>
            <description>HDMI1: 1920x1080 @ 60.00Hz</description>
            <subtitles>1042</subtitles>
            <pixelratio>1.000000</pixelratio>
            <refreshrate>60.000000</refreshrate>
            <output>HDMI1</output>
            <xrandrid>0x48</xrandrid>
            <overscan>
                <left>0</left>
                <top>0</top>
                <right>1920</right>
                <bottom>1080</bottom>
            </overscan>
        </resolution>

I do remember back in the days you had some special settings for this chipset and hw scaling and something i believe with 20% etc, I cannot find that in the current version though anymore. This is a snippit from guisettings.xml 
Ok ill drop it tomorrow.
  Latest nightly didnt fix the problem. I am back to "d" for now and drop the guisettings.xml stuff tomorrow for further test


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-10-20

New LibreELEC.tv Leia build #1019: Generic
(Supercedes previous build)

SHA256 Checksum: 5b3b087354fcb88645f4302f9eacc42fed1e30d693a568a9368164632ae58fe6 (Generic)

# uname -a
Linux NUC 4.18.15 #1 SMP Sat Oct 20 00:24:59 BST 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20181020002309-#1019-g86e23ee [Build #1019]

# Kodi version
(18.0-BETA4 Git:a3f5e1e). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (86e23ee, changelog) and tip of XBMC master (a3f5e1e, changelog) with the following modifications: Build Highlights:
  1. busybox: update to 1.29.3
  2. mesa: update to mesa-18.2.3
  3. DVB addons - enable more options
Build Details:
  1. XBMC:
    • [cmake][addons] package CUSTOM_DATA & ADDITIONAL_BINARY for posix (PR:14646, 1 commit, 1 file changed)
    • [GBM] add vt handler utility (PR:14627, 1 commit, 5 files changed)
    • X11: fixes a lot of misses in VideoReferenceClock OML (PR:14637, 1 commit, 1 file changed)
    • [Feature][skin.estuary] add support for artist-slideshow add-on (PR:14558, 1 commit, 3 files changed)
    • Allow a clean shutdown on window system failure (PR:14625, 4 commits, 8 files changed)
  2. inputstream.adaptive:
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] compare (perma): kodi: next (Nov 2018)
    • Added: [env] patch: config/functions: next wave of cleanups
    • Updated: [env] PR:3001 (perma): DVB driver addons update to latest
    • Added: [env] PR:3041 (perma): busybox: quit countdown timers on keyboard input
    • Added: [env] PR:3042 (perma): busybox: update to 1.29.3
    • Added: [env] PR:3043 (perma): mesa: update to mesa-18.2.3



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - theboy181 - 2018-10-20

I'm not sure if I encountered a BUG or if there was a development change regarding my WIFI PCIE card.

I installed LibreELEC then updated to LibreELEC-Generic.x86_64-9.0-Milhouse-20181018210245-#1018-g86e23ee via the UPDATE folder, using this installed (Rosewill RNX-AC1900PCE) WIFI card.

https://wikidevi.com/wiki/Rosewill_RNX-AC1900PCE

After the update the WIFI stopped working. I have tested several builds to see where it broke, and going all the way back to AUGUST 2018 was still a no go.

Here is a log http://ix.io/1pCw

I do hope that I can get 9.0 working, we love our Netflix, and Inputstreams.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - piotrasd - 2018-10-20

Hi @fritsch im watching 4K UHD channels - and I noticed the tone mapping don't work well for HLG 
https://en.wikipedia.org/wiki/Hybrid_Log-Gamma

Format : MPEG-TS
File size : 3.91 GiB
Duration : 20 min 44 s
Overall bit rate mode : Variable
Overall bit rate : 27.0 Mb/s

Video
ID : 256 (0x100)
Menu ID : 1 (0x1)
Format : HEVC
Format/Info : High Efficiency Video Coding
Format profile : Main [email protected]@high
Codec ID : 36
Duration : 20 min 44 s
Bit rate : 25.4 Mb/s
Width : 3 840 pixels
Height : 2 160 pixels
Display aspect ratio : 16:9
Frame rate : 50.000 FPS
Standard : Component
Color space : YUV
Chroma subsampling : 4:2:0 (Type 0)
Bit depth : 10 bits
Bits/(Pixel*Frame) : 0.061
Stream size : 3.68 GiB (94%)
Color range : Limited
Color primaries : BT.2020
Transfer characteristics : HLG
Matrix coefficients : BT.2020 non-constant

Image




colors maybe are not washed fully but picture is slightly dark and looks like some problem with gamma.
I can post some sample for you, I'm using coffee lake NUC with latest LE with libva 2.3.0


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - fritsch - 2018-10-20

That's expected. Therefore you can change the Parameter on the fly.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - piotrasd - 2018-10-20

to be honest something is wrong I tried from 0 up to 5 for me its looks same ... nothing changed Sad 
and also tried switch off - and still same picture


Update
@fritsch 
Ok i tested around 1h everything because I was think that issue is only in LiveTV 
but I tried switch off and on and change value from 0 to 5 with no any change on picture, but with any other movies MKV that's work - like 0.10 is ultra bright picture.

Image

but next I recorded something and play from Movies and same issue - so im think maybe Kodi don't recognize HLG ? and don't use tone mapping ? 

here sample: 
https://ufile.io/h1sow


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - fritsch - 2018-10-20

Possible. I pinged fernet for his oppinion. Will download the sample now. I think I know what goes "wrong".


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - FernetMenta - 2018-10-21

Kodi does not support HLG yet. Instead of metadata HLG has its own transfer functions that needs to be considered.