•   
  • 1
  • 32
  • 33
  • 34(current)
  • 35
  • 36
  • 56
  •   
WIP Windows DirectX 11 upgrade test thread
(2015-07-29, 18:50)afedchin Wrote: @Ed76
Please try same tests with disabled harware acceleration - DXVA2 and Auto detect in render method.

updated to catalyst 15.7.1 and all is fine now (deinterlacing and also color room)

i noticed another thing: in file "guisettings" i found this:

<defaultvideosettings>
.
.
<sharpness>0.000000</sharpness>
.
.
does this work? max. value seems to be "1". but there ist no entry in gui? can you tell something about that?
Reply
this setting cannot be used in dxva.
Reply
(2015-08-07, 12:05)afedchin Wrote: @mikesilvo164,
Will be fixed in next build.

Thanks Smile

Would that be the next DX 11 build or Jarvis nightly or both Huh
Reply
New build Kodi Isengard 15.1 Beta
  • Fixed displaying textures which is shown with reverse side.
  • Rebased onto Isengard 15.1 branch.

Download link at the first post.
Reply
just a headsup for legacy AMD users. I upgraded to Windows10 and the stock Win10 AMD drivers (dated january 2015) work perfectly fine with DXVA2 acceleration etc - so no need for outdated Catalyst drivers
Reply
Hi.

I've been using the Isengard DX11 version of 23th of July and 7th of August, and in both of them I have a huge problem of tearing...

My setup:

AMD E2-1800 APU
AMD Radeon HD 7340 1280x720 @ 60Hz
Windows 7 64 bits
1 single monitor: Samsung HD-Ready TV
Catalyst driver 14.2

My video output settings:
Display Mode: Full Screen #1
Resolution 1280 x 720p
Use fullscreen window
3D Disabled
Vertical blank sync -> Always enabled
Used limited colour range (16-235)

Acceleration:
Render method: Autodetect
HQ scalers: 0%
Allow DXVA2

However, with Helix 14.2, Isengard DX9 15.0 and 15.1, with the same video settings, I have no tearing at all.

If you need any debug log or whatever else, please let me know.

Thanks and awesome work with DX11!
Reply
(2015-08-08, 15:54)da-anda Wrote: just a headsup for legacy AMD users. I upgraded to Windows10 and the stock Win10 AMD drivers (dated january 2015) work perfectly fine with DXVA2 acceleration etc - so no need for outdated Catalyst drivers

Thanks for this Information, i try this in the next week.
Reply
(2015-07-29, 18:18)Ed76 Wrote: i noticed another problem:
because of my tv i have to limit the color range (16-235). i do this within catalyst (and not within kodi). the problem is, not every time the video is set to limited color, sometimes it is set to full color. i can test this with that "black clipping/flashing lights video", i guess you know that. i guess it could be something to do with refresh rate change, but iam not sure.

log: http://pastebin.com/ad2tLJrC

in debug log you will see that i have done the following:

start kodi (50 hz)
start testvideo (24hz), result: full color range
start testvideo again, result: limited colorrange
start testvideo again, result: limited collorrange
start tv (50hz)
start testvideo: result: full color range
start testvideo again, result: limited color range
start testvideo again, result: limited color range
start tv (50hz)
start testvideo: result: full color range
start testvideo again, result: limited color range
.......

i also limited color range within kodi with the same result

With my amd card, I need to set the color range for each hz separately.
Reply
Where can I find the video "black clipping/flashing lights"? I also want to test my clolour range settings, because I'm note sure what the correct seetings are.
Reply
(2015-08-10, 10:56)Caramba69 Wrote: Where can I find the video "black clipping/flashing lights"? I also want to test my clolour range settings, because I'm note sure what the correct seetings are.

http://www.avsforum.com/forum/139-displa...ation.html
Reply
I have tested the black level file. So what black level needs to flash to have the correct settings: 2-25 or 17-25 only?
Reply
Just a heads up: I recently tested the DX11 build on Windows 10 with Radeon HD 6570 and it worked fine. Pretty responsive and very quick display mode changes. (Unfortunately Win10 feels like a rough beta so I will stay on 8.1 for a while.)
My patches (source code) :: Windows installer builds
These builds are unofficial! If you find a bug, make sure it is also present in a recent official build and you can reproduce it before filing a ticket.
Reply
(2015-08-09, 23:53)balkerman Wrote:
(2015-07-29, 18:18)Ed76 Wrote: i noticed another problem:
because of my tv i have to limit the color range (16-235). i do this within catalyst (and not within kodi). the problem is, not every time the video is set to limited color, sometimes it is set to full color. i can test this with that "black clipping/flashing lights video", i guess you know that. i guess it could be something to do with refresh rate change, but iam not sure.

log: http://pastebin.com/ad2tLJrC

in debug log you will see that i have done the following:

start kodi (50 hz)
start testvideo (24hz), result: full color range
start testvideo again, result: limited colorrange
start testvideo again, result: limited collorrange
start tv (50hz)
start testvideo: result: full color range
start testvideo again, result: limited color range
start testvideo again, result: limited color range
start tv (50hz)
start testvideo: result: full color range
start testvideo again, result: limited color range
.......

i also limited color range within kodi with the same result

With my amd card, I need to set the color range for each hz separately.

I'm also interested in the answer.
Do I have to set Kodi also on limited color range, because if I do my blacks are worse? I now have set it only in my NVIDIA GeForce GTX 760, which seems to give the best results.
Reply
(2015-08-11, 08:26)Caramba69 Wrote: I have tested the black level file. So what black level needs to flash to have the correct settings: 2-25 or 17-25 only?

I guess 17-25 should blink only?
Reply
(2015-08-11, 13:29)Kwart1001 Wrote:
(2015-08-09, 23:53)balkerman Wrote:
(2015-07-29, 18:18)Ed76 Wrote: i noticed another problem:
because of my tv i have to limit the color range (16-235). i do this within catalyst (and not within kodi). the problem is, not every time the video is set to limited color, sometimes it is set to full color. i can test this with that "black clipping/flashing lights video", i guess you know that. i guess it could be something to do with refresh rate change, but iam not sure.

log: http://pastebin.com/ad2tLJrC

in debug log you will see that i have done the following:

start kodi (50 hz)
start testvideo (24hz), result: full color range
start testvideo again, result: limited colorrange
start testvideo again, result: limited collorrange
start tv (50hz)
start testvideo: result: full color range
start testvideo again, result: limited color range
start testvideo again, result: limited color range
start tv (50hz)
start testvideo: result: full color range
start testvideo again, result: limited color range
.......

i also limited color range within kodi with the same result

With my amd card, I need to set the color range for each hz separately.

I'm also interested in the answer.
Do I have to set Kodi also on limited color range, because if I do my blacks are worse? I now have set it only in my NVIDIA GeForce GTX 760, which seems to give the best results.

Did you enabled dynamic range or set pixel format? Because when i tried dynamic range wasn't working well..
Reply
  •   
  • 1
  • 32
  • 33
  • 34(current)
  • 35
  • 36
  • 56
  •   
 
Thread Rating:
  • 6 Vote(s) - 3.5 Average



Logout Mark Read Team Forum Stats Members Help
Windows DirectX 11 upgrade test thread3.56