Kodi Freeze When Timeshifting or Playing Recording
I recently wiped my NUC5PPYH and re-loaded it fresh with LE 7.90.010. I didn't restore any backup from my previous Milhouse build of LE, which was upgraded from OE (Isengard.) With the upgraded LE/OE setup, Media Portal would work just fine. I could watch live TV and recordings using TSReader with my Samba credentials.

After re-loading the NUC, I setup the Media Portal PVR addon within Kodi (2.4.12). It configures fine, loads the guide and shows all of my recordings. However, if I try to view a channel either from the list or guide Kodi will freeze with the blue progress circle. This also happens when I try to view a recording.

I AM able to view a recording using Kodi's built-in file manager and a smb path directly to the recorded tv share.

My log is here: Kodi.log

What I've tried:
  1. Disabled and re-enabled the Media Portal add-on
  2. Updated the TVServerKodi plugin to the lastest version for MP1 (
  3. Restarted MP backend server
  4. Checked and double-checked smb credentials in MP config
  5. Tried ffmpg streaming, but same issue
  6. Entered my WINS server and Workgroup into service settings

I searched pretty extensively here and on LE's forum, but am not making much headway. I should mention that I'm using this same MP backend with an Amazon Fire Stick running Kodi, and it works great. That one is on the current Jarvis version, though. Thanks for taking a look, I'm up for any ideas!
From your log file:
Quote:17:31:38.984 T:139744461707008 ERROR: AddOnLog: MediaPortal PVR Client: Failed to open file 'C:\LiveTV Buffer\live3-0.ts.tsbuffer' as 'smb://percivalConfused[email protected]/LiveTV Buffer/live3-0.ts.tsbuffer'
Seems that your Kodi installation is not able to access the timeshift buffer. Could you try to access the same share from Kodi directly (e.g. by adding it to the Video section)?
Developer of the MediaPortal PVR addon and retired developer of the Argus-TV PVR-addon.
Yeah, I'm confused by that error. Weirdly enough, I added the LiveTV Buffer share as a source in the file manager, and it connects. That connection didn't require credentials. The share on my Win10 TV server is accessible to everyone, though. There was nothing in it to play when I accessed it from the file manager. When I tried the recording share, I was able to play from the file manager but not the TV section. So it seems the issue isn't reading the share/files, it's writing back to them.

I haven't tried adding the LiveTV Buffer as a video source, though. I do know the credentials are right, as I'm using them on my Fire Stick in another room. I can try that when I get home later, but I'm not sure how I'd get anything in the Timeshift share to play if I can't open a channel.
Remove the credentials and try again.
Developer of the MediaPortal PVR addon and retired developer of the Argus-TV PVR-addon.
(2017-01-04, 19:14)margro Wrote: Remove the credentials and try again.

I gave it a run, and had the same issue. I noticed this time that it ran one of my CPU cores to 100% and it stuck there. Also, after rebooting this time, my resolution was back to default [email protected] So I wonder if the issue would be that I have the display refresh rate set to change with the video. I would think a lot of people use this setting, though.

* Edit: Un-checking "Adjust display refresh rate to match video" didn't fix the problem.

Here's the new log: kodi.log

Edit: That log is interesting. I see no errors after the channel is selected. It shows the screensaver activating, then me pressing down to wake it up. It shows me pressing Esc to try backing out (blue circle still going) and then finally shows me pressing 's' to activate the shutdown window and reboot.

Here's another one. The first accidentally had RTSP enabled, and without that enabled I had no weird CPU spikes. However, same issue with errors though, I don't see any errors after starting timeshift. I just never get any video. I can see the two timeshift files being created in the LiveTV Buffer folder on my backend server as well. Kodi.log without RTSP

After moving a couple files into the LiveTV Buffer folder and testing as a video source, I can confirm that I am able to play using that method. So the problem appears isolated to the PVR/TV section.
I'm reloading my NUC today with a new M2 SATA drive. The old 2.5" is being repurposed. I think I'll try starting out with the last build I know worked, Milhouse's last Krypton build.
Well, using Milhouse's 1129 build (Kodi b7) and Media Portal PVR client 2.4.9 yielded the same result. Reverting back to current, and now using 2.4.13 didn't help. So, I'm not sure where to go. Every other video in my library seems to work. No issues with smb connection that I can tell.

I tried resetting playback and display settings to defaults. That didn't help either. I'm open to ideas.

Most recent log: https://paste.ubuntu.com/23756411
Now ffmpg streaming is working. TSReader is not. I rebooted router and mp server machine. Credentials are 100% correct and work on another machine. I just tried creating another admin account on the mp box and using that in Kodi's MP client, but same issue.
Try the IP address rather than the server name in the settings. I've never managed to get mine working with the server name.
(2017-01-08, 11:30)mcelliott Wrote: Try the IP address rather than the server name in the settings. I've never managed to get mine working with the server name.

Thanks for the response, but I am using the IP address. Kodi is translating it to the host name at some point. I found after much trial and error that it is an smb issue. Kodi isn't accepting valid credentials. I've made several changes on the server despite another box working well. There are a few steps in the smb wiki that I thought might do it, but they made no difference. I'll just deal with ffmpg for now. It bothers me, but it would be wise to step away and come back to it refreshed.
I setup the NUC using Fritsch's guide for Ubuntu Server. I'm now running Kodi 17 RC2 with the Media Portal addon, and TS Reader is working using the same credentials/settings! I doubt the issue was solely LibreElec-related, but there were a few issues with that build I needed to get away from. In any case, I'm fully functional again!

Logout Mark Read Team Forum Stats Members Help
Kodi Freeze When Timeshifting or Playing Recording0
This forum uses Lukasz Tkacz MyBB addons.