Thread Closed
  •  Previous
  • 1
  • 134
  • 135
  • 136
  • 137
  • 138(current)
 
Thread Rating:
  • 7 Vote(s) - 4.86 Average
[DEPRECIATED] XBMC Subtitles - Addon Script (previously OpenSubtitles OSD)
(2012-03-23, 18:02)helcik Wrote: does anybody have problems with opensubtitles.org, it downloads the TXT files, but looks like the files have linux/unix line separators and the subtitles are not displayed correctly on windows machines.

let me know if this arleady has been addressed.

I use it on OSX and have no issues and have not heard about anyone with the same issue on win.

I have this same issue with opensubtitles.org - ubuntu 11.10 and Openelec
Latest git version - and addon version 2.9.37 (2.9.38 stop working all Sad )

When i back to 2.9.37 again almost all work without opensubtitles bug


Here log from 2.9.38
http://pastebin.com/f43JHeWm
(2012-03-24, 12:11)piotrasd Wrote: I have this same issue with opensubtitles.org - ubuntu 11.10 and Openelec
Latest git version - and addon version 2.9.37 (2.9.38 stop working all Sad )

When i back to 2.9.37 again almost all work without opensubtitles bug


Here log from 2.9.38
http://pastebin.com/f43JHeWm

can you try with this please -> https://github.com/amet/script.xbmc.subt...b390c2e494

Just wanted to say that this script is so awesome that I almost got emotional when I discovered and started using it :p

Very seldom something with the purpose of complementing something else does so in such an awesome manner.
(2012-03-22, 19:48)amet Wrote:
(2012-03-22, 17:17)tebicenter Wrote: Hi, Amet

Do you know when (an estimate) are you going to push an updated version of this plugin to the official repository?

Thanks for the hard work.

what are you after?

(2012-03-23, 09:56)amet Wrote:
Code:
[script.xbmc.subtitles] -v 2.9.38

- fix Argenteam service
- "fix" for Subdivx service, not happy with this but best I can do for now
- Select the current service in the service list, thx Martin Wallgren
- fixed Bulgarian addon.xml localization, thx Kiril

There, that's what I was looking for, thanks!
It's me again, sorry for the double post.

I just updated to final version of Eden on my ATV2 and the subtitle plugin was updated as well.

The problem is that when I tried to download a subtitle, I'm getting the following error:

Code:
21:31:11 T:230973440   ERROR: Exception in python script callback execution
21:31:11 T:230973440   ERROR: Traceback (most recent call last):
21:31:11 T:230973440   ERROR:   File "/var/mobile/Library/Preferences/XBMC/addons/script.xbmc.subtitles/resources/lib/gui.py", line 488, in onClick
21:31:11 T:230973440   ERROR: self.Download_Subtitles( self.getControl( SUBTITLES_LIST ).getSelectedPosition() )
21:31:11 T:230973440   ERROR:   File "/var/mobile/Library/Preferences/XBMC/addons/script.xbmc.subtitles/resources/lib/gui.py", line 297, in Download_Subtitles
21:31:11 T:230973440   ERROR: zipped, language, file = self.Service.download_subtitles(self.subtitles_list, pos, zip_subs, self.tmp_sub_dir, self.sub_folder,self.session_id)
21:31:11 T:230973440   ERROR:   File "/var/mobile/Library/Preferences/XBMC/addons/script.xbmc.subtitles/resources/lib/services/Argenteam/service.py", line 142, in download_subtitles
21:31:11 T:230973440   ERROR: log( __name__ ,"%s argenteam: número de init_filecount %s" % (debug_pretext, init_filecount)) #EGO
21:31:11 T:230973440   ERROR:   File "/var/mobile/Library/Preferences/XBMC/addons/script.xbmc.subtitles/resources/lib/utilities.py", line 110, in log
21:31:11 T:230973440   ERROR: xbmc.log((u"### [%s-%s] - %s" % (__scriptname__,module,msg,)).encode('utf-8'),level=xbmc.LOGDEBUG )
21:31:11 T:230973440   ERROR: UnicodeDecodeError
21:31:11 T:230973440   ERROR: :
21:31:11 T:230973440   ERROR: 'ascii' codec can't decode byte 0xc3 in position 22: ordinal not in range(128)

Any ideas of what this could be?

Thanks
Ok, found the problem.

I commented all lines with "log( __name__ ,"%s..." and it's working fine now.

Can you update it on git or should I make a new push?

Thanks in advance

PD: BTW, I'm Esteban, the one that added the argenteam service.
(2012-03-25, 03:01)tebicenter Wrote: Ok, found the problem.

I commented all lines with "log( __name__ ,"%s..." and it's working fine now.

Can you update it on git or should I make a new push?

Thanks in advance

PD: BTW, I'm Esteban, the one that added the argenteam service.

Do a PR on github, I'll pull it in .. thx
Hallo,

Sometimes when i want a subtitle to be found xbmc subtitles is giving this error.

Error : 'ascii' codec can't decode byte 0xe9 in position 115: ordinal not in range (128)

Can someone help me with this error ?
(2012-03-25, 14:01)flippamike Wrote: Hallo,

Sometimes when i want a subtitle to be found xbmc subtitles is giving this error.

Error : 'ascii' codec can't decode byte 0xe9 in position 115: ordinal not in range (128)

Can someone help me with this error ?

not without Debug Log
all further bugs and discussion moved to http://forum.xbmc.org/showthread.php?tid=126495

cheers,
amet
  •  Previous
  • 1
  • 134
  • 135
  • 136
  • 137
  • 138(current)
  Thread Closed



[DEPRECIATED] XBMC Subtitles - Addon Script (previously OpenSubtitles OSD)4.867