•   
  • 1
  • 39
  • 40
  • 41(current)
  • 42
  • 43
  • 93
  •   
Release -  CetonTV+HDHomeRun - Watch TV on XBMC (WIN/OSX)
(2012-04-18, 19:44)LehighBri Wrote:
(2012-04-17, 04:19)mcheng89 Wrote: @LehighBri: I'll investigate the cpu usage soon.... maybe its the transcoding options that i use?

Great. Looking forward to hearing what you find and what optimizations you think there might be

Could it be that transcoding to a 60fps video uses more cpu..
(its 60fps according to vlc. I dont set a frame rate when I transcode Tongue)
I'm guessing plex is transcoding to something lower like 24/30fps?

So I assume less frames equals lower cpu usage? I'll test this later tonight
Reply
(2012-04-19, 00:24)mcheng89 Wrote:
(2012-04-18, 19:44)LehighBri Wrote:
(2012-04-17, 04:19)mcheng89 Wrote: @LehighBri: I'll investigate the cpu usage soon.... maybe its the transcoding options that i use?

Great. Looking forward to hearing what you find and what optimizations you think there might be

Could it be that transcoding to a 60fps video uses more cpu..
(its 60fps according to vlc. I dont set a frame rate when I transcode Tongue)
I'm guessing plex is transcoding to something lower like 24/30fps?

So I assume less frames equals lower cpu usage? I'll test this later tonight

That might actually be why I get the "jumpy" video on the iPad? Fingers crossed...

Reply
test this Smile. it fixed the occasional stutter/jump that was happening for me!
i'm not sure if its the same jumpy video that you saw though

DELTED: http://www.mediafire.com/?lmzsctqnrc138k9 - didnt fix anything

seems what really fixed my stutter was my cpu upgrade
Reply
(2012-04-19, 00:50)mcheng89 Wrote: test this Smile. it fixed the occasional stutter/jump that was happening for me!
i'm not sure if its the same jumpy video that you saw though

http://www.mediafire.com/?lmzsctqnrc138k9

todo: update vlc interface to match flash web interface

I just tried the new file and the playback still seems pretty jumpy on CBS HD but works smooth on ABC HD, NBC HD, and ESPN HD (the ticker at the bottom of ESPN that scrolls across looked pretty smooth too)! For CBS, it also played audio for the first couple seconds then the audio completely cut out! (720p, low quality, wireless-n network on new ipad 3). vlc looks to still be around 70-80% cpu on either channel sometimes spiking to 90%. Did you just change the frame rate? And only issue on ESPN is it played back for about 10 seconds then the feed all of a sudden stopped for some reason (any clue how to debug that?)

FOLLOWUP: I tried 1080, low quality, and ESPN HD and ABC HD are both essentially unwatchable. Very very jerky.
Reply
attempt #2: http://www.mediafire.com/?3a3ywii3v9akfx7

playing around with encoding settings: http://mewiki.project357.com/wiki/X264_Settings
Reply
(2012-04-19, 05:49)mcheng89 Wrote: attempt #2: http://www.mediafire.com/?3a3ywii3v9akfx7

playing around with encoding settings: http://mewiki.project357.com/wiki/X264_Settings

The CPU usage appears to have gone up. On 720, low quality, i'm around 85-95% CPU whereas before it was around 70-80. And playback does not begin for some reason after I click the play icon that appears on the ipad (i get a "The operation could not be completed" on the ipad).

Is there any reason you're using vlc for transcoding vs. using something like ffmpeg?
Reply
(2012-04-19, 13:52)LehighBri Wrote: The CPU usage appears to have gone up. On 720, low quality, i'm around 85-95% CPU whereas before it was around 70-80. And playback does not begin for some reason after I click the play icon that appears on the ipad (i get a "The operation could not be completed" on the ipad).

Is there any reason you're using vlc for transcoding vs. using something like ffmpeg?

attempt #3: http://www.mediafire.com/?d61d8p8b6a5yi1z

I use vlc because it saves me alot of coding Smile

this one seems a bit better for me:
720 low quality I'm at 12-20% cpu (down from 16-25%) and 1080 around 30% cpu (didnt test this last time)
Reply
(2012-04-20, 00:12)mcheng89 Wrote:
(2012-04-19, 13:52)LehighBri Wrote: The CPU usage appears to have gone up. On 720, low quality, i'm around 85-95% CPU whereas before it was around 70-80. And playback does not begin for some reason after I click the play icon that appears on the ipad (i get a "The operation could not be completed" on the ipad).

Is there any reason you're using vlc for transcoding vs. using something like ffmpeg?

attempt #3: http://www.mediafire.com/?d61d8p8b6a5yi1z

I use vlc because it saves me alot of coding Smile

this one seems a bit better for me:
720 low quality I'm at 12-20% cpu (down from 16-25%) and 1080 around 30% cpu (didnt test this last time)

720 seems about the same... and sometimes I just get a black screen and no play button (and CPU is pegged in the 90s for 1080). 720 is definitely "good enough" for now Smile. But curious on why I get no play button despite the stream starting. Can you describe what tweaks have you been making?
Reply
Any progress on Android development? I would love to be able to watch TV on my Xoom tablet.
Reply
(2012-04-24, 16:53)jfoley Wrote: Any progress on Android development? I would love to be able to watch TV on my Xoom tablet.

does the latest version not work for you? (use the iphone interface)
other than full screen not working yet
Reply
(2012-04-25, 02:52)mcheng89 Wrote:
(2012-04-24, 16:53)jfoley Wrote: Any progress on Android development? I would love to be able to watch TV on my Xoom tablet.

does the latest version not work for you? (use the iphone interface)
other than full screen not working yet

Not sure which is the latest version (2.1.1 is what I am running)? I factory reset my Xoom so I am back on Honeycomb Android (3.2.6 I believe). I am not able to get it to play with the default browser. Chrome Beta will not work on the Honeycomb, only Ice Cream Sandwich.

**EDIT** Tried with my cell phone, which has ICS, it also doesn't work? My phone has ICS, but I can't get Chrome Browser to install. So, also using default browser.

**EDIT #2** I updated to version 2.1.3, same issue. However, when I launch RemoteCeton, it says I am on version 2.1.0, the web interface also says the same?

Reply
Is there an IRC channel for this project?
Reply
I can confirm it works on Xoom ICS 4.0.4, using default browser and MX Video Player to play the video.

Only the VLC interface is usable, also on Windows, the flash player cannot be maximized and the interface can't be navigated on android since it requires keys, touch won't switch channels.

The iphone interface on android is very slow and video won't play.
Reply
I can't get the logos to show for the life of me.

This is what my file structure looks like:

remoteCeton\resources:
<logos>
affiliates.xml
channelmap.csv
epgdata.db
logomapper.exe
logos.xml
mc2xml.dat
mc2xml.exe
xmltv.xml

Everything works except the logos are not showing.

Any ideas?

Thanks
Reply
Can I add a feature request? Can you add a timestamp to the remotecenton app? Not sure if this would be hard or not but useful for me.
Reply
  •   
  • 1
  • 39
  • 40
  • 41(current)
  • 42
  • 43
  • 93
  •   
 
Thread Rating:
  • 10 Vote(s) - 4.3 Average



Logout Mark Read Team Forum Stats Members Help
CetonTV+HDHomeRun - Watch TV on XBMC (WIN/OSX)4.310