Frodo seems to be hogging all the audio
#1
Updated to beta3 today and I noticed that mpd stopped playing audio because of xbmc hogging all the audio.
Anyone know a fix for this?
Reply
#2
Would greatly appreciate an answer on this.
I cannot be the only one running xbmc and mpd side by side
Reply
#3
Most likely it's not because of MPD but because of music/audio which is the subject here. Looks like 99,9% of the users here use XBMC for movies and series merely Undecided
MIFcom Mini-ITX ASUS ION2 | 4GB RAM | 120 GB SSD | LibreElec 8.01 / Kodi 17.1
Philips 42PFL8684
Reply
#4
I've run those two programs side by side for years and now with the new audio engine it just doesn't work anymore.
Before I could choose ALSA with a custom device in the audio system settings in xbmc, that seems to no longer be possible as I can only choose my soundcard directly.
Reply
#5
Look at AE's advancedsettings.xml.

http://wiki.xbmc.org/index.php?title=Aud...d_settings

Your looking to adding:
Code:
<advancedsettings>
   <audio>
     <streamsilence>0</streamsilence>
   </audio>
</advancedsettings>

That will release audio hogging from XBMC.

uNi
Reply
#6
Thank you uNiversal! Smile
Reply
#7
I presume it works as prescribed?

+1 uNi
Reply
#8
Unfortunately no Sad
Reply
#9
You did restart xbmc after adding that?

If it doest work its probably not reading the advancedsettings.xml.

Anyway I cant test it either way.

uNi
Reply
#10
That function is not currently enabled on ALSA - it was exposing some odd behaviour in the ALSA kernal, so has been by-passed for now (works on Windows only). We're hoping a fix there will be in place for 12.1.
System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon  AVR-3808CI  - Denon DVD-5900 Universal Player  - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray  - X-Box 360  - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
Reply
#11
nope, it won't work. Alsa sinks are not suspended/freed at all atm. Needs some work in AE.
Reply
#12
You can try with a build from end of November or so - it was still active then.
System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon  AVR-3808CI  - Denon DVD-5900 Universal Player  - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray  - X-Box 360  - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
Reply
#13
Thank you for the reply. Guess I'll have to make due without mpd until 12.1
Reply
#14
(2012-12-14, 17:22)DDDamian Wrote: You can try with a build from end of November or so - it was still active then.

could you post a link to the commit or commits that disables it so i could re enable on my own branch?

Reply
#15
in AESink.h

Code:
/*
    Requests sink to prepare itself for a suspend state
    @return false if sink cannot be suspended
  */
  virtual bool SoftSuspend() {return false;};

  /*
    Notify sink to prepare to resume processing after suspend state
    @return false if sink must be reinitialized
  */
  virtual bool SoftResume() {return false;};

change returns to true - expect issues Wink
System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon  AVR-3808CI  - Denon DVD-5900 Universal Player  - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray  - X-Box 360  - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Frodo seems to be hogging all the audio00