• 1
  • 4
  • 5
  • 6(current)
  • 7
  • 8
  • 77
Release Picture Slideshow Screensaver
#76
(2013-03-06, 19:43)ronie Wrote:
(2013-03-05, 03:14)Robotica Wrote: Aha, it's only the cached lists... Sorry.

Also, (recursive) slideshows always loops. Should this be an option if someone want it to stop after going through all photos once? For the screensaver this makes sense but for individual slideshows, I doubt.
you lost me there... we're discussing a screensaver here, so of course it loops forever :-)
You're confusing the terminology or you miss-interpreet me: this screensaver uses the slideshow and the loop is in the slideshow and not in the screensaver. I think it would be a good idea to have an option to control this loop so you can let the slideshow stop after the last picture is showed. It enables to trigger the user to switch sources for his slideshow.

I know your goal is a 1:1 implementation for the old screensaver. Since you did the work, you might have an opinion about this idea.
Reply
#77
(2013-03-06, 19:50)Robotica Wrote:
(2013-03-06, 19:43)ronie Wrote:
(2013-03-05, 03:14)Robotica Wrote: Aha, it's only the cached lists... Sorry.

Also, (recursive) slideshows always loops. Should this be an option if someone want it to stop after going through all photos once? For the screensaver this makes sense but for individual slideshows, I doubt.
you lost me there... we're discussing a screensaver here, so of course it loops forever :-)
This screensaver uses the slideshow and the loop is in the slideshow and not in the screensaver....
the built-in slideshow screensaver in xbmc eden works that way.

this is the slideshow screensaver addon for xbmc frodo,
it doesn't use the built-in picture slideshow of xbmc.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#78
(2013-02-25, 00:23)ronie Wrote: xbmc kills the screensaver right before it suspends the monitor.
whether this is intended behaviour or not, i don't know.

i'm not sure why xbmc fails to suspend your monitor.
it works fine on my end.

Hmm, you're right, my mistake, I'm able to replicate this with all screensavers, even blank. How odd.
Reply
#79
Thanks Ronie, the slideshow addon works really well for me on my aTV2.

I especially like the additional options incl showing the picture date and music info. Great work.

The only quirk was it fell back to displaying video art until I previewed from the settings screen.

thanks
Paul
AFTV Stick 4K
AFTV (Gen 1)
Reply
#80
Thank you, love it!

BTW, the latest version is not showing up in the the official repo.
HTPC: Dell Optiplex 7050 SFF i7-7700 quad-core, 3.6GHz, 16GB
NAS: Synology DS1813+ and DX513, Hybrid RAID (SHR) 48TB usable space
My Media Center | www.CaptainKen.us | www.YouTube.com/KenInGilbert
Reply
#81
I got this working initially with Frodo and Aeon Nox v4. Now when the screensaver activates the screen goes black except for the file name and picture tags in the lower right corner.

I've tried versions 0.0.9 and 0.1.1. I've also tried the Folder setting with local and NAS folders of pics. Also tried the fanart setting.

Here's the log file.

EDIT:
Here's a cleaner log file.
HTPC: Dell Optiplex 7050 SFF i7-7700 quad-core, 3.6GHz, 16GB
NAS: Synology DS1813+ and DX513, Hybrid RAID (SHR) 48TB usable space
My Media Center | www.CaptainKen.us | www.YouTube.com/KenInGilbert
Reply
#82
if you could post a Debug Log, i'll have a look.

normal logfiles rarel contain any usefull info when it comes troublesooting.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#83
I'm assuming that you wanted me to use these parameters: <loglevel hide="false">2</loglevel>

Here is the new log
HTPC: Dell Optiplex 7050 SFF i7-7700 quad-core, 3.6GHz, 16GB
NAS: Synology DS1813+ and DX513, Hybrid RAID (SHR) 48TB usable space
My Media Center | www.CaptainKen.us | www.YouTube.com/KenInGilbert
Reply
#84
(2013-03-23, 20:09)CaptainKen Wrote: I'm assuming that you wanted me to use these parameters: <loglevel hide="false">2</loglevel>

Here is the new log

not really...
wiki Wrote:If someone asks for a debug log then debugging needs to be enabled. There are three ways to control log output:

GUI Settings

most common method
In Settings -> System -> Debugging toggle the Enable debug logging setting.

whatever you did, it didn't work :-)
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#85
(2013-03-23, 21:02)ronie Wrote:
(2013-03-23, 20:09)CaptainKen Wrote: I'm assuming that you wanted me to use these parameters: <loglevel hide="false">2</loglevel>

Here is the new log

not really...
wiki Wrote:If someone asks for a debug log then debugging needs to be enabled. There are three ways to control log output:

GUI Settings

most common method
In Settings -> System -> Debugging toggle the Enable debug logging setting.

whatever you did, it didn't work :-)

Oops, sorry I thought I had done that part.

Let's try this again.
HTPC: Dell Optiplex 7050 SFF i7-7700 quad-core, 3.6GHz, 16GB
NAS: Synology DS1813+ and DX513, Hybrid RAID (SHR) 48TB usable space
My Media Center | www.CaptainKen.us | www.YouTube.com/KenInGilbert
Reply
#86
(2013-03-23, 21:16)CaptainKen Wrote: Oops, sorry I thought I had done that part.

Let's try this again.

hmm.. i'm not seeing any errors in the logfile.

do you have the same issue if you try the screensaver in confluence?
does your fanart work in the movie library?
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#87
(2013-03-24, 20:20)ronie Wrote:
(2013-03-23, 21:16)CaptainKen Wrote: Oops, sorry I thought I had done that part.

Let's try this again.

hmm.. i'm not seeing any errors in the logfile.

do you have the same issue if you try the screensaver in confluence?
does your fanart work in the movie library?

No, screensaver has same issue as AN in Confluence. Yes, Fanart shows up in Movies.
HTPC: Dell Optiplex 7050 SFF i7-7700 quad-core, 3.6GHz, 16GB
NAS: Synology DS1813+ and DX513, Hybrid RAID (SHR) 48TB usable space
My Media Center | www.CaptainKen.us | www.YouTube.com/KenInGilbert
Reply
#88
(2013-03-24, 21:35)CaptainKen Wrote: No, screensaver has same issue as AN in Confluence. Yes, Fanart shows up in Movies.

'fraid i don't have an answer then.
i've read your log upside-down and back again, but nothing stands out.

the only thing i could recommend is upgrading xbmc to the latest 12.1 release.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#89
Hi ronie,

any chance you can integrate other image plugins as image sources for this add-on?

regards,
sphere
My GitHub. My Add-ons:
Image
Reply
#90
(2013-03-24, 21:51)ronie Wrote:
(2013-03-24, 21:35)CaptainKen Wrote: No, screensaver has same issue as AN in Confluence. Yes, Fanart shows up in Movies.

'fraid i don't have an answer then.
i've read your log upside-down and back again, but nothing stands out.

the only thing i could recommend is upgrading xbmc to the latest 12.1 release.

Thanks for looking into it Ronnie!

I installed v12.1, but no change. The goods news is that this is a test system. My live system is still Eden, but I'm playing around on a test system to get a handle on any issues I run into before switching over to Frodo. I'll try this out on a fresh install of the test system at some point, and try to remember to followup back here.
HTPC: Dell Optiplex 7050 SFF i7-7700 quad-core, 3.6GHz, 16GB
NAS: Synology DS1813+ and DX513, Hybrid RAID (SHR) 48TB usable space
My Media Center | www.CaptainKen.us | www.YouTube.com/KenInGilbert
Reply
  • 1
  • 4
  • 5
  • 6(current)
  • 7
  • 8
  • 77

Logout Mark Read Team Forum Stats Members Help
Picture Slideshow Screensaver4
This forum uses Lukasz Tkacz MyBB addons.