Due to maintenance, our forum will be offline for a short while on Monday June 1st, around 22:00 UTC.

  •   
  • 1
  • 48
  • 49
  • 50
  • 51(current)
  • 52
  •   
  Thread Closed
libstagefright - Experimental hardware video decoding builds
Hi Guys,

Thanks for great work you are doing!

I'm trying to compile the libstagefright release from the sources.
I'm using the Ubuntu 12.04 x32 virtual machine.

I'm getting the error:

Code:
make -C arm-linux-androideabi-android-14
make[3]: Entering directory `/home/developer/libstagefright/xbmc-android/tools/depends/target/pcre/arm-linux-androideabi-android-14'
make[3]: *** No targets specified and no makefile found.  Stop.
make[3]: Leaving directory `/home/developer/libstagefright/xbmc-android/tools/depends/target/pcre/arm-linux-androideabi-android-14'
make[2]: *** [arm-linux-androideabi-android-14/.libs/libpcre.a] Error 2
make[2]: Leaving directory `/home/developer/libstagefright/xbmc-android/tools/depends/target/pcre'
make[1]: *** [pcre] Error 2
make[1]: Leaving directory `/home/developer/libstagefright/xbmc-android/tools/depends/target'
make: *** [target/.installed-arm-linux-androideabi-android-14] Error 2
[email protected]:~/libstagefright/xbmc-android/tools/depends$

Here's the compile instructions I used to build the libstagefright XBMC:
https://docs.google.com/document/d/1fDd3...sp=sharing

Could you please advice on this issue?
does anyone has a working compile instruction?

Thank you!
(2013-07-23, 17:41)jevgenijo Wrote: Hi Guys,

Thanks for great work you are doing!

I'm trying to compile the libstagefright release from the sources.
I'm using the Ubuntu 12.04 x32 virtual machine.

I'm getting the error:

Code:
make -C arm-linux-androideabi-android-14
make[3]: Entering directory `/home/developer/libstagefright/xbmc-android/tools/depends/target/pcre/arm-linux-androideabi-android-14'
make[3]: *** No targets specified and no makefile found.  Stop.
make[3]: Leaving directory `/home/developer/libstagefright/xbmc-android/tools/depends/target/pcre/arm-linux-androideabi-android-14'
make[2]: *** [arm-linux-androideabi-android-14/.libs/libpcre.a] Error 2
make[2]: Leaving directory `/home/developer/libstagefright/xbmc-android/tools/depends/target/pcre'
make[1]: *** [pcre] Error 2
make[1]: Leaving directory `/home/developer/libstagefright/xbmc-android/tools/depends/target'
make: *** [target/.installed-arm-linux-androideabi-android-14] Error 2
[email protected]:~/libstagefright/xbmc-android/tools/depends$

You must follow the instructions in the Readme.Android file, see here https://github.com/xbmc/xbmc/blob/master...ME.android
You are also using the wrong Android NDK, the Crystal NDK was previously used.
Also try to use Java 6 instead of Java 7 as default.
Also try to use 'make' without running it in parallel threads, no '-j10'.
If it doesn't compile correctly, run 'make' again and look at the lines that say error to know which file is causing the error.
You can also read this thread for help http://forum.xbmc.org/showthread.php?tid=167107
Hi Koying,

I trying to use XBMC libstagefright version on my android device.

But XBMC did not playing smoothly.

It drop many frames. (I checked it from codecinfo view)

So I tried other video player using libstagefright (VPlayer,BSPlayer,MX Player), and those are good.

My android device spec.

CPU : CORTEX-A9 1GHz (Dual)
GPU : POWERVR SGX531
Vendor : Entropic
Android version : 4.0.4

xbmc_log : http://xbmclogs.com/show.php?id=39181
The decoding for the build in the OP doesn't work in Android 4.3 on my Nexus 4.
(2013-07-25, 05:01)TouchMyBox Wrote: The decoding for the build in the OP doesn't work in Android 4.3 on my Nexus 4.
Did it work before 4.3? Does xbmc start?
Anyway, that'll have to wait that I get 4.3 on my N7.
Same problem here with Nexus 7 running 4.3.

Everything is working fine except for playback. First I get a colorful striped screen and after a few seconds the screen goes black. The sound playback is fine. When touching the screen the menu is still working. So I guess only the video playback is messed up.

I didn't try xbmc-20130714-6ec63cd-adddroidlibstagefright-armeabi-v7a.apk on Android 4.2.2.

However the previous version (xbmc-20130703-8bc564d-Gotham_alpha5SF-armeabi-v7a.apk) did work on 4.2.2 but also gives the same video playback issue on 4.3. So something changed in Android 4.3 that messed up the video playback.
(2013-07-25, 16:37)TwoZeroOne Wrote: Everything is working fine except for playback. First I get a colorful striped screen and after a few seconds the screen goes black. The sound playback is fine. When touching the screen the menu is still working. So I guess only the video playback is messed up.
Well, good news is that they didn't change the interface Smile
If you could get a logcat and a screenshot, that might already give some clues...
The sound is also messed up, playing a bit too fast and choppy Sad

Screenshot: http://imageshack.us/photo/my-images/855/fmr6.png/
Log: http://xbmclogs.com/show.php?id=39412

EDIT: Just noticed I didn't reinstall the new version. I'm still on 13.0-ALPHA5 Git:20130703-8bc564d. Let me know if you need a logcat of the latest version.
4.3 gives support for open gl es 3.0. Thee might be soms changes..
(2013-07-25, 17:36)TwoZeroOne Wrote: EDIT: Just noticed I didn't reinstall the new version. I'm still on 13.0-ALPHA5 Git:20130703-8bc564d. Let me know if you need a logcat of the latest version.
That would be nice. Also, could you create an actual logcat, not an xbmc log?
Installed xbmc-20130714-6ec63cd-adddroidlibstagefright-armeabi-v7a.apk
Started XBMC
Started movie
Watched 5 seconds
Closed XBMC

http://xbmclogs.com/show.php?id=39612

I reported before the sound was bad, but that was with the old 20130703-8bc564d version. xbmc-20130714-6ec63cd has perfect sound.
(2013-07-25, 08:15)Koying Wrote:
(2013-07-25, 05:01)TouchMyBox Wrote: The decoding for the build in the OP doesn't work in Android 4.3 on my Nexus 4.
Did it work before 4.3? Does xbmc start?
Anyway, that'll have to wait that I get 4.3 on my N7.

Previous builds worked great before upgrading to 4.3. I get sound but no video.
Hi Koying, Man... I have to say it.. excellent work! this thing works better and better with each release

Report.
Device=Tablet 1600x1200 resolution
chip= Rockchip rk3188
OS=android 4.2.2
latest 14 07 release from the OP

first file played SD content, plays perfect, seeks work perfect
second file played 720 content, plays perfect, seeks work well
third file played low bitrate 1080 content, plays very well, no noticeable drops, seeks works well, 2 or 3 seconds till synced
fourth file higher bitrate 720, works well, seeks works well
fifth file SD MPG content, plays perfect, seeks perfect
sixth file played 1080i 12mbps content plays in slow motion with audio gaps to sync a/v, seeks cause 4 to 5 second video with drops till synced and start slow motion again with audio gaps

logfile http://xbmclogs.com/show.php?id=39803

Juanjo
Philips 32PFL6606D
Intel N3150 fanless + 4Gb DDR3 + SSD 64Gb + 3TB+3TB WD RED
Hama MCE remote.
Ubuntu 18.04 minimal install + KODI
(2013-07-26, 16:00)TouchMyBox Wrote:
(2013-07-25, 08:15)Koying Wrote:
(2013-07-25, 05:01)TouchMyBox Wrote: The decoding for the build in the OP doesn't work in Android 4.3 on my Nexus 4.
Did it work before 4.3? Does xbmc start?
Anyway, that'll have to wait that I get 4.3 on my N7.

Previous builds worked great before upgrading to 4.3. I get sound but no video.
Got my N7 to 4.3 and solved the issue (static_cast is evil Wink )
There won't be anymore experimental libstagefright builds, though. It will be merged after the next alpha release, so all android nightlies from August on will have it built in.
Koying,
What did you do please to get jb 4.3 working? As my nexus 10 updated to jb 4.3 and now all I get is sound and a black screen. Any advice will be great
iechyd da
  •   
  • 1
  • 48
  • 49
  • 50
  • 51(current)
  • 52
  •   
  Thread Closed
 
Thread Rating:
  • 10 Vote(s) - 4.5 Average



Logout Mark Read Team Forum Stats Members Help
libstagefright - Experimental hardware video decoding builds4.510
This forum uses Lukasz Tkacz MyBB addons.