•   
  • 1
  • 249
  • 250
  • 251(current)
  • 252
  • 253
  • 315
  •   
  Thread Closed
Release [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
(2014-01-01, 17:30)T-Ricky Wrote: The format of parameter in the setInfo method in ListItem changed. You need to adjust like this:
I changed this strings, but it's not helped.
did you delete the corresponding .pyo files so they get regenarated on execution? (I think this is how it works, on demand compiles)
(2013-03-09, 21:23)evuraan Wrote: how can i "play all" against an youtube search? is this possible?

I've xbmc 12.0, and have enabled "Play next video automatically" per this.

it still does not play the next item from an youtube search. Is this feature not available yet? Please advise? thx..

Feature Request :

(in case this is not yet thought of by the devs. if I should file this elsewhere, please let me know, thanks!)

I was hoping for the capability to play all the videos from your youtube search. Say you search for "Harlem Shake" , and you start playing one from your search result. After that one finishes, it will automatically play the remaining results one after another, if left alone that is. (well, at least play the next 10 of the results?)

Those of you who might have used the youtube app by nowhereman on Roku may know how awesome this feature is. (albeit Roku was later forced by google to remove this private channel - this was the BEST youtube experience I ever had!)

Did anyone get back to you on this? I would like a play all in Subscriptions too...
So as I can't "Play All" videos in a subscription I've mapped a key on my remote to queue them one by one which seems to work however when I reach the bottom of the list and hit queue on "More Results" by mistake (it moves down one however doesn't show the next item) I get a freeze in the plugin where it stays on "Loading" and it seems to get stuck in a loop trying to reload the results. Log here
My next related bug is playing multiple videos in a "Now Playing" playlist and then I get a black screen saying "Loading..." Doesnt work too well this does it Smile Log
Hi Guys,
How to unblock the youtube Geo block?
Thanks
(2014-01-04, 21:52)hassuni Wrote: Hi Guys,
How to unblock the youtube Geo block?
Thanks

Use a VPN
(2014-01-03, 21:04)sebj Wrote: did you delete the corresponding .pyo files so they get regenarated on execution? (I think this is how it works, on demand compiles)
.pyo or .pyc?
P.S. Still the same error: http://fpaste.org/65802/38891979/
For those who cant watch trailers anymore with youtube and get logon error. I found a workaround for this. I tried some of the steps mentioned but didnt work for me.

What I did:

1. Go to the scaper settings by choose configure i videoaddons (I use TheMoviedb scraper for my movies) but other might work also.
2. Uncheck the option to view trailers from youtube
3. Choose view trailer from hd-trailer instead (option below) and choose a preferred resolution (you dont need their addon to use this) Save!
4. Go back to your movie library and go into a movie and choose update and confirm to download info from internet if you have scraped this info locally before. You may loose your downloaded artwork if you have this enabled like "View BR disc" this can be redownloaded at the end
5. after it has updated go in again and try to play the trailer (it should now stream fine, using HD-trailers.net as source instead of YouTube.com)
6. last, redownload any lost artwork if you lost anything (should work fine after that)

NOTE: this has to be done on every movie in your collection Sad for me it wasnt that bad since I had under 10 movies atm.

Tested using Aeon Nox GIT 4.1

Hope this helps someone here whos struggling with trailers not working
Image
(2014-01-01, 17:30)T-Ricky Wrote: The format of parameter in the setInfo method in ListItem changed. You need to adjust like this:

Code:
diff -ur tmp/plugin.video.youtube/YouTubeNavigation.py /home/xbmc/.xbmc/addons/plugin.video.youtube/YouTubeNavigation.py
--- tmp/plugin.video.youtube/YouTubeNavigation.py    2013-07-17 22:12:30.000000000 +0200
+++ /home/xbmc/.xbmc/addons/plugin.video.youtube/YouTubeNavigation.py    2014-01-01 15:31:06.526269052 +0100
@@ -442,7 +442,7 @@

         listitem.setProperty("Video", "true")
         listitem.setProperty("IsPlayable", "true")
-        listitem.setInfo(type='Video', infoLabels=item_params)
+        listitem.setInfo('Video', {'infoLabels': 'item_params'})
         self.xbmcplugin.addDirectoryItem(handle=int(sys.argv[1]), url=url, listitem=listitem, isFolder=False, totalItems=listSize + 1)
         self.common.log("Done", 5)

diff -ur tmp/plugin.video.youtube/YouTubePlayer.py /home/xbmc/.xbmc/addons/plugin.video.youtube/YouTubePlayer.py
--- tmp/plugin.video.youtube/YouTubePlayer.py    2013-07-17 22:12:30.000000000 +0200
+++ /home/xbmc/.xbmc/addons/plugin.video.youtube/YouTubePlayer.py    2014-01-01 15:28:05.206269147 +0100
@@ -86,7 +86,7 @@

         listitem = self.xbmcgui.ListItem(label=video['Title'], iconImage=video['thumbnail'], thumbnailImage=video['thumbnail'], path=video['video_url'])

-        listitem.setInfo(type='Video', infoLabels=video)
+        listitem.setInfo('Video', {'infoLabels': 'video'})

         self.common.log(u"Playing video: " + repr(video['Title']) + " - " + repr(get('videoid')) + " - " + repr(video['video_url']))

diff -ur tmp/plugin.video.youtube/YouTubePlaylistControl.py /home/xbmc/.xbmc/addons/plugin.video.youtube/YouTubePlaylistControl.py
--- tmp/plugin.video.youtube/YouTubePlaylistControl.py    2013-07-17 22:12:30.000000000 +0200
+++ /home/xbmc/.xbmc/addons/plugin.video.youtube/YouTubePlaylistControl.py    2014-01-01 15:34:02.686269018 +0100
@@ -92,7 +92,7 @@
             listitem = self.xbmcgui.ListItem(label=video("Title"), iconImage=video("thumbnail"), thumbnailImage=video("thumbnail"))
             listitem.setProperty('IsPlayable', 'true')
             listitem.setProperty("Video", "true" )
-            listitem.setInfo(type='Video', infoLabels=entry)
+            listitem.setInfo('Video', {'infoLabels': 'entry'})

             playlist.add(video_url % (sys.argv[0], video("videoid") ), listitem)

@@ -132,7 +132,7 @@
             listitem = self.xbmcgui.ListItem(label=video("Title"), iconImage=video("thumbnail"), thumbnailImage=video("thumbnail"))
             listitem.setProperty('IsPlayable', 'true')
             listitem.setProperty("Video", "true" )
-            listitem.setInfo(type='Video', infoLabels=entry)
+            listitem.setInfo('Video', {'infoLabels': 'entry'})

             playlist.add(video_url % (sys.argv[0], video("videoid") ), listitem)


This works! Thank you!!!
@Morphy99

You could use addon youtube quicksearch. This is what i use.

courtesy of AddonScriptorDE http://forum.xbmc.org/showthread.php?tid=171056
I am getting youtube script error on my box. I have installed it from xbmc.org repo . Author is TheCollective . I am not sure where to post but found this youtube thread so hopefully i am right place. Can anyone help please. My kids love to see cartoon on youtube so its very important it does Work. Please help,
Quote:A lot of users have been asking for similar functionality (albeit from within xbmc), so I've also created a patch for XBMC that would allow someone to implement similar behavior by adding a new builtin function "PlayAll(<plugin path>)" (see trac ticket: http://trac.xbmc.org/ticket/10959).

But the horizon for getting this patch accepted and committed to trunk seems to be very long, so we'll probably see if we can't code around it for the next beta.

tl;dr: Auto play of YouTube playlists not possible yet.. Smile

In case you're trying to do something else with playlists please elaborate Smile

Hello all! Please forgive my ignorance as I am new to xbmc and linux in general. My requirement at the moment is to play a specific youtube playlist on bootup.

Im running OpenELEC 3.0.3 with XBMC 12.2 on my Rpi. The reason I haven't updated OpenELEC is due to playback errors when i run the youtube plugin 4.4.6.

The command

xbmc.executebuiltin("XBMC.PlayMedia(plugin://plugin.video.youtube/?action=play_video&videoid=XecLsVXi6oM)")

Works fine to autoplay single videos. Has the above feature been implemented?
(2013-12-27, 04:44)j005u Wrote: The 2 factor login issues seem to have been resolved on Github.

Replace your YouTubeLogin.py with https://github.com/HenrikDK/youtube-xbmc...beLogin.py

YouTubeLogin.py is in folders integrationtests,plugin,unitests.
Should I ovewrite them in all those folders, or only in plugin folders? Should I delete them in other folders?

Thanks in advance for your help,

koze
I always do
Code:
rm ./*.pyc  
rm ./YouTubeLogin.py
wget https://raw.github.com/HenrikDK/youtube-xbmc-plugin/master/plugin/YouTubeLogin.py
this is it easy from the command line, and a do it for every new file in the github.
to get the new version. (i stil use the orginal youtube plugin)
But the VEVO video's does not work any more.

But keep up the good work
  •   
  • 1
  • 249
  • 250
  • 251(current)
  • 252
  • 253
  • 315
  •   
  Thread Closed
 
Thread Rating:
  • 28 Vote(s) - 4.14 Average



Logout Mark Read Team Forum Stats Members Help
[depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only4.1428