•   
  • 1
  • 168
  • 169
  • 170(current)
  • 171
  • 172
  • 244
  •   
  Thread Closed
Linux Radeon OSS with vdpau (howto)
Have one problem with this guide: getting 100% cpu load, extream slow xbmc menu and xbmc is crashing when starting a video.
Got an A4-3400 so cpu should not hit 100. Somehow I guess it has something to do with X not realy using the radeon oss.
Happens with both offical beta ppa and wsnipex ppa - also tested the linux headers from fritsch.

Xorg.0.log: http://paste.ubuntu.com/7274083/

Any idea?
Provide all the logs, the first post wants.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Oh sorry here the missing logs

dmesg
http://paste.ubuntu.com/7274335/
xbmc.log
http://paste.ubuntu.com/7274336/
vdpauinfo
http://paste.ubuntu.com/7274338/
dpkg
http://paste.ubuntu.com/7274346/
You don't have any Audio devices. Did you do the useradd command? Are you member of the audio group? What does id show?

What does aplay -L show?
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
shit, fealing stupid now...
i checked the history, guess the usermod command i copied got swallows by the adduser password promt...

thanks for this realy fast help
Workaround for "I want to boot with my AVR and TV off"

1.) Boot with the TV AVR powered on, make sure everything is working
2.) Copy the currently in use EDID into a file
2a) Find out which device is connected
Code:
for f in /sys/class/drm/card*; do echo $f && cat $f/enabled; done

Sample Output:
Quote:/sys/class/drm/card0-DP-1
disabled
/sys/class/drm/card0-HDMI-A-1
enabled
/sys/class/drm/card0-VGA-1
disabled

2b) copy firmware somewhere, make sure use the correctly connected head (in that case card0-HDMI-A-1)
Code:
sudo mkdir -p /lib/firmware/edid
sudo cp /sys/class/drm/card0-HDMI-A-1/edid /lib/firmware/edid/edid.bin

3) edit /etc/default/grub
and add to the existing GRUB_CMDLINE_LINUX_DEFAULT drm_kms_helper.edid_firmware=HDMI-A-1:edid/edid.bin

Make sure to get the HDMI-A-1 string correct in both the forced enable and the workaround.
Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi='!Windows 2012' drm_kms_helper.edid_firmware=HDMI-A-1:edid/edid.bin video=HDMI-A-1:e"
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
(2014-04-18, 13:30)fritsch Wrote: Workaround for "I want to boot with my AVR and TV off"

1.) Boot with the TV AVR powered on, make sure everything is working
2.) Copy the currently in use EDID into a file
2a) Find out which device is connected
Code:
for f in /sys/class/drm/card*; do echo $f && cat $f/enabled; done

Sample Output:
Quote:/sys/class/drm/card0-DP-1
disabled
/sys/class/drm/card0-HDMI-A-1
enabled
/sys/class/drm/card0-VGA-1
disabled

2b) copy firmware somewhere, make sure use the correctly connected head (in that case card0-HDMI-A-1)
Code:
sudo mkdir -p /lib/firmware/edid
sudo cp /sys/class/drm/card0-HDMI-A-1/edid /lib/firmware/edid/edid.bin

3) edit /etc/default/grub
and add to the existing GRUB_CMDLINE_LINUX_DEFAULT drm_kms_helper.edid_firmware=HDMI-A-1:edid/edid.bin:

Make sure to get the HDMI-A-1 string correct in both the forced enable and the workaround.
Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi='!Windows 2012' drm_kms_helper.edid_firmware=HDMI-A-1:edid/edid.bin video=HDMI-A-1:e"

fritsch thanks for this little tidbit and I was curious if this could help me remove my HDMI Detective Plus from my configuration since I tend to leave the HTPCs on in idle and shut down the surrounding components. On my TV configuration which is merely a samsung into the HTPC I get video after a reboot of the HTPC with the TV off but when I power up the TV to use it I don't get audio. I tried rebooting the system with the TV on and the EDID in place but still get video and no audio. Any help or thoughts here? Logs below:

dmesg:
http://paste.ubuntu.com/7275899/
xbmc.log:
http://paste.ubuntu.com/7275900/
Xorg.0.log:
http://paste.ubuntu.com/7275901/
vdpauinfo:
http://paste.ubuntu.com/7275902/
dpkg w/mesa:
http://paste.ubuntu.com/7275903/
HTPC(s): All running LibreELEC
  • AMD 2200G APU on Gigabyte AB350N-Gaming WIFI-CF
  • RPI3 x2 | RPI2 x2
NAS: FreeNAS (Latest Stable) | NFS/CIFS
Nope. No idea - works for me (with Samsung TV).

Edit: Same issue on my second test system. So handle with care :-)
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Ironically after removing the EDID and keeping the HDMI straight to the HTPC it worked so far after multiple reboots with the TV being off. I am going to play with it for a few days and see what happens.

Ideally it makes the configuration much easier so maybe worth it.
HTPC(s): All running LibreELEC
  • AMD 2200G APU on Gigabyte AB350N-Gaming WIFI-CF
  • RPI3 x2 | RPI2 x2
NAS: FreeNAS (Latest Stable) | NFS/CIFS
(2014-04-18, 11:07)sa1x Wrote: Have one problem with this guide: getting 100% cpu load, extream slow xbmc menu and xbmc is crashing when starting a video.
Got an A4-3400 so cpu should not hit 100. Somehow I guess it has something to do with X not realy using the radeon oss.
Happens with both offical beta ppa and wsnipex ppa - also tested the linux headers from fritsch.

Xorg.0.log: http://paste.ubuntu.com/7274083/

Any idea?

This happened to me when I had no libglamor0, try running
Code:
apt-get install libglamor0=0.6.0-0ubuntu4
and paste the output of
Code:
dpkg -l | grep vdpau
Hello,
my XBMC did run very well with Ubuntu 13.10.
But I upgraded to 14.04 and it doesnt work anymore. I did all the steps of page 1 again.
The xbmc menu ist just lagging as hell and starting a video ist not possible, because xbmc crashes.
Can you please help me to solve this issue? I already delete my .xbmc folder, but this didnt helped. I've full load on both CPU cores triggered by xbmc too :/

dmesg http://paste.ubuntu.com/7283796/
xbmc.log http://paste.ubuntu.com/7283797/
Xorg.0.log http://paste.ubuntu.com/7283798/
vdpauinfo http://paste.ubuntu.com/7283805/
dpkg http://paste.ubuntu.com/7283808/
and additional xbmc_crashlog http://paste.ubuntu.com/7283813/

Thank you!
sudo apt-get install xserver-xorg-video-ati

you did not purge wsnipex mesa prior to upgrading

sudo ppa-purge ppa:wsnipex/mesa

then reinstall this ppa to upgrade.

Currently you are missing a correct gpu driver.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
ppa-purge won't work after release-upgrade, as ppas get automatically disabled.

try this:
dpkg -l | grep saucy

then uninstall any mesa related libs from the output above, then add my mesa ppa and install those libs again
Aww thank you. Fritschs hint was enough Smile My XBMC is up and running again, thank you Smile
My cpu usage went down from 10-15% to 3-5% when I went from saucy to trusty. Why?
  •   
  • 1
  • 168
  • 169
  • 170(current)
  • 171
  • 172
  • 244
  •   
  Thread Closed
 
Thread Rating:
  • 26 Vote(s) - 4.58 Average



Logout Mark Read Team Forum Stats Members Help
Radeon OSS with vdpau (howto)4.5826