Openelec: Music drops with some HD multichannel
#1
Hi,

I am back every few weeks with the same issue:
When I play HD (24/96, 24/88.2) multichannel music, I have drops with some files.
Last time I was told to overclock RPi. Now I run with:

Code:
Firmware Version
Jul  5 2014 19:03:42
Copyright (c) 2012 Broadcom
version cb433d55f9f5b29b59968019e3b54802894af489 (clean) (release)

temp=65.9'C

arm:     frequency(45)=1000000000
core:     frequency(1)=500000000
h264:     frequency(28)=250000000
isp:     frequency(42)=250000000
v3d:     frequency(43)=250000000
uart:     frequency(22)=3000000
pwm:     frequency(25)=0
emmc:     frequency(47)=250000000
pixel:     frequency(29)=146250000
vec:     frequency(10)=0
hdmi:     frequency(9)=163682000
dpi:     frequency(4)=0
core:     volt=1.35V
sdram_c: volt=1.20V
sdram_i: volt=1.20V
sdram_p: volt=1.23V
H264=enabled
MPG2=disabled
WVC1=disabled
MPG4=enabled
MJPG=enabled
WMV9=disabled

Config info
config is unknown
arm_freq=1000
core_freq=500
sdram_freq=500
over_voltage=6
hdmi_force_hotplug=1
disable_overscan=1
program_serial_random=1
config_hdmi_boost=2
emmc_pll_core=1
hdmi_ignore_cec_init=1
hdmi_force_cec_address=65535
hdmi_edid_file=1
temp_limit=85
force_pwm_open=1
pause_burst_frames=1
avoid_fix_ts=1

Memory split
arm=384M
gpu=128M

13:24:24 up 29 min,  load average: 0.97, 0.75, 0.64

I use passthrough on.

Files with 2 channels are good even with 24/192.
Some files 24/96 are good other not, I can't find why.
With some files that drop, CPU usage with ssh (top), is around 65%. This is not a CPU speed issue.

I noticed something strange (for me): When I enable debug logging, there are less drops than without! (ie: 1 drop every second without, 1 drop only at the end of the file with it)

xbmc.log:
http://sprunge.us/GceU

So hopfully, you will find the issue in this thread.
If you need more info, just let me know.

BTW, if you find improvement to be done is the log file, let me know
- 12:56:06 T:3058360320 DEBUG: FactoryCodec - Audio: passthrough - Failed
- CecLogMessage

Many thanks

Edit: I only use Openelec to listen music, no video, no TV only a monitor
Config, audio player only:
2T HDD <USB> RPi2/Kodi <HDMI> Denon AVR-2313 <HDMI> LG TV 55UF860V
Reply
#2
Can you try with Helix build (e.g. latest Milhouse).
Flac is now decoded with ffmpeg rather than external lib.
Disable visualisation (on Helix that will skip a downmix/resample stage).

If enabling logging makes it better, then that is interesting (although can't think of a reason for that yet).
Reply
#3
I did some new tests:

Version 4.07 stable (same as previous post)
With
Paplayer (default): drops
DVDplayer: drops
OMXplayer: OK, NO drop

Version OpenELEC-RPi.arm-Milhouse-20140913233905-r19230-g9ab2c87
same settings as version 4.07
with
Paplayer (default): drops
DVDplayer: OK, NO drop
there is no OMXplayer in this version

I could use DVDplayer as default, is it a good choice?
Config, audio player only:
2T HDD <USB> RPi2/Kodi <HDMI> Denon AVR-2313 <HDMI> LG TV 55UF860V
Reply
#4
Version OpenELEC-RPi.arm-Milhouse-20140913233905-r19230-g9ab2c87
same settings as version 4.07

I just noticed that with DVDplayer, Kodi downrate to 44.1 kHz instead of keeping 96 kHz, this lead to get no drop.

This is not at all a good choice, I want to keep the original sampling frequency.
Config, audio player only:
2T HDD <USB> RPi2/Kodi <HDMI> Denon AVR-2313 <HDMI> LG TV 55UF860V
Reply
#5
(2014-09-19, 16:06)MrNice Wrote: I just noticed that with DVDplayer, Kodi downrate to 44.1 kHz instead of keeping 96 kHz, this lead to get no drop.

See: http://wiki.xbmc.org/index.php?title=Audio_settings

I don't believe 44.1kHz is forced.
If Output configuration is "best match" then you always get the source sample rate (but you lose gapless when it changes)
If Output configuration is "optimised" then you get the source sample rate for any new file. If several tracks are queued then they will all use the settings from first one.
Reply
#6
Config was "Best Match" so I should have 96 and not 44.1 !
I didn't play gapless for this test.

I changed to "Optimized"
I tried again one file at 5.1, 24/96. My AVR can show file sample rate:
with Paplayer > 96 > drops
DVDplayer > 44.1 > no drop

I changed to "fixed" at 96
I tried again 2L file at 5.1, 24/96. My AVR can show file sample rate:
with Paplayer > 96 > drops
DVDplayer > 96 > drops

Looks like there is an issue with DVDplayer and output configuration "best match" and "optimized"
and another issue with the both players that drop.
Config, audio player only:
2T HDD <USB> RPi2/Kodi <HDMI> Denon AVR-2313 <HDMI> LG TV 55UF860V
Reply
#7
Something that could help:
Playing a file 5.2, 24/96 with DVDplayer

System > Settings > Audio output > output configuration = Fixed
Limit sampling rate = 44.1
then back to
System > Settings > Audio output > output configuration = Best match or Optimized
When playing, sample rate is 44.1

System > Settings > Audio output > output configuration = Fixed
Limit sampling rate = 88.2
then back to
System > Settings > Audio output > output configuration = Best match or Optimized
When playing, sample rate is 88,2
Config, audio player only:
2T HDD <USB> RPi2/Kodi <HDMI> Denon AVR-2313 <HDMI> LG TV 55UF860V
Reply
#8
@popcornmix

Any news?
Do you need more info, tests?
Config, audio player only:
2T HDD <USB> RPi2/Kodi <HDMI> Denon AVR-2313 <HDMI> LG TV 55UF860V
Reply
#9
New OpenELEC Helix build: #1003

Unfortunately, I still have drops with the HD file.

Thanks for your helps and advices
Config, audio player only:
2T HDD <USB> RPi2/Kodi <HDMI> Denon AVR-2313 <HDMI> LG TV 55UF860V
Reply
#10
(2014-09-15, 15:19)popcornmix Wrote: ...
If enabling logging makes it better, then that is interesting (although can't think of a reason for that yet).

OpenELEC Helix build: #1005
I can confirm:
I played 2 mn of the same HD audio file with log disabled then with log enabled, that 6 times:
- Without log I get a drop at average of 1.5 second, so around 80 drops for 2 mn
- With log I get 0 to 6 drops within the first 15 seconds then not drop for 2 mn

The log:
2 starts of the same HD audio file, the first start has no drop, the second start has 5 or 6 drops.
http://sprunge.us/RhiE
Config, audio player only:
2T HDD <USB> RPi2/Kodi <HDMI> Denon AVR-2313 <HDMI> LG TV 55UF860V
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Openelec: Music drops with some HD multichannel00
This forum uses Lukasz Tkacz MyBB addons.