•   
  • 1
  • 48
  • 49
  • 50(current)
  • 51
  • 52
  • 55
  •   
Win Yatse 2 : Open Source Media Center Remote Control App for Touch Screen
Here you go, I hope it helps you find out what's wrong...

Yatse2.log

(2015-07-02, 05:11)GlennNZ Wrote:
(2015-07-02, 04:54)MKANET Wrote: Reverting back to the old Yatse2 makes music fanart work again using the same settings in my XML config file. Kodi on my setup hasn't changed (plugin/addon-wise).

I agree, it DOES depend on my Kodi setup. However, nothing really changed there to change music fanart behavior (at least nothing obvious). It still displays the same in Kodi for the same albums and songs as before.

So, I also need to install the yatse2.service just to get music fanart to display in PlayNow? Any way to just get it to work more like before (without the need for depending on the service).

EDIT: This happens on ALL music... not just local music files; but, streaming too (like the Google Music addon).

PS: If you still need a log file, what do I need to do exactly to get you the information you need?

Log file - enable debug and trace in settings screen. Restart Yatse, log located in %appdata%\Yatse 3 Socket\Logs. Copy and paste log to pastebin.com and paste link.

re: Yatse2.service - shouldn't need to have service installed for music fanart - but may be how it is coded currently. Will check and update if easy fix (which should be) - But do need log to have a look at paths which is probably where the problem lies.

Glenn
Reply
Ok re: log:

1st of:

Does correctly work without the service running, off or not installed.

You have no default audio/music fanart images (Directory set in the xml file)
In your case currently looking in the below directory and finding nothing:
C:\Users\MKANET\AppData\Roaming\Kodi\userdata\addon_data\script.artworkorganizer\ArtistFanart\

Some Points
- Likely not to work with streaming files - there are a few streaming examples here from google.

- For the artist fanart sideshow to show - need to have the current playing info screen off for audio files

- There is some issue here with Yatse not having the fanart from the kodi webserver - this is likely while the nowplaying screen is not showing fanart.
Also same issue on mine.
(I believe it relates to the database and files - art embeded within the mp3 is shown in Kodi, but not sent as fanart via the JSON which is relied upon)

- I would turn off musicfanart rotation - this just rotates the cached music fanart images and is unrelated to the file being played back.

'Old versions' versus new - ? What are you referring to?
Have gone all the way back through versions and there is no change in this behaviour that I can see between all the versions of Yatse.

I believe the difference between versions relates to Yatse Database being refreshed or not and/or the information being in kodi.

The nowplaying info screen gets its fanart from the yatse database, my additions to fanart from an extrafanart directory bypass this.
On the newer version - refresh database is not enabled by default, slow, can cause issues on big database - as basically I wasn't using it.
If you change this setting, refresh your database, and then disable refresh on connection (until changes)
I believe will return to the same as the 'old version'



But you are right - have had a look at the Music NowPlaying screen and often wouldn't show anything.


Seems to be because kodi database doesn't include any information in the fanart tags - have checked with direct check of Json.

You to can try run in a web browser : (with the 8181 port changed to your kodi webserver port)

Code:
http://127.0.0.1:8181/jsonrpc?request={"jsonrpc": "2.0", "method": "Player.GetItem", "params": { "properties": ["title", "album", "artist", "duration", "thumbnail", "file", "fanart", "streamdetails"], "playerid": 0 }, "id": "AudioGetItem"}

This basically queries kodi json for details of currently playing file - need to have a file playing. On most of my files the fanart == attribute is empty. This is were the artwork/backdrop comes from.
It appears that Kodi - doesnt have this data.
I presume the images seen in Kodi come from the mp3 itself (embeded) or the folder.jpg arts. Neither of these seem to be parsed via Json.

When I check my database - most of the fanart tags are incorrect/or point to some server route that doesnt exist. CdARtManager is running now updating...


To bypass this:
I have upload build 130 to try - this uses MusicSource/artist/extrafanart directory to get fanart slideshow for the now playing/currently info screen playing artist. (IF it is blank/non-existent)
Doesn't use Yatse database.

The artist/extrafanart directory - needs to exisit - but use cdArtManager - use the updated zip version as in the forum posts.
https://github.com/stefansielaff/script....tree/Helix. Use this to download, update artist info/extrafanart and the above build should work.


Glenn
Reply
(2015-07-02, 06:04)GlennNZ Wrote: You have no default audio/music fanart images (Directory set in the xml file)
In your case currently looking in the below directory and finding nothing:
C:\Users\MKANET\AppData\Roaming\Kodi\userdata\addon_data\script.artworkorganizer\ArtistFanart\
- I would turn off musicfanart rotation - this just rotates the cached music fanart images and is unrelated to the file being played back.

MKANET -
This is very similar to the issue that I had with Yatse not recognising the fanart, even though it could be seen in Kodi.
(I might be wrong on this but it almost that Yatse creates it's own folder of the same fanart and then connects to that rather that rather than the Kodi fanart folder)
Anyhow, what I did was basically refresh the audio / visual libraries within Kodi and then reconnect to Yatse and then it 'downloaded' the fanart.

Hope this helps and doesn't lead you down a blind alley!
bb69
Reply
Glenn, I just tried build 130. Now, it restores the old behavior (which isn't right either). Currently, Yatse is stuck cycling through old fanart during PlayNow (however, in Kodi, the fanart there is all correct during music playback).

So, how can I correctly use the fanart that Kodi uses in Yatse? I checked cdART addon, I don't think that addon even works.. I already have the latest version. The fanart folder I assigned it is completely empty. So, I"m not sure where Kodi get's it's fanart from, whatever it is, it seems to work correctly.
Reply
(2015-07-02, 06:04)GlennNZ Wrote: Ok re: log:

You have no default audio/music fanart images (Directory set in the xml file)
In your case currently looking in the below directory and finding nothing:
C:\Users\MKANET\AppData\Roaming\Kodi\userdata\addon_data\script.artworkorganizer\ArtistFanart\
Have you fixed the above?

As I mentioned in the long reply above - we reply on Kodi giving us the fanart file/location via JSON; and this solely depends on the database. Not embedded in mp3, not folder.jpgs etc - if not in the Db yatse wont get it.

If you play a file on Kodi and then in a webbrowser copy and paste the previous Json 127.0.0.1 - request it will list whether you have fanart setup for the file you are playing.

Build 130 - checks for this fanart from Json, but if not there also checks for MusicSource/Artist/extrafanart - files. For this to work you need to have a Artist directory in your Music source and have extrafanart within it.
CDArtManager does work - I'm running in on 15.beta2. You uninstall the repo version, download the zip and install from zip file as per the link I attached to.
1893252 (post)

As per CDArtManager forum - download the below zip (after deleting old version) and install via zip file below.
https://github.com/stefansielaff/script....tree/Helix

Will likely redo nowplaying Audio Currently screen/code shortly - along these lines
- check for fanart from JSON if none there/absence
- check for Artist Fanart from MusicSource\Artistname\extrafanart (default fanart from CDArtManager)
- check for Album fanart from Json - if blank
- check local path file for albumart.jpg? or something similar - will check best default
(But regardless will not show anything unless fanart json set, or extrafanart artist directory exists)

Build 140:
Added - usual place.
Uses cdart.png (downloaded per album by CDartManager (which does work!) - for local albums only
&
Uses Kodi source.xml for Music root. Checks music root for artistname\extrafanart artwork - and uses this regardless of sourcefile.
ie. works with googleplay streaming kodi addon for NowPlaying Info screen artisit backdrops
NB::!!! Need the artist directory\extrafanart in music root to work. CdArtManager does download as above
eg.
G:\Music == Music root as defined in sources.xml
G\Music\Ed Sheeran\extrafanart\
G:\Music\Pink Floyd\extrafanart\
etc - these directories and files if exist - will use this for backdrop


Example - see Cdart used (checks album directory for cdart.png file)
Image
&
Image

Glenn
Reply
Glenn, I wasn't able to fix this. I already have the latest zip install of the cdART script (from the link you sent me early on). It looks like cdART isn't able to even startup. Below is the Kodi log when I manually try to start the script via Kodi Addons menu. As soon as I have a fanart folder (that isn't empty), I'll be able to have Yatse's

BTW: When I playback Google Music streaming songs, I see all possible fanart for each artist and album (background wallpapers, etc) during music playback in Kodi's screensaver. Not sure where all those images are stored; but, they definitely more than a single single default.jpg for each streaming song.

EDIT: I just tried BUILD 140..It still cycles through old fanart no matter what song I play... even when getting SEVERAL fanart background images per song on Kodi.

EDIT: It looks like <MinimiseAlways>true</MinimiseAlways> is ignored now (Yatse starts up fully visible; and, stays that way). It's been doing this for a couple of builds now.

PS: I disabled music fanart rotation... I'm still seeing incorrect images being cycled during music playback with build 140... probably due to the Yatse's music directory is pointing to a non-existent directory, Anyway below, is my cdART log file, if you see anything wrong with it...

cdART log
Reply
(2015-07-03, 19:02)MKANET Wrote: Glenn, I wasn't able to fix this. I already have the latest zip install of the cdART script (from the link you sent me early on). It looks like cdART isn't able to even startup. Below is the Kodi log when I manually try to start the script via Kodi Addons menu. As soon as I have a fanart folder (that isn't empty), I'll be able to have Yatse's

BTW: When I playback Google Music streaming songs, I see all possible fanart for each artist and album (background wallpapers, etc) during music playback in Kodi's screensaver. Not sure where all those images are stored; but, they definitely more than a single single default.jpg for each streaming song.

EDIT: I just tried BUILD 140..It still cycles through old fanart no matter what song I play... even when getting SEVERAL fanart background images per song on Kodi.

EDIT: It looks like <MinimiseAlways>true</MinimiseAlways> is ignored now (Yatse starts up fully visible; and, stays that way). It's been doing this for a couple of builds now.

PS: I disabled music fanart rotation... I'm still seeing incorrect images being cycled during music playback with build 140... probably due to the Yatse's music directory is pointing to a non-existent directory, Anyway below, is my cdART log file, if you see anything wrong with it...

cdART log
It's still running the old version (non zip) cd art manager
Need to delete both versions - NB delete
And reinstall the zipped version, build thE cdartmanager database and try again
Reply
I only see one directory for cdart under addons. I already completely removed and replaced it with the latest zip from github (same as the link you provided). I also tried removing the add-on via Kodi Add-on manager, then restart Kodi, then installed the zip file via Kodi. Is cdART repository version called something else than cdART? I only see one add-on.
Reply
There is the addon folder but also addon_data folder need to delete everything

Have a look at the paths in the log - make sure these are all deleted and then rein slowed from zip file
Reply
(2015-07-03, 19:02)MKANET Wrote: Glenn, I wasn't able to fix this.
The inital post refers to your images directory having no images! I cant fix that.

Quote:BTW: When I playback Google Music streaming songs, I see all possible fanart for each artist and album (background wallpapers, etc) during music playback in Kodi's screensaver. Not sure where all those images are stored; but, they definitely more than a single single default.jpg for each streaming song.

As I have repeatedly said - those images are downloaded by kodi and various addons seperately. Yatse cannot access them - sure we could make yatse download its own fanart images from somewhere - however that would take time and not suit the purposes of a nowplaying screen. It doesn't matter what Kodi is showing if that is not shared (which it isnt)
Quote:EDIT: I just tried BUILD 140..It still cycles through old fanart no matter what song I play... even when getting SEVERAL fanart background images per song on Kodi.
As above - Yatse is completely seperate to Kodi. It doesn't matter what Kodi is showing. Kodi has various skin addons to download and show a whole pile of stuff - that doesnt mean than Yatse can access it.
Quote:EDIT: It looks like <MinimiseAlways>true</MinimiseAlways> is ignored now (Yatse starts up fully visible; and, stays that way). It's been doing this for a couple of builds now.
Not on my testing - MinimiseAlways behaviour (At least on build 140) works as expected - always minimise unless nowplaying occuring)
What are you seeing ? Post a Yatse log.
Quote:PS: I disabled music fanart rotation... I'm still seeing incorrect images being cycled during music playback with build 140... probably due to the Yatse's music directory is pointing to a non-existent directory, Anyway below, is my cdART log file, if you see anything wrong with it...
Yes - Music fanart rotation needs to be disabled. This just plays random fanart from yatse cache directory. I don't see the point of it - but have left it there. To use the extrafanart directories and the like need this off.
BUT these images need to exist! (I can't fix that)

Quote:cdARt Not Working

Need to delete ALL the folders (your log shows quite clearly the paths)
This folder needs to be deleted - there is an old database in here crashing

C:\Users\MKANET\AppData\Roaming\Kodi\userdata\addon_data\script.cdartmanager
&
C:\Users\MKANET\AppData\Roaming\Kodi\userdata\addons\script.cdartmanager
&
C:\Users\MKANET\AppData\Roaming\Kodi\userdata\addons\script.cdartmanager-Helix

and then reinstall via zip file as link
Reply
It appears that the cdART addon isn't automatic in the background. I don't really see myself manually running the cdart script; especially with the volume of new songs I listen to via Google Music. I did notice you posted a question about fanart handling of Google Music in the forum... thank you. Maybe they might update it to include fanart tags that can be accessed via http json queries.

PS: Alwaysminimize functionality itself works.. However, when I start Yatse. it doesn't start minimized anymore. I have to manually double-click the system tray icon every time after it launches; or, it just sits fullscreen on my 7" LCD after startup. This seemed to start happening a couple of builds ago.

(2015-07-04, 03:58)GlennNZ Wrote:
(2015-07-03, 19:02)MKANET Wrote: Glenn, I wasn't able to fix this.
The inital post refers to your images directory having no images! I cant fix that.

Quote:BTW: When I playback Google Music streaming songs, I see all possible fanart for each artist and album (background wallpapers, etc) during music playback in Kodi's screensaver. Not sure where all those images are stored; but, they definitely more than a single single default.jpg for each streaming song.

As I have repeatedly said - those images are downloaded by kodi and various addons seperately. Yatse cannot access them - sure we could make yatse download its own fanart images from somewhere - however that would take time and not suit the purposes of a nowplaying screen. It doesn't matter what Kodi is showing if that is not shared (which it isnt)
Quote:EDIT: I just tried BUILD 140..It still cycles through old fanart no matter what song I play... even when getting SEVERAL fanart background images per song on Kodi.
As above - Yatse is completely seperate to Kodi. It doesn't matter what Kodi is showing. Kodi has various skin addons to download and show a whole pile of stuff - that doesnt mean than Yatse can access it.
Quote:EDIT: It looks like <MinimiseAlways>true</MinimiseAlways> is ignored now (Yatse starts up fully visible; and, stays that way). It's been doing this for a couple of builds now.
Not on my testing - MinimiseAlways behaviour (At least on build 140) works as expected - always minimise unless nowplaying occuring)
What are you seeing ? Post a Yatse log.
Quote:PS: I disabled music fanart rotation... I'm still seeing incorrect images being cycled during music playback with build 140... probably due to the Yatse's music directory is pointing to a non-existent directory, Anyway below, is my cdART log file, if you see anything wrong with it...
Yes - Music fanart rotation needs to be disabled. This just plays random fanart from yatse cache directory. I don't see the point of it - but have left it there. To use the extrafanart directories and the like need this off.
BUT these images need to exist! (I can't fix that)

Quote:cdARt Not Working

Need to delete ALL the folders (your log shows quite clearly the paths)
This folder needs to be deleted - there is an old database in here crashing

C:\Users\MKANET\AppData\Roaming\Kodi\userdata\addon_data\script.cdartmanager
&
C:\Users\MKANET\AppData\Roaming\Kodi\userdata\addons\script.cdartmanager
&
C:\Users\MKANET\AppData\Roaming\Kodi\userdata\addons\script.cdartmanager-Helix

and then reinstall via zip file as link
Reply
Re: MiniseAlways

As I said does appear to be working and will check again. All double clicking the Taskbar does is set or unset the minimisealways to true/false.
I would guess that there is some error or typo in the xml file - or you are using the wrong one - it's located at %appdata% Yatse 3 Socket. (Not in the running directory)
A log includes all this info through
Reply
Glenn, I didn't realize the XML settings file had moved. I deleted the old XML file; and, enabled Always Minimize via the new Yatae GUI menu option. Now, its doing it correctly! Thanks for the tip!
Reply
Hello,

I would like ask you, is it planned to integrated "run another addon's"?

I use yatse for android and control the radion addon in the kitchen,
and I would do the same from my notebook too.
Reply
Thanks GlennNZ, it's working really great.

Is there a way to implement pvr into yatse? And is there a theme with bigger fonts?
Reply
  •   
  • 1
  • 48
  • 49
  • 50(current)
  • 51
  • 52
  • 55
  •   
 
Thread Rating:
  • 5 Vote(s) - 4 Average



Logout Mark Read Team Forum Stats Members Help
Yatse 2 : Open Source Media Center Remote Control App for Touch Screen45
This forum uses Lukasz Tkacz MyBB addons.