•   
  • 1
  • 22
  • 23
  • 24(current)
  • 25
  • 26
  • 168
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)
(2015-07-31, 06:45)illiac4 Wrote: Ok this revert seems to fix the problem but....

Lets assume that I have overclock enabled with the following settings
Code:
# mode 'Turbo'                  :   1000   |    500    |    500     |      6
arm_freq=1000
core_freq=500
sdram_freq=500
over_voltage=6
# set to 'force_turbo=1' to disable dynamic overclocking (you can lose your warranty!)
  force_turbo=0

In this case I will still get Gui freezes like Milhouse did with my sample video since dynamic overclocking is enabled and in case it will speedup the CPU to turbo speed it will freeze the gui.
Don't bother oc sdram it will probably cause stability issues.
2053366 (post)

Also over voltage only needs to be at 2 and with turbo 3-4 at most.
I am not talking about overclocking in general but I am saying that if parameter force_turbo=0 is selected and some overclock (in my case turbo) enabled the stream will freeze after some time.
Since popcornmix has disabled the turbo mode in last commit the users who have force_turbo=1 (like milhouse) will not face the problem with the freezed gui but the one with force_turbo=0 will.
I still get the frozen GUI when playing the sample file, even with the latest #0730 build, but I don't experience crashes (of Kodi, or the Pi).

Was the firmware revert meant to fix crashes, or the GUI freeze? I thought it might be fixing only crashes by not switching from non-turbo to turbo (those already forcing turbo would never see this problem).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Please do not know why I'm not in the OSD menu when playing video info button. I have openelec kodi 15 rpi2.Moc thank you for your answer and for a great motive.
(2015-07-31, 15:54)Milhouse Wrote: I still get the frozen GUI when playing the sample file, even with the latest #0730 build, but I don't experience crashes (of Kodi, or the Pi).

Was the firmware revert meant to fix crashes, or the GUI freeze? I thought it might be fixing only crashes by not switching from non-turbo to turbo (those already forcing turbo would never see this problem).

Firmware fix was for turbo related gpu crash. The frozen gui is something else.
Do you get it with omxplayer enabled/disabled? Do you get it with "sync playback to display" enabled/disabled?
(2015-07-31, 16:07)popcornmix Wrote: Do you get it with omxplayer enabled/disabled? Do you get it with "sync playback to display" enabled/disabled?

Freeze in all cases - with/without omxplayer, with/without sync playback (whether Adjust PLL or Resample Audio).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-07-31, 16:49)Milhouse Wrote: Freeze in all cases - with/without omxplayer, with/without sync playback (whether Adjust PLL or Resample Audio).

I'm struggling to reproduce this. You are using MTV-Dance1.ts? Is the freeze permanent or does stop/seek work?
Yes, MTV-Dance1.ts (over smb://). The freeze is permanent, requiring a reboot. It usually takes a couple of runs though the video before a freeze occurs. Will try a "clean" .kodi with default settings.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I assume that it is possible that it has something to do with deinterlacer. Will try to disable it and will see if it happens.
It does seem to be harder to provoke with all default settings (but Auto/MMAL-Advanced configured as deinterlacer). Maybe a conflict with another setting?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-07-31, 18:06)Milhouse Wrote: It does seem to be harder to provoke with all default settings (but Auto/MMAL-Advanced configured as deinterlacer). Maybe a conflict with another setting?

Quite possible. If you can identify the setting that makes it hang more reliably that would be useful. I've played it about 20 times without a hang....
From my remembering those freezes accrued a few weeks or. even month before so it could be interlaced connected. I am running it now with deinterlaced disabled and till now no freeze. But as i said it is totally random but certain and hard to track. Killa sample this video fileSmile
I can paste guisetings.xml and config.txt if it helps.
At first i thought that it is cpu guvernor connected when it turns on ti higher frequency but then Milhouse would not be affected.
Got bored of twiddling random settings, so copied in my old guisettings.xml to the "clean" .kodi and managed to provoke a freeze on the second play. These settings are here, if you want to try them yourself: http://sprunge.us/aaeS

Now that it appears to be due to another setting, I'll revert back to the default settings and continue my twiddling.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Do you get the freeze if you disable deinterlacer?
Mine is (ATM deinterlacing is disabled in this config):
http://pastebin.com/f4Fxw2Qc
interesting...can't wait to see the results
  •   
  • 1
  • 22
  • 23
  • 24(current)
  • 25
  • 26
  • 168
  •   
  Thread Closed
 
Thread Rating:
  • 10 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)510