•   
  • 1
  • 112
  • 113
  • 114(current)
  • 115
  • 116
  • 509
  •   
Kodi DSPlayer – DirectShow Player for Windows
(2015-10-05, 22:01)Warner306 Wrote:
(2015-10-05, 07:37)Knight77 Wrote: I'll post a screenshot ASAP anyway with MPC-HC doesn't happen: with that it shows clearly exclusive fullscreen.

UPDATE: here is the screenshot
...

I can't see anything unusual. Someone else may have to chime in. Using windowed mode is completely acceptable if you are outputting at 8-bits. You won't miss any extra features. Still, a solution should be available.

What kind of GPU are you using?

Nvidia GTX960, but count that if I use another player (ex. MPC-HC) I get fullscreen exclusive....
Reply
(2015-10-05, 22:09)Knight77 Wrote:
Knight77 Wrote:I think I've got a little problem: I followed the instructions and installed everything as described but, even if I selected "fullscreen exclusive mode" in the DSPlayer settings and in madvr itself, if I play a video and check with ctrl+J I see "D3D windowed"...... Is it normal? Should it be fullscreen exclusive? How can I fix this? I tried everything :-(

Here is the log.

( http://pastebin.com/RZ5yRrQx )

Started Kodi, turned debug on, started an episode of serial (MrRobot) let some time pass and stopped it, then exit Kodi.

ok you should try some different setup to find out where is the problem

- use Kodi DSPlayer with a fresh new userdata folder without any addons (or just launching kodi.exe with the portable switch "-p")
- use madVR in dx9
- manage resolution change only in madVR in display mode
- try without any resolution change
Reply
(2015-10-05, 19:05)SoundsGreat Wrote: Hi,

Following up with my earlier post,I have updated to the Oct4 Build and also did some tinkering with the drivers and what not.

Anyways Now Am able to play videos to some extent properly,not half as bad as the older post or not half as good as it used to be ! But somewhere inbetween which I can live with.

My main question now is,

1. Am on Win8.1 with DX11.1 and Am not able to install DX11.2 via windows update,How does one do that.
2. Although I have DX11.1 and have enabled exclusive mode Am not seeing the same on stats (had to disable exclusive to take screen shot),It shows D3D9 which means its using DX9 and not 11. How do I get it use DX11 ?? Perhaps that's why Am not able to get proper playback !

https://drive.google.com/file/d/0B_mUe2A...o2QjA/view

https://drive.google.com/file/d/0B_mUe2A...dqZFE/view


Please let me know what Am I missing ?

Regards.

D3D11 is used for presentation in madVR and this must be set from the madVR control panel under general settings. If you are not outputting at 10-bits, the result may be the same (although, entering and exiting fullscreen exclusive mode can be faster).
Reply
Can someone help me, i hooked my tv up through an dvi-hdmi cord but i can't seem to get audio when playing videos in dsplayer kodi

in regular kodi it works fine, i'm using directshow merits with LAV on DSPlayer.

i can also get the audio to play to it in mpc and i can hear the GUI sounds.
Reply
(2015-10-05, 12:00)aracnoz Wrote: @weirdinin

there are two "official" versions from the Kodi team (or better there are two versions without DSPlayer) the one that you can download from kodi.tv and then another one developed by afedchin that uses dx11 instead of dx9 that you can find here 218274 (thread), DSPlayer it's only in DX11 since by Kodi 16 there will be only the dx11 version

so you have to compare DSPlayer with that version and if you still have problems with DVDPlayer and Main Menus without any playback in background with the "official dx11" build you should report there to afedchin

Ok. Thank you. Artifacts also appear with afedchin's version when using full screen window. I'm going to report there.
Current setup
HTPC: G4560 Kaby Lake, ASRock H110M-ITX, 8 GB, Win10
Server: G2120 Ivy Bridge, ASRock B75 Pro3-M, 8 GB, 22 TB HDD, Ubuntu 16.04.5 LTS
Audio&Visual: Marantz NR-1602, Dali Opticon 6 5.1, SVS PB12-NSD, Sony KD-65A1
Reply
(2015-10-06, 03:21)Shogunreaper Wrote: Can someone help me, i hooked my tv up through an dvi-hdmi cord but i can't seem to get audio when playing videos in dsplayer kodi

in regular kodi it works fine, i'm using directshow merits with LAV on DSPlayer.

i can also get the audio to play to it in mpc and i can hear the GUI sounds.

Have you tried ReClock and set PCM and bitstream to WASAPI Exclusive?
Reply
(2015-10-05, 17:11)aracnoz Wrote: there is a strange behavior with internal subtitles, in my case the problem come with madVR 0.89.6

with madVR 0.89.5 seems ok

can you pls try?

Using madVR 089.5 does not solve my subtitle problem, I think I am experiencing a different issue to others however as I have since noticed my issue only happens when streaming.

If am playing locally stored content with an external subtitle file (srt) in the same directory, subtitles work.

If am playing locally stored content with no external subtitle in the same directory, I can use the download option, an external subtitle is downloaded and works. The subtitle file is stored in the same directory as the content playing .

If am playing an external stream and I use the subtitle download option subtitles do not work. I can however see the subtitle is stored in kodis cache directory but with weird filename, I can force it to load via the XySubFilter tray icon but I just assumed it would be seamless in the same way as local content already is.

Is this expected behaviour, a known issue or a new bug?
Reply
Hi,

@aracnoz and @ Warner306

Quote:D3D11 is used for presentation in madVR and this must be set from the madVR control panel under general settings. If you are not outputting at 10-bits, the result may be the same (although, entering and exiting fullscreen exclusive mode can be faster).

Thnaks to both of you for your response,I somehow missed it in MadVR ! I had set it and don't after the numerous installs and uninstalls when did this option slide by my attention.

Anyways after the DX11 things are bit better and Am able to see some differences in playback.Still some hiccups remain which I will try to sort !

Thanks for the help and also for this wonderful player !

Regards.
MOBO :AMD A68i-350
RAM:6GB DDR3
CPU : 1.6GHZ DUAL CORE
GPU : HD6310 (512MB Shared Memory)
Reply
(2015-10-06, 10:25)Razoola Wrote:
(2015-10-05, 17:11)aracnoz Wrote: there is a strange behavior with internal subtitles, in my case the problem come with madVR 0.89.6

with madVR 0.89.5 seems ok

can you pls try?

Using madVR 089.5 does not solve my subtitle problem, I think I am experiencing a different issue to others however as I have since noticed my issue only happens when streaming.

If am playing locally stored content with an external subtitle file (srt) in the same directory, subtitles work.

If am playing locally stored content with no external subtitle in the same directory, I can use the download option, an external subtitle is downloaded and works. The subtitle file is stored in the same directory as the content playing .

If am playing an external stream and I use the subtitle download option subtitles do not work. I can however see the subtitle is stored in kodis cache directory but with weird filename, I can force it to load via the XySubFilter tray icon but I just assumed it would be seamless in the same way as local content already is.

Is this expected behaviour, a known issue or a new bug?

can you pls provide a FullDebugLog
Reply
Can you give me a precise explanation down to earth, how V-Sync madVR? I raise this question because the statistics of rendering engines, I noticed that V-Sync works almost always a value of 16.68 ms - 41.71 ms frame interval Movie, V-Sync should not be a value 41.71 ms
I have a setting D3D11 Exclusive (10-bit) as settings in madVR, I ask, it is important to know these differences expressed in values ms V-Sync.
enlighten, thanks
Reply
I have a question of TV internal processing vs MadVR.

The new Samsung JS9500 series and LG OLED series have quite powerful internal processing, is it a match for MadVR or is MadVR just the clear winner by far?
Reply
(2015-10-06, 12:08)aracnoz Wrote:
(2015-10-06, 10:25)Razoola Wrote:
(2015-10-05, 17:11)aracnoz Wrote: there is a strange behavior with internal subtitles, in my case the problem come with madVR 0.89.6

with madVR 0.89.5 seems ok

can you pls try?

Using madVR 089.5 does not solve my subtitle problem, I think I am experiencing a different issue to others however as I have since noticed my issue only happens when streaming.

If am playing locally stored content with an external subtitle file (srt) in the same directory, subtitles work.

If am playing locally stored content with no external subtitle in the same directory, I can use the download option, an external subtitle is downloaded and works. The subtitle file is stored in the same directory as the content playing .

If am playing an external stream and I use the subtitle download option subtitles do not work. I can however see the subtitle is stored in kodis cache directory but with weird filename, I can force it to load via the XySubFilter tray icon but I just assumed it would be seamless in the same way as local content already is.

Is this expected behaviour, a known issue or a new bug?

can you pls provide a FullDebugLog

Sure, I have zipped up a log here.
Reply
(2015-10-06, 12:29)Razoola Wrote: Sure, I have zipped up a log here.

that's perfect, because you are using stremming contents ...

i think that i solved your issue

i also included some changes for internal filters to use lavfiters with http/https

so can you pls report if your problems with subs are solved and also if you are experiencing any improvements to play http stream contents

thx

http://www.mediafire.com/download/k2zk2d...am_sub.rar
Reply
(2015-09-25, 12:12)*Roma* Wrote:
(2015-09-25, 11:53)Bjur Wrote: Hi Roma the profile doesn't work. The error in madVR is:

expected some sort of "and" or "or" statement

Fixed: (checked on madVR v0.89.2)
Code:
if (filePath == "*rtsp:/*") or (fileExt == "tsbuffer") or (fileExt == "ts")  "MediaPortal PVR profile"
else if (srcWidth = 1920) or ((srcHeight > 720) and (srcHeight <= 1080)) "1080p"
else if (srcWidth = 1280) or ((srcHeight > 540) and (srcHeight <= 720)) "720p"
else if ((srcWidth <= 960) or (srcHeight <= 540)) "SD"

Hi Roma. I have a question I hope you can help with:

Regarding the statement above. Is it possible to separate it further to also have 720p and 1080i Mediaportal PVR Profiles?
Reply
And when you want to use Emby with DSplayer is it really necessary to install the Emby Server and setup medias or just the skin? I have got it working without on local stuff but haven't testet on network shares.
Reply
  •   
  • 1
  • 112
  • 113
  • 114(current)
  • 115
  • 116
  • 509
  •   
 
Thread Rating:
  • 47 Vote(s) - 4.43 Average



Logout Mark Read Team Forum Stats Members Help
Kodi DSPlayer – DirectShow Player for Windows4.4347